libcap: update to latest release 0.9.8. Partly closes 2989.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Fri, 22 Feb 2008 01:26:06 +0000 (01:26 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Fri, 22 Feb 2008 01:26:06 +0000 (01:26 +0000)
packages/libpcap/libpcap-0.9.6/.mtn2git_empty [deleted file]
packages/libpcap/libpcap-0.9.6/shared.patch [deleted file]
packages/libpcap/libpcap-0.9.8/.mtn2git_empty [new file with mode: 0644]
packages/libpcap/libpcap-0.9.8/shared.patch [new file with mode: 0644]
packages/libpcap/libpcap_0.9.6.bb [deleted file]
packages/libpcap/libpcap_0.9.8.bb [new file with mode: 0644]

diff --git a/packages/libpcap/libpcap-0.9.6/.mtn2git_empty b/packages/libpcap/libpcap-0.9.6/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/libpcap/libpcap-0.9.6/shared.patch b/packages/libpcap/libpcap-0.9.6/shared.patch
deleted file mode 100644 (file)
index 159389b..0000000
+++ /dev/null
@@ -1,119 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- libpcap-0.9.3/Makefile.in~shared
-+++ libpcap-0.9.3/Makefile.in
-@@ -37,6 +37,15 @@
- srcdir = @srcdir@
- VPATH = @srcdir@
-+# some defines for shared library compilation - FIXME, if not matching
-+MAJ=0.9
-+MIN=6
-+VERSION=$(MAJ).$(MIN)
-+LIBNAME=pcap
-+LIBRARY=lib$(LIBNAME).a
-+SOLIBRARY=lib$(LIBNAME).so
-+SHAREDLIB=$(SOLIBRARY).$(VERSION)
-+
- #
- # You shouldn't need to edit anything below.
- #
-@@ -50,6 +59,7 @@
- # Standard CFLAGS
- CFLAGS = $(CCOPT) $(INCLS) $(DEFS)
-+CFLAGS_SHARED = -shared -Wl,-soname,$(SOLIBRARY).$(MAJ)
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -70,6 +80,9 @@
- .c.o:
-       @rm -f $@
-       $(CC) $(CFLAGS) -c $(srcdir)/$*.c
-+%_pic.o: %.c
-+      @rm -f $@
-+      $(CC) -fPIC $(CFLAGS) -c -o $@ $(srcdir)/$*.c
- PSRC =        pcap-@V_PCAP@.c
- FSRC =  fad-@V_FINDALLDEVS@.c
-@@ -84,6 +97,7 @@
- # We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
- # hack the extra indirection
- OBJ = $(PSRC:.c=.o) $(FSRC:.c=.o) $(CSRC:.c=.o) $(SSRC:.c=.o) $(GENSRC:.c=.o) $(LIBOBJS)
-+OBJ_PIC = $(PSRC:.c=_pic.o) $(FSRC:.c=.o) $(CSRC:.c=_pic.o) $(GENSRC:.c=_pic.o)
- HDR = pcap.h pcap-int.h pcap-namedb.h pcap-nit.h pcap-pf.h \
-       ethertype.h gencode.h gnuc.h
- GENHDR = \
-@@ -95,15 +109,22 @@
- TAGFILES = \
-       $(SRC) $(HDR) $(TAGHDR)
--CLEANFILES = $(OBJ) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c
-+CLEANFILES = $(OBJ) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c libpcap.so*
--all: libpcap.a
-+all: libpcap.a $(SHAREDLIB)
- libpcap.a: $(OBJ)
-       @rm -f $@
-       ar rc $@ $(OBJ) $(LIBS)
-       $(RANLIB) $@
-+$(SHAREDLIB): $(OBJ_PIC)
-+      -@rm -f $@
-+      -@rm -f $(SOLIBRARY) $(SOLIBRARY).$(MAJ)
-+      $(CC) $(CFLAGS_SHARED) -o $(SHAREDLIB) $(OBJ_PIC) -lc
-+      ln -s $(SHAREDLIB) $(SOLIBRARY).$(MAJ)
-+      ln -s $(SOLIBRARY).$(MAJ) $(SOLIBRARY)
-+
- shared: libpcap.$(DYEXT)
- #
-@@ -129,6 +150,9 @@
- scanner.o: scanner.c tokdefs.h
-       $(CC) $(CFLAGS) -c scanner.c
-+scanner_pic.o: scanner.c tokdefs.h
-+      $(CC) -fPIC $(CFLAGS) -o $@ -c scanner.c
-+
- pcap.o: version.h
- tokdefs.h: grammar.c
-@@ -142,9 +166,16 @@
-       @rm -f $@
-       $(CC) $(CFLAGS) -Dyylval=pcap_lval -c grammar.c
-+grammer_pic.o: grammar.c
-+      @rm -f $@
-+      $(CC) -fPIC $(CFLAGS) -Dyylval=pcap_lval -o $@ -c grammar.c 
-+
- version.o: version.c
-       $(CC) $(CFLAGS) -c version.c
-+version_pic.o: version.c
-+      $(CC) -fPIC $(CFLAGS) -c version.c -o $@
-+
- snprintf.o: $(srcdir)/missing/snprintf.c
-       $(CC) $(CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c
-@@ -170,11 +201,17 @@
- bpf_filter.o: bpf_filter.c
-       $(CC) $(CFLAGS) -c bpf_filter.c
-+bpf_filter_pic.o: bpf_filter.c
-+      $(CC) -fPIC $(CFLAGS) -c bpf_filter.c -o $@
-+
- install: libpcap.a 
-       [ -d $(DESTDIR)$(libdir) ] || \
-           (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
-       $(INSTALL_DATA) libpcap.a $(DESTDIR)$(libdir)/libpcap.a
-       $(RANLIB) $(DESTDIR)$(libdir)/libpcap.a
-+      $(INSTALL_DATA) $(SHAREDLIB) $(DESTDIR)$(libdir)/
-+      ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/$(SOLIBRARY).$(MAJ)
-+      ln -sf $(SOLIBRARY).$(MAJ) $(DESTDIR)$(libdir)/$(SOLIBRARY)
-       [ -d $(DESTDIR)$(includedir) ] || \
-           (mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
-       $(INSTALL_DATA) $(srcdir)/pcap.h $(DESTDIR)$(includedir)/pcap.h
diff --git a/packages/libpcap/libpcap-0.9.8/.mtn2git_empty b/packages/libpcap/libpcap-0.9.8/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/libpcap/libpcap-0.9.8/shared.patch b/packages/libpcap/libpcap-0.9.8/shared.patch
new file mode 100644 (file)
index 0000000..159389b
--- /dev/null
@@ -0,0 +1,119 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libpcap-0.9.3/Makefile.in~shared
++++ libpcap-0.9.3/Makefile.in
+@@ -37,6 +37,15 @@
+ srcdir = @srcdir@
+ VPATH = @srcdir@
++# some defines for shared library compilation - FIXME, if not matching
++MAJ=0.9
++MIN=6
++VERSION=$(MAJ).$(MIN)
++LIBNAME=pcap
++LIBRARY=lib$(LIBNAME).a
++SOLIBRARY=lib$(LIBNAME).so
++SHAREDLIB=$(SOLIBRARY).$(VERSION)
++
+ #
+ # You shouldn't need to edit anything below.
+ #
+@@ -50,6 +59,7 @@
+ # Standard CFLAGS
+ CFLAGS = $(CCOPT) $(INCLS) $(DEFS)
++CFLAGS_SHARED = -shared -Wl,-soname,$(SOLIBRARY).$(MAJ)
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -70,6 +80,9 @@
+ .c.o:
+       @rm -f $@
+       $(CC) $(CFLAGS) -c $(srcdir)/$*.c
++%_pic.o: %.c
++      @rm -f $@
++      $(CC) -fPIC $(CFLAGS) -c -o $@ $(srcdir)/$*.c
+ PSRC =        pcap-@V_PCAP@.c
+ FSRC =  fad-@V_FINDALLDEVS@.c
+@@ -84,6 +97,7 @@
+ # We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
+ # hack the extra indirection
+ OBJ = $(PSRC:.c=.o) $(FSRC:.c=.o) $(CSRC:.c=.o) $(SSRC:.c=.o) $(GENSRC:.c=.o) $(LIBOBJS)
++OBJ_PIC = $(PSRC:.c=_pic.o) $(FSRC:.c=.o) $(CSRC:.c=_pic.o) $(GENSRC:.c=_pic.o)
+ HDR = pcap.h pcap-int.h pcap-namedb.h pcap-nit.h pcap-pf.h \
+       ethertype.h gencode.h gnuc.h
+ GENHDR = \
+@@ -95,15 +109,22 @@
+ TAGFILES = \
+       $(SRC) $(HDR) $(TAGHDR)
+-CLEANFILES = $(OBJ) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c
++CLEANFILES = $(OBJ) libpcap.a $(GENSRC) $(GENHDR) lex.yy.c libpcap.so*
+-all: libpcap.a
++all: libpcap.a $(SHAREDLIB)
+ libpcap.a: $(OBJ)
+       @rm -f $@
+       ar rc $@ $(OBJ) $(LIBS)
+       $(RANLIB) $@
++$(SHAREDLIB): $(OBJ_PIC)
++      -@rm -f $@
++      -@rm -f $(SOLIBRARY) $(SOLIBRARY).$(MAJ)
++      $(CC) $(CFLAGS_SHARED) -o $(SHAREDLIB) $(OBJ_PIC) -lc
++      ln -s $(SHAREDLIB) $(SOLIBRARY).$(MAJ)
++      ln -s $(SOLIBRARY).$(MAJ) $(SOLIBRARY)
++
+ shared: libpcap.$(DYEXT)
+ #
+@@ -129,6 +150,9 @@
+ scanner.o: scanner.c tokdefs.h
+       $(CC) $(CFLAGS) -c scanner.c
++scanner_pic.o: scanner.c tokdefs.h
++      $(CC) -fPIC $(CFLAGS) -o $@ -c scanner.c
++
+ pcap.o: version.h
+ tokdefs.h: grammar.c
+@@ -142,9 +166,16 @@
+       @rm -f $@
+       $(CC) $(CFLAGS) -Dyylval=pcap_lval -c grammar.c
++grammer_pic.o: grammar.c
++      @rm -f $@
++      $(CC) -fPIC $(CFLAGS) -Dyylval=pcap_lval -o $@ -c grammar.c 
++
+ version.o: version.c
+       $(CC) $(CFLAGS) -c version.c
++version_pic.o: version.c
++      $(CC) -fPIC $(CFLAGS) -c version.c -o $@
++
+ snprintf.o: $(srcdir)/missing/snprintf.c
+       $(CC) $(CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c
+@@ -170,11 +201,17 @@
+ bpf_filter.o: bpf_filter.c
+       $(CC) $(CFLAGS) -c bpf_filter.c
++bpf_filter_pic.o: bpf_filter.c
++      $(CC) -fPIC $(CFLAGS) -c bpf_filter.c -o $@
++
+ install: libpcap.a 
+       [ -d $(DESTDIR)$(libdir) ] || \
+           (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
+       $(INSTALL_DATA) libpcap.a $(DESTDIR)$(libdir)/libpcap.a
+       $(RANLIB) $(DESTDIR)$(libdir)/libpcap.a
++      $(INSTALL_DATA) $(SHAREDLIB) $(DESTDIR)$(libdir)/
++      ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/$(SOLIBRARY).$(MAJ)
++      ln -sf $(SOLIBRARY).$(MAJ) $(DESTDIR)$(libdir)/$(SOLIBRARY)
+       [ -d $(DESTDIR)$(includedir) ] || \
+           (mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
+       $(INSTALL_DATA) $(srcdir)/pcap.h $(DESTDIR)$(includedir)/pcap.h
diff --git a/packages/libpcap/libpcap_0.9.6.bb b/packages/libpcap/libpcap_0.9.6.bb
deleted file mode 100644 (file)
index 865e57a..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require libpcap.inc
-
-PR = "r2"
diff --git a/packages/libpcap/libpcap_0.9.8.bb b/packages/libpcap/libpcap_0.9.8.bb
new file mode 100644 (file)
index 0000000..865e57a
--- /dev/null
@@ -0,0 +1,3 @@
+require libpcap.inc
+
+PR = "r2"