libnsbmp: add recipe for version 0.0.1
authorDmitry Artamonow <mad_soft@inbox.ru>
Sat, 23 May 2009 10:35:16 +0000 (10:35 +0000)
committerTom Rini <trini@embeddedalley.com>
Sat, 30 May 2009 16:32:44 +0000 (12:32 -0400)
libnsbmp is BMP and ICO decoding library.
Currently only Netsurf browser is using it, so we build just static library.

Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru>
Acked-by: Tom Rini <trini@embeddedalley.com>
recipes/netsurf/libnsbmp_0.0.1.bb [new file with mode: 0644]

diff --git a/recipes/netsurf/libnsbmp_0.0.1.bb b/recipes/netsurf/libnsbmp_0.0.1.bb
new file mode 100644 (file)
index 0000000..a17cd31
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "Libnsbmp is a decoding library for the BMP and ICO image file formats"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsbmp/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsbmp-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+       oe_libinstall -a -C build-OE/ libnsbmp ${STAGING_LIBDIR}
+       install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+       oe_runmake install
+}