flashrom svn: new recipe
authorKalev Lember <kalev@smartlink.ee>
Sat, 25 Oct 2008 09:57:31 +0000 (12:57 +0300)
committerKalev Lember <kalev@smartlink.ee>
Sat, 25 Oct 2008 10:22:15 +0000 (13:22 +0300)
* add makefile patch to not strip executable during install, we do that while packaging

conf/distro/include/sane-srcrevs.inc
packages/flashrom/files/makefile-disable-strip.patch [new file with mode: 0644]
packages/flashrom/flashrom_svn.bb [new file with mode: 0644]

index 98da283..347a77d 100644 (file)
@@ -43,6 +43,7 @@ SRCREV_pn-ezxd ?= "2074"
 SRCREV_pn-elf2flt ?= "1786"
 SRCREV_pn-epiphany ?= "7837"
 SRCREV_pn-fbgrab-viewer-native ?= "1943"
+SRCREV_pn-flashrom ?= "3682"
 SRCREV_pn-frameworkd ?= "a816e0412c687bf8e59e3505cce877f02e51f84d"
 SRCREV_pn-fso-gpsd ?= "fd1cd578d6ba9fa13aadceb59a9b46345108583b"
 SRCREV_pn-fso-sounds ?= "b24d3c2e66fee10a5e288101cd1b6f5bbd3da7e2"
diff --git a/packages/flashrom/files/makefile-disable-strip.patch b/packages/flashrom/files/makefile-disable-strip.patch
new file mode 100644 (file)
index 0000000..0296e1d
--- /dev/null
@@ -0,0 +1,18 @@
+--- flashrom/Makefile.orig     2008-10-25 12:13:21.000000000 +0300
++++ flashrom/Makefile          2008-10-25 12:14:04.000000000 +0300
+@@ -17,7 +17,6 @@
+ LDFLAGS = -lpci -lz
+ else
+ LDFLAGS = -lpci -lz
+-STRIP_ARGS = -s
+ endif
+ ifeq ($(OS_ARCH), FreeBSD)
+ CFLAGS += -I/usr/local/include
+@@ -40,7 +39,6 @@
+ $(PROGRAM): $(OBJS)
+       $(CC) -o $(PROGRAM) $(OBJS) $(LDFLAGS)
+-      $(STRIP) $(STRIP_ARGS) $(PROGRAM)
+ flashrom.o: flashrom.c
+       $(CC) -c $(CFLAGS) $(SVNDEF) $(CPPFLAGS) $< -o $@
diff --git a/packages/flashrom/flashrom_svn.bb b/packages/flashrom/flashrom_svn.bb
new file mode 100644 (file)
index 0000000..0c51a58
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "Flashrom is a simple utility for reading/writing BIOS chips"
+HOMEPAGE = "http://www.coreboot.org/Flashrom"
+LICENSE = "GPL"
+DEPENDS = "zlib pciutils"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = " \
+       svn://coreboot.org/repos/trunk/util/;module=flashrom \
+       file://makefile-disable-strip.patch;patch=1 \
+       "
+
+S = "${WORKDIR}/${PN}"
+
+LDFLAGS += "-lpci -lz"
+
+do_install () {
+       install -d "${D}${sbindir}"
+       oe_runmake 'PREFIX=${D}/${prefix}' install
+}