ltp: Add 20090131 version
authorTom Rini <trini@embeddedalley.com>
Wed, 11 Feb 2009 18:53:48 +0000 (13:53 -0500)
committerTom Rini <trini@embeddedalley.com>
Wed, 11 Feb 2009 18:53:48 +0000 (13:53 -0500)
conf/checksums.ini
packages/ltp/ltp-20090131/cross-compile.patch [new file with mode: 0644]
packages/ltp/ltp-20090131/fix-tcore_patch_test_suites.patch [new file with mode: 0644]
packages/ltp/ltp-20090131/no-IDcheck.patch [new file with mode: 0644]
packages/ltp/ltp-20090131/no_epoll_create2_mips.patch [new file with mode: 0644]
packages/ltp/ltp-20090131/no_hyperthreading_tests.patch [new file with mode: 0644]
packages/ltp/ltp-20090131/runltp-path.patch [new file with mode: 0644]
packages/ltp/ltp_20090131.bb [new file with mode: 0644]

index d9d1eb2..41256a7 100644 (file)
@@ -14126,17 +14126,13 @@ sha256=898db51a4016efca7d408163578443238373773357949e1b4978e26807a1fb2b
 md5=afd35e0770f28121a9f8d6093d20a62b
 sha256=bfc8cf4258574b48d33e9d622627db496e6533a469a6a87fd7ed76098dabb8a6
 
-[http://heanet.dl.sourceforge.net/ltp/ltp-full-20070228.tgz]
-md5=afd35e0770f28121a9f8d6093d20a62b
-sha256=bfc8cf4258574b48d33e9d622627db496e6533a469a6a87fd7ed76098dabb8a6
-
 [http://downloads.sourceforge.net/ltp/ltp-full-20080229.tgz]
 md5=5860835de7e8d6f76a856243fd5f299e
 sha256=e4c56dbbbf2d1a4d641624234b561e9402c00e47b5b253ae126aa444182310a4
 
-[http://heanet.dl.sourceforge.net/ltp/ltp-full-20080229.tgz]
-md5=5860835de7e8d6f76a856243fd5f299e
-sha256=e4c56dbbbf2d1a4d641624234b561e9402c00e47b5b253ae126aa444182310a4
+[http://downloads.sourceforge.net/ltp/ltp-full-20090131.tgz]
+md5=397b376dd659459e4a431474b42263a8
+sha256=5fa4353d826b719cc313e370dd8f4ab0793432e4d797a96cb5bb01e078ff1e10
 
 [ftp://ftp.debian.org/debian/pool/main/l/ltrace/ltrace_0.4-1.diff.gz]
 md5=89c0ebdd0a27bc7f68726100f4bb079b
diff --git a/packages/ltp/ltp-20090131/cross-compile.patch b/packages/ltp/ltp-20090131/cross-compile.patch
new file mode 100644 (file)
index 0000000..b414b6f
--- /dev/null
@@ -0,0 +1,352 @@
+---
+ Makefile                                                              |    4 +++-
+ lib/Makefile                                                          |    3 ---
+ m4/GNUmakefile                                                        |    3 ---
+ pan/Makefile                                                          |    2 --
+ testcases/ballista/ballista/Makefile                                  |    2 +-
+ testcases/ballista/ballista/compile/Makefile                          |    8 ++++----
+ testcases/kernel/device-drivers/acpi/Makefile                         |    2 +-
+ testcases/kernel/device-drivers/agp/user_space/Makefile               |    6 +++---
+ testcases/kernel/device-drivers/base/user_base/Makefile               |    6 +++---
+ testcases/kernel/device-drivers/dev_sim_framework/user_space/Makefile |    6 +++---
+ testcases/kernel/device-drivers/drm/user_space/Makefile               |    2 +-
+ testcases/kernel/device-drivers/include/Makefile                      |    2 +-
+ testcases/kernel/device-drivers/nls/Makefile                          |    2 +-
+ testcases/kernel/device-drivers/pci/user_tpci/Makefile                |    6 +++---
+ testcases/kernel/device-drivers/tbio/user_space/Makefile              |    6 +++---
+ testcases/kernel/device-drivers/usb/user_usb/Makefile                 |    6 +++---
+ testcases/kernel/fs/fs-bench/Makefile                                 |    6 +++---
+ testcases/kernel/fs/scsi/ltpfs/Makefile                               |    2 +-
+ testcases/kernel/sched/hyperthreading/ht_affinity/Makefile            |    4 ++--
+ testcases/kernel/sched/hyperthreading/ht_enabled/Makefile             |    2 +-
+ testcases/kernel/sched/hyperthreading/ht_interrupt/Makefile           |    2 +-
+ 21 files changed, 38 insertions(+), 44 deletions(-)
+
+Index: ltp-full-20090131/Makefile
+===================================================================
+--- ltp-full-20090131.orig/Makefile
++++ ltp-full-20090131/Makefile
+@@ -5,14 +5,16 @@ CROSS_COMPILER = $(CROSS_COMPILE)
+ endif
+ ifdef CROSS_COMPILER
+ CC=$(CROSS_COMPILER)gcc
++CPP=$(CROSS_COMPILER)g++
+ AR=$(CROSS_COMPILER)ar
+ RANLIB=$(CROSS_COMPILER)ranlib
+ endif
++PREFIX=/opt/ltp
+ HAS_NUMA=$(shell sh tools/scripts/numa_test.sh)
+ export CFLAGS += -Wall $(CROSS_CFLAGS)
+-export CC AR RANLIB CPPFLAGS LDFLAGS HAS_NUMA
++export CC CPP AR RANLIB CPPFLAGS LDFLAGS HAS_NUMA
+ -include config.mk
+Index: ltp-full-20090131/testcases/ballista/ballista/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/ballista/ballista/Makefile
++++ ltp-full-20090131/testcases/ballista/ballista/Makefile
+@@ -24,7 +24,7 @@
+ ########################
+ # compiler info for the host
+-CC = g++ -Wno-deprecated
++CC = $(CPP) -Wno-deprecated
+ CFLAGS += -w ${TARGET_DEF}
+ CLIBS = -lpthread -ldl -lnsl -rdynamic
+ TEST_MAN_FILE = selfHost
+Index: ltp-full-20090131/testcases/ballista/ballista/compile/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/ballista/ballista/compile/Makefile
++++ ltp-full-20090131/testcases/ballista/ballista/compile/Makefile
+@@ -19,14 +19,14 @@ dFLAGS=-g -DDEBUG
+ FLAGS= -O -Wall
+ PFLAGS= -p -g3
+-CPPCOMP= g++
++CPPCOMP= $(CPP)
+ #
+ # The following is "boilerplate" to set up the standard compilation
+ # commands:
+ .SUFFIXES:
+ .SUFFIXES: .cpp .c .cc .h .o
+-.c.o:  ; gcc $(FLAGS) -c $*.c
++.c.o:  ; $(CC) $(FLAGS) -c $*.c
+ .cc.o:  ; $(CPPCOMP) $(FLAGS) -c $*.cc
+ .cpp.o:  ; $(CPPCOMP) $(FLAGS) $(INC) -c $*.cpp
+ .cxx.o:  ; $(CPPCOMP) $(FLAGS) $(INC) -c $*.cxx
+@@ -41,10 +41,10 @@ all: blexer bparser
+       chmod 700 ../templates/do_parse
+ blexer: jlist.o butil.o lex.yy.o blexer.o
+-      gcc $(FLAGS)  -o blexer jlist.o butil.o lex.yy.o blexer.o 
++      $(CC) $(FLAGS)  -o blexer jlist.o butil.o lex.yy.o blexer.o 
+ bparser: bparser.o 
+-      g++ $(FLAGS) -o bparser bparser.o butil.c
++      $(CPP) $(FLAGS) -o bparser bparser.o butil.c
+ jlist.o: jlist.c butil.h jlist.h
+Index: ltp-full-20090131/testcases/kernel/device-drivers/acpi/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/acpi/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/acpi/Makefile
+@@ -15,7 +15,7 @@ PWD  := $(shell pwd)
+ default:
+       $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+-      gcc  $(CFLAGS) -o LtpAcpiMain  LtpAcpiMain.c
++      $(CC)  $(CFLAGS) -o LtpAcpiMain  LtpAcpiMain.c
+ #     $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) modules
+ endif
+Index: ltp-full-20090131/testcases/kernel/device-drivers/agp/user_space/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/agp/user_space/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/agp/user_space/Makefile
+@@ -1,8 +1,8 @@
+ test_agp: tagp_ki.o user_tagp.o
+-      gcc tagp_ki.o user_tagp.o -o test_agp 
++      $(CC) tagp_ki.o user_tagp.o -o test_agp 
+ tagp_ki.o: tagp_ki.c
+-      gcc -c tagp_ki.c
++      $(CC) -c tagp_ki.c
+ user_tagp.o: user_tagp.c
+-      gcc -c user_tagp.c
++      $(CC) -c user_tagp.c
+Index: ltp-full-20090131/testcases/kernel/device-drivers/base/user_base/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/base/user_base/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/base/user_base/Makefile
+@@ -1,11 +1,11 @@
+ test_base: tbase_ki.o user_tbase.o
+-      gcc tbase_ki.o user_tbase.o -o test_base
++      $(CC) tbase_ki.o user_tbase.o -o test_base
+ tbase_ki.o: tbase_ki.c
+-      gcc -c tbase_ki.c
++      $(CC) -c tbase_ki.c
+ user_tbase.o: user_tbase.c
+-      gcc -c user_tbase.c
++      $(CC) -c user_tbase.c
+ clean: 
+        rm -f *.o 2>/dev/null || true
+Index: ltp-full-20090131/testcases/kernel/device-drivers/dev_sim_framework/user_space/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/dev_sim_framework/user_space/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/dev_sim_framework/user_space/Makefile
+@@ -1,8 +1,8 @@
+ test_mod: tmod_ki.o user_tmod.o
+-      gcc tmod_ki.o user_tmod.o -o test_mod
++      $(CC) tmod_ki.o user_tmod.o -o test_mod
+ tmod_ki.o: tmod_ki.c
+-      gcc -c tmod_ki.c
++      $(CC) -c tmod_ki.c
+ user_tmod.o: user_tmod.c
+-      gcc -c user_tmod.c
++      $(CC) -c user_tmod.c
+Index: ltp-full-20090131/testcases/kernel/device-drivers/drm/user_space/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/drm/user_space/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/drm/user_space/Makefile
+@@ -2,4 +2,4 @@
+       KDIR := /lib/modules/$(shell uname -r)/build
+       CFLAGS := -I$(KDIR)/drivers/char/drm
+ default:
+-      gcc -o test_drm  user_tdrm.c $(CFLAGS)
++      $(CC) -o test_drm  user_tdrm.c $(CFLAGS)
+Index: ltp-full-20090131/testcases/kernel/device-drivers/include/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/include/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/include/Makefile
+@@ -14,7 +14,7 @@ PWD  := $(shell pwd)
+ default:
+       $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+-      gcc -Wall -o userBlockInclude userBlockInclude.c
++      $(CC) -Wall -o userBlockInclude userBlockInclude.c
+ #     $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) modules
+ endif
+Index: ltp-full-20090131/testcases/kernel/device-drivers/nls/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/nls/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/nls/Makefile
+@@ -13,7 +13,7 @@ PWD  := $(shell pwd)
+ default:
+       $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+-      gcc $(EXTRA_CFLAGS) -o userBlockNLS userBlockNLS.c
++      $(CC) $(EXTRA_CFLAGS) -o userBlockNLS userBlockNLS.c
+ #     $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) modules
+ clean:
+Index: ltp-full-20090131/testcases/kernel/device-drivers/pci/user_tpci/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/pci/user_tpci/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/pci/user_tpci/Makefile
+@@ -1,8 +1,8 @@
+ test_pci: tpci_ki.o user_tpci.o
+-      gcc tpci_ki.o user_tpci.o -o test_pci
++      $(CC) tpci_ki.o user_tpci.o -o test_pci
+ tpci_ki.o: tpci_ki.c 
+-      gcc -c tpci_ki.c
++      $(CC) -c tpci_ki.c
+ user_tpci.o: user_tpci.c
+-      gcc -c user_tpci.c
++      $(CC) -c user_tpci.c
+Index: ltp-full-20090131/testcases/kernel/device-drivers/tbio/user_space/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/tbio/user_space/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/tbio/user_space/Makefile
+@@ -1,8 +1,8 @@
+ test_bio: tbio_ki.o user_tbio.o
+-      gcc -g tbio_ki.o user_tbio.o -o test_bio
++      $(CC) -g tbio_ki.o user_tbio.o -o test_bio
+ tbio_ki.o: tbio_ki.c
+-      gcc -c -g  tbio_ki.c
++      $(CC) -c -g  tbio_ki.c
+ user_tbio.o: user_tbio.c
+-      gcc -c -g user_tbio.c
++      $(CC) -c -g user_tbio.c
+Index: ltp-full-20090131/testcases/kernel/device-drivers/usb/user_usb/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/device-drivers/usb/user_usb/Makefile
++++ ltp-full-20090131/testcases/kernel/device-drivers/usb/user_usb/Makefile
+@@ -1,8 +1,8 @@
+ test_usb: tusb_ki.o user_tusb.o
+-      gcc tusb_ki.o user_tusb.o -o test_usb
++      $(CC) tusb_ki.o user_tusb.o -o test_usb
+ tusb_ki.o: tusb_ki.c 
+-      gcc -c tusb_ki.c
++      $(CC) -c tusb_ki.c
+ user_tusb.o: user_tusb.c
+-      gcc -c user_tusb.c
++      $(CC) -c user_tusb.c
+Index: ltp-full-20090131/testcases/kernel/fs/fs-bench/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/fs/fs-bench/Makefile
++++ ltp-full-20090131/testcases/kernel/fs/fs-bench/Makefile
+@@ -6,13 +6,13 @@ all: ${EXECS}
+       @echo done
+ cr: create-files.o ${UTILS}
+-      gcc ${UTILS} create-files.o -lm -o cr
++      $(CC) ${UTILS} create-files.o -lm -o cr
+ ra: random-access.o
+-      gcc random-access.o -o ra
++      $(CC) random-access.o -o ra
+ radc: random-del-create.o ${UTILS}
+-      gcc  ${UTILS} random-del-create.o -lm -o radc
++      $(CC)  ${UTILS} random-del-create.o -lm -o radc
+ install:
+        @set -e; for i in $(EXECS) $(SCRIPTS); do ln -f $$i ../../../bin/$$i ; done
+Index: ltp-full-20090131/testcases/kernel/fs/scsi/ltpfs/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/fs/scsi/ltpfs/Makefile
++++ ltp-full-20090131/testcases/kernel/fs/scsi/ltpfs/Makefile
+@@ -15,7 +15,7 @@ PWD  := $(shell pwd)
+ default:
+       $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+-      gcc  $(CFLAGS) -o ltpfstest -lm  main.c 
++      $(CC)  $(CFLAGS) -o ltpfstest -lm  main.c 
+ #     $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) modules
+ endif
+Index: ltp-full-20090131/testcases/kernel/sched/hyperthreading/ht_affinity/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/sched/hyperthreading/ht_affinity/Makefile
++++ ltp-full-20090131/testcases/kernel/sched/hyperthreading/ht_affinity/Makefile
+@@ -7,9 +7,9 @@ TARGETS   := ht_affinity
+ all: $(TARGETS)
+ #ht_affinity: HTaffinity.o HTutils.o
+-#     gcc -o ht_affinity HTaffinity.o HTutils.o $(CFLAGS) $(LOADLIBES)
++#     $(CC) -o ht_affinity HTaffinity.o HTutils.o $(CFLAGS) $(LOADLIBES)
+ ht_affinity:
+-      gcc -o ht_affinity HTaffinity.c HTutils.c $(CFLAGS) $(LOADLIBES)
++      $(CC) -o ht_affinity HTaffinity.c HTutils.c $(CFLAGS) $(LOADLIBES)
+ install:
+       @set -e; for i in $(TARGETS) ; do ln -f $$i ../../../../bin/$$i ; done
+Index: ltp-full-20090131/testcases/kernel/sched/hyperthreading/ht_enabled/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/sched/hyperthreading/ht_enabled/Makefile
++++ ltp-full-20090131/testcases/kernel/sched/hyperthreading/ht_enabled/Makefile
+@@ -7,7 +7,7 @@ TARGETS  := ht_enabled
+ all: $(TARGETS)
+ ht_enabled:
+-      gcc -o ht_enabled HTenabled.c HTutils.c $(CFLAGS) $(LOADLIBES)
++      $(CC) -o ht_enabled HTenabled.c HTutils.c $(CFLAGS) $(LOADLIBES)
+ install:
+       @set -e; for i in $(TARGETS) ; do ln -f $$i ../../../../bin/$$i ; done
+Index: ltp-full-20090131/testcases/kernel/sched/hyperthreading/ht_interrupt/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/sched/hyperthreading/ht_interrupt/Makefile
++++ ltp-full-20090131/testcases/kernel/sched/hyperthreading/ht_interrupt/Makefile
+@@ -7,7 +7,7 @@ TARGETS = ht_interrupt
+ all: $(TARGETS)
+ ht_interrupt:
+-      gcc -o ht_interrupt HTinterrupt.c HTutils.c $(CFLAGS) $(LOADLIBES) 
++      $(CC) -o ht_interrupt HTinterrupt.c HTutils.c $(CFLAGS) $(LOADLIBES) 
+ install:
+       @set -e; for i in $(TARGETS) ; do ln -f $$i ../../../../bin/$$i ; done
+Index: ltp-full-20090131/lib/Makefile
+===================================================================
+--- ltp-full-20090131.orig/lib/Makefile
++++ ltp-full-20090131/lib/Makefile
+@@ -1,6 +1,3 @@
+-
+-PREFIX=/opt/ltp
+-
+ CFLAGS+= -Wall
+ CFLAGS+= -D_USC_LIB_
+ CPPFLAGS+= -I../include 
+Index: ltp-full-20090131/m4/GNUmakefile
+===================================================================
+--- ltp-full-20090131.orig/m4/GNUmakefile
++++ ltp-full-20090131/m4/GNUmakefile
+@@ -1,6 +1,3 @@
+-
+-
+-PREFIX=/opt/ltp
+ M4MACROS=$(notdir $(wildcard *.m4))
+ all:
+Index: ltp-full-20090131/pan/Makefile
+===================================================================
+--- ltp-full-20090131.orig/pan/Makefile
++++ ltp-full-20090131/pan/Makefile
+@@ -1,8 +1,6 @@
+-
+ LOADLIBES += -lm
+ LFLAGS += -l -w
+ CFLAGS += -w 
+-PREFIX = /opt/ltp
+ all: pan bump scanner
diff --git a/packages/ltp/ltp-20090131/fix-tcore_patch_test_suites.patch b/packages/ltp/ltp-20090131/fix-tcore_patch_test_suites.patch
new file mode 100644 (file)
index 0000000..92a8879
--- /dev/null
@@ -0,0 +1,20 @@
+---
+ testcases/misc/tcore_patch_test_suites/tcore.c |    3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+Index: ltp-full-20090131/testcases/misc/tcore_patch_test_suites/tcore.c
+===================================================================
+--- ltp-full-20090131.orig/testcases/misc/tcore_patch_test_suites/tcore.c
++++ ltp-full-20090131/testcases/misc/tcore_patch_test_suites/tcore.c
+@@ -27,9 +27,10 @@ extern int  Tst_count;               /* 
+ extern char *TESTDIR;                /* temporary dir created by tst_tmpdir() */
+ /* Global Variables */
+ char *TCID     = "tcore";            /* test program identifier.              */
+-int  TST_TOTAL = 1;                  /* total number of tests in this file.   */
+ #if defined __i386__ || defined(__x86_64__)
++int  TST_TOTAL = 1;                  /* total number of tests in this file.   */
++
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <unistd.h>
diff --git a/packages/ltp/ltp-20090131/no-IDcheck.patch b/packages/ltp/ltp-20090131/no-IDcheck.patch
new file mode 100644 (file)
index 0000000..d437807
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ Makefile |    2 --
+ 1 file changed, 2 deletions(-)
+
+Index: ltp-full-20090131/Makefile
+===================================================================
+--- ltp-full-20090131.orig/Makefile
++++ ltp-full-20090131/Makefile
+@@ -37,8 +37,6 @@ install: all
+       @$(MAKE) -C doc/man1 install
+       @$(MAKE) -C doc/man3 install
+-      @./IDcheck.sh
+-
+ libltp.a: config.h
+       @$(MAKE) -C lib $@
diff --git a/packages/ltp/ltp-20090131/no_epoll_create2_mips.patch b/packages/ltp/ltp-20090131/no_epoll_create2_mips.patch
new file mode 100644 (file)
index 0000000..84ce8e4
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ testcases/kernel/syscalls/Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: ltp-full-20090131/testcases/kernel/syscalls/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/syscalls/Makefile
++++ ltp-full-20090131/testcases/kernel/syscalls/Makefile
+@@ -25,7 +25,7 @@ EXCLUDE_DIR=epoll
+ #
+ # Commented this out since there are directories here we don't want built by default
+ #
+-SUBDIR = `ls */Makefile | sed "s/Makefile//g"` 
++SUBDIR = `ls */Makefile | sed "s/Makefile//g | grep -vE "^epoll_create2""` 
+ UCLINUX_SUBDIR = `ls */Makefile | sed "s/Makefile//g" | grep -vE "^fork|epoll|capget|capset|chmod|chown|llseek|nftw|clone|profil|getcontext"`
+ all:
diff --git a/packages/ltp/ltp-20090131/no_hyperthreading_tests.patch b/packages/ltp/ltp-20090131/no_hyperthreading_tests.patch
new file mode 100644 (file)
index 0000000..6ef9635
--- /dev/null
@@ -0,0 +1,14 @@
+---
+ testcases/kernel/sched/Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: ltp-full-20090131/testcases/kernel/sched/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/sched/Makefile
++++ ltp-full-20090131/testcases/kernel/sched/Makefile
+@@ -1,4 +1,4 @@
+-SUBDIRS = cfs-scheduler clisrv hyperthreading nptl process_stress pthreads sched_stress tool 
++SUBDIRS = cfs-scheduler clisrv nptl process_stress pthreads sched_stress tool 
+ all:
+       @set -e; for i in $(SUBDIRS); do $(MAKE) -C $$i ; done
diff --git a/packages/ltp/ltp-20090131/runltp-path.patch b/packages/ltp/ltp-20090131/runltp-path.patch
new file mode 100644 (file)
index 0000000..607e019
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ runltp |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: ltp-full-20090131/runltp
+===================================================================
+--- ltp-full-20090131.orig/runltp
++++ ltp-full-20090131/runltp
+@@ -74,7 +74,7 @@ setup()
+         echo "FATAL: unable to change directory to $(dirname $0)"
+         exit 1
+     }
+-    export LTPROOT=${PWD}
++    export LTPROOT=/usr/libexec/ltp
+     export TMPBASE="/tmp"
+     export PATH="${PATH}:${LTPROOT}/testcases/bin"
diff --git a/packages/ltp/ltp_20090131.bb b/packages/ltp/ltp_20090131.bb
new file mode 100644 (file)
index 0000000..0e52ae3
--- /dev/null
@@ -0,0 +1,73 @@
+DESCRIPTION = "Linux Test Project"
+HOMEPAGE = "http://ltp.sourceforge.net"
+LICENSE = "GPL"
+SECTION = "console/utils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.tgz \
+           file://cross-compile.patch;patch=1 \
+           file://runltp-path.patch;patch=1 \
+           file://fix-tcore_patch_test_suites.patch;patch=1 \
+           file://no-IDcheck.patch;patch=1 \
+           file://no_hyperthreading_tests.patch;patch=1"
+
+SRC_URI_append_mips += "file://no_epoll_create2_mips.patch;patch=1"
+SRC_URI_append_mipsel += "file://no_epoll_create2_mips.patch;patch=1"
+
+S = "${WORKDIR}/ltp-full-${PV}"
+
+EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
+
+FILES_${PN}-dbg =  "${libexecdir}/ltp/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/trigo/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/iperb/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/exp_log/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/power/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/bessel/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/abs/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/atof/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/nextafter/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/fptests/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/f00f/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/crash/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/pan/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/ipv6/*/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/rpc/rpc01/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/bin/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/syscalls/*/.debug"
+#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/mem/*/.debug"
+
+do_compile(){
+        oe_runmake CROSS_COMPILE=${HOST_PREFIX}
+}
+
+do_install(){
+        export CREATE=0
+        export LTPROOT=${D}/usr/libexec/ltp/testcases
+
+        oe_runmake DESTDIR=${D} PREFIX=/usr/libexec/ltp install
+
+        install -d ${D}/usr/libexec/ltp/testcases
+        install -d ${D}/usr/libexec/ltp/pan
+
+        #install testcases 
+        #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/testcases
+        #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/
+        
+        # treecopy testcases pan/pan runtest ver_linux IDcheck.sh \
+        # ${D}/usr/libexec/ltp
+        cp testcases    ${D}/usr/libexec/ltp/ -rfp
+        rm              ${D}/usr/libexec/ltp/testcases/ballista -rf
+        cp pan/pan      ${D}/usr/libexec/ltp/pan -p
+        cp runtest      ${D}/usr/libexec/ltp/ -rfp
+        cp ver_linux    ${D}/usr/libexec/ltp/ -p
+        cp runltp       ${D}/usr/libexec/ltp/ -p
+        cp IDcheck.sh   ${D}/usr/libexec/ltp/ -p
+
+       # We don't want "devel" stuff
+       rm -rf ${D}/opt/ltp/include
+       rm ${D}/usr/libexec/ltp/share/pkgconfig/ltp.pc
+}