qte/qtopia-core: factor out qte_arch function into qte-functions.inc, use this from...
authorMichael Lauer <mickey@vanille-media.de>
Fri, 20 Oct 2006 12:14:06 +0000 (12:14 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Fri, 20 Oct 2006 12:14:06 +0000 (12:14 +0000)
packages/qte/qte-common_2.3.10.inc
packages/qte/qte-functions.inc [new file with mode: 0644]
packages/qte/qtopia-core_4.2.0.bb

index 3ea3c0d..b8ed16c 100644 (file)
@@ -69,17 +69,7 @@ SRC_URI_append_h1910        = "file://ipaq-keyboard.patch;patch=1 file://ipaq_so
 S = "${WORKDIR}/qt-${PV}"
 export QTDIR = "${S}"
 
-def qte_arch(d):
-       import bb, re
-       arch = bb.data.getVar('TARGET_ARCH', d, 1)
-       if re.match("^i.86$", arch):
-               arch = "x86"
-       elif arch == "x86_64":
-               arch = "x86"
-       elif arch == "mipsel":
-               arch = "mips"
-       return arch
-
+require qte-functions.inc
 QTE_ARCH := "${@qte_arch(d)}"
 
 #
diff --git a/packages/qte/qte-functions.inc b/packages/qte/qte-functions.inc
new file mode 100644 (file)
index 0000000..f0ffb0e
--- /dev/null
@@ -0,0 +1,11 @@
+def qte_arch(d):
+        import bb, re
+        arch = bb.data.getVar('TARGET_ARCH', d, 1)
+        if re.match("^i.86$", arch):
+                arch = "x86"
+        elif arch == "x86_64":
+                arch = "x86"
+        elif arch == "mipsel":
+                arch = "mips"
+        return arch
+
index 2f937c5..ecb5978 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "GPL"
 PRIORITY = "optional"
 HOMEPAGE = "http://www.trolltech.com"
 DEPENDS = "glib-2.0 dbus-glib tslib"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
            file://linux-oe-qmake.conf"
@@ -55,11 +55,10 @@ export OE_QMAKE_LIBDIR_QT="${QTDIR}/lib"
 export OE_QMAKE_INCDIR_QTOPIA="${QTOPIADIR}/include"
 export OE_QMAKE_LIBDIR_QTOPIA="${QTOPIADIR}/lib"
 
+require qte-functions.inc
+QT_ARCH := "${@qte_arch(d)}"
 
-# FIXME
-# We should have architecture detection here and translate it to the correct
-# Qtopia -embedded switch
-QT_ARCH = "arm"
+# FIXME use info.bbclass once it has been commited
 QT_ENDIAN = "-little-endian"
 
 # We don't build the examples and demos atm. They're quite big and not used
@@ -70,7 +69,6 @@ QT_CONFIG_FLAGS = "-release \
        -nomake demos -nomake examples -nomake tools \
        -qt-mouse-tslib"
 
-
 # We might want to package all the libraries separately, so you can really
 # fine-tune what to install. This is e.g. done in qt4-x11-free_4.1.2.bb.
 # What should these packages be called? I'm tempted to call them the same