libgles-omap3: add comments on how to get the gles binary files to help
authorCarsten Haitzler (Raster) <raster@rasterman.com>
Thu, 19 Feb 2009 10:58:20 +0000 (21:58 +1100)
committerKoen Kooi <koen@openembedded.org>
Thu, 19 Feb 2009 13:36:26 +0000 (14:36 +0100)
people get started faster

Signed-off-by: Koen Kooi <koen@openembedded.org>
conf/distro/include/sane-srcrevs.inc
packages/efl1/ecore.inc
packages/mtd/mtd-utils-native_1.2.0+git.bb
packages/powervr-drivers/libgles-omap3.inc
packages/qte/qte-mt-static_2.3.10.bb [deleted file]
packages/qte/qte-mt_2.3.10.bb [deleted file]
packages/qte/qte_2.3.10.bb [deleted file]

index f241d7c..bd1a76b 100644 (file)
@@ -246,7 +246,7 @@ SRCREV_pn-zhone ?= "f38cc52fbf11f7fe945797a6b8ade29ed479d924"
 # Enlightenment Foundation Libraries
 # Caution: This is not alphabetically, but (roughly) dependency-sorted.
 # Please leave it like that.
-EFL_SRCREV ?= "38544"
+EFL_SRCREV ?= "38853"
 SRCREV_pn-edb-native ?= "${EFL_SRCREV}"
 SRCREV_pn-edb ?= "${EFL_SRCREV}"
 SRCREV_pn-eina-native ?= "${EFL_SRCREV}"
index 653fb18..27dd10d 100644 (file)
@@ -8,7 +8,7 @@ PR = "r1"
 
 inherit efl
 
-SRC_URI += "file://fix-directfb-include.patch;patch=1"
+#SRC_URI += "file://fix-directfb-include.patch;patch=1"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ecore"
 
index 6135d7f..5fa3bbb 100644 (file)
@@ -1,5 +1,5 @@
 # Doesn't build for everyone, errors range from missing includes to linking errors
-DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE = "1"
 
 require mtd-utils_${PV}.bb
 require mtd-utils-native.inc
index 36c2b6e..c960903 100644 (file)
@@ -3,7 +3,20 @@ LICENCE = "proprietary-binary"
 
 PROVIDES += "virtual/egl"
 
-# Put "OMAP35x_Graphics_SDK_setuplinux_3_00_00_05.bin" in the same directory as this recipe
+# some hints to get you going. as this isnt a totally "open" library, you need
+# to do some work. follow the steps below.
+#
+# 1. if you don't already have a ti account get one here. it's free:
+#  http://www.ti.com/hdr_my_ti
+# 2. fetch the gl-es bin from here:
+#  https://www-a.ti.com/downloads/sds_support/targetcontent/dvsdk/oslinux_dvsdk/v3_00_3530/OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin
+# (replace version in .bin file as appropriate)
+# 3. put the OMAP35x_*.bin file in libgles-omap3/
+#  mv OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin ./libgles-omap3/
+# 4. make it executable:
+#  chmod a+x ./libgles-omap3/OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin
+# 
+# voila!
 SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
            file://rc.pvr \
           "
diff --git a/packages/qte/qte-mt-static_2.3.10.bb b/packages/qte/qte-mt-static_2.3.10.bb
deleted file mode 100644 (file)
index 68ab2ac..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-require qte-common_${PV}.inc
-PR = "r8"
-
-DEFAULT_PREFERENCE = "-1"
-
-EXTRA_OECONF += "-static -thread"
-
-do_stage() {
-       rm -rf ${STAGING_DIR_HOST}/qt2
-       install -d ${STAGING_DIR_HOST}/qt2/lib
-       oe_libinstall -a -C lib libqte-mt ${STAGING_DIR_HOST}/qt2/lib
-       rm -f include/qxt.h
-       install -d ${STAGING_DIR_HOST}/qt2/include
-       cp -pfLR include/* ${STAGING_DIR_HOST}/qt2/include
-       cp -pPR lib/fonts ${STAGING_DIR_HOST}/qt2/lib/
-}
-
-do_install() {
-       :
-}
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/packages/qte/qte-mt_2.3.10.bb b/packages/qte/qte-mt_2.3.10.bb
deleted file mode 100644 (file)
index 32afeda..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-require qte-common_${PV}.inc
-PR = "r27"
-
-EXTRA_OECONF += "-thread"
-
-DEFAULT_PREFERENCE = "1"
diff --git a/packages/qte/qte_2.3.10.bb b/packages/qte/qte_2.3.10.bb
deleted file mode 100644 (file)
index 68825b6..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require qte-common_${PV}.inc
-PR = "r52"
-