freetype: Added release 2.3.0, but with DEFAULT_PREFERENCE -1, needs testing.
authorLeon Woestenberg <leon.woestenberg@gmail.com>
Thu, 18 Jan 2007 23:20:04 +0000 (23:20 +0000)
committerLeon Woestenberg <leon.woestenberg@gmail.com>
Thu, 18 Jan 2007 23:20:04 +0000 (23:20 +0000)
packages/freetype/freetype-2.3.0/.mtn2git_empty [new file with mode: 0644]
packages/freetype/freetype-2.3.0/configure.patch [new file with mode: 0644]
packages/freetype/freetype-2.3.0/no-hardcode.patch [new file with mode: 0644]
packages/freetype/freetype_2.3.0.bb [new file with mode: 0644]

diff --git a/packages/freetype/freetype-2.3.0/.mtn2git_empty b/packages/freetype/freetype-2.3.0/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/freetype/freetype-2.3.0/configure.patch b/packages/freetype/freetype-2.3.0/configure.patch
new file mode 100644 (file)
index 0000000..7c2035d
--- /dev/null
@@ -0,0 +1,43 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: freetype-2.3.0/builds/unix/configure.ac
+===================================================================
+--- freetype-2.3.0.orig/builds/unix/configure.ac       2007-01-17 12:51:51.000000000 +0100
++++ freetype-2.3.0/builds/unix/configure.ac    2007-01-19 00:10:00.000000000 +0100
+@@ -159,7 +159,7 @@
+ # don't quote AS_HELP_STRING!
+ AC_ARG_WITH([zlib],
+-  AS_HELP_STRING([--without-zlib],
++  AC_HELP_STRING([--without-zlib],
+                  [use internal zlib instead of system-wide]))
+ if test x$with_zlib != xno && test -z "$LIBZ"; then
+   AC_CHECK_LIB([z], [gzsetparams], [AC_CHECK_HEADER([zlib.h], [LIBZ='-lz'])])
+@@ -175,7 +175,7 @@
+ # don't quote AS_HELP_STRING!
+ AC_ARG_WITH([old-mac-fonts],
+-  AS_HELP_STRING([--with-old-mac-fonts],
++  AC_HELP_STRING([--with-old-mac-fonts],
+                  [allow Mac resource-based fonts to be used]))
+ if test x$with_old_mac_fonts = xyes; then
+   orig_LDFLAGS="${LDFLAGS}"
+Index: freetype-2.3.0/builds/unix/unix-cc.in
+===================================================================
+--- freetype-2.3.0.orig/builds/unix/unix-cc.in 2006-10-15 10:57:22.000000000 +0200
++++ freetype-2.3.0/builds/unix/unix-cc.in      2007-01-19 00:10:53.000000000 +0100
+@@ -14,8 +14,10 @@
+ CC           := @CC@
+ COMPILER_SEP := $(SEP)
++SHELL        := @SHELL@
++top_builddir := $(BUILD_DIR)
+-LIBTOOL ?= $(BUILD_DIR)/libtool
++LIBTOOL := @LIBTOOL@
+ # The object file extension (for standard and static libraries).  This can be
diff --git a/packages/freetype/freetype-2.3.0/no-hardcode.patch b/packages/freetype/freetype-2.3.0/no-hardcode.patch
new file mode 100644 (file)
index 0000000..6528975
--- /dev/null
@@ -0,0 +1,11 @@
+--- freetype-2.2.1/builds/unix/freetype-config.in.orig 2006-07-10 10:51:47.000000000 +0100
++++ freetype-2.2.1/builds/unix/freetype-config.in      2006-07-10 10:52:27.000000000 +0100
+@@ -16,7 +16,7 @@
+ libdir=@libdir@
+ enable_shared=@enable_shared@
+ wl=@wl@
+-hardcode_libdir_flag_spec='@hardcode_libdir_flag_spec@'
++hardcode_libdir_flag_spec=''
+ usage()
+ {
diff --git a/packages/freetype/freetype_2.3.0.bb b/packages/freetype/freetype_2.3.0.bb
new file mode 100644 (file)
index 0000000..3c57448
--- /dev/null
@@ -0,0 +1,38 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+          file://configure.patch;patch=1 \
+           file://no-hardcode.patch;patch=1"
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+DEFAULT_PREFERENCE = "-1"
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+       cd builds/unix
+       gnu-configize
+       aclocal -I .
+       autoconf
+       cd ${S}
+       oe_runconf
+}
+
+do_compile_prepend() {
+       ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+do_stage() {
+       autotools_stage_includes
+       oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"