perl: Another sh3/sh4 shared library fix. Modules build built with
authorJamie Lenehan <lenehan@twibble.org>
Tue, 3 Oct 2006 20:53:58 +0000 (20:53 +0000)
committerJamie Lenehan <lenehan@twibble.org>
Tue, 3 Oct 2006 20:53:58 +0000 (20:53 +0000)
cpan.bbclass were being linked using ld instead of gcc, which often
breaks on sh. Override the LD settings so any cpan modules that
compile c/c++ code use gcc to link. Bump the PR on the effected
modules.

classes/cpan.bbclass
packages/perl/libcompress-zlib-perl_1.42.bb
packages/perl/libdigest-sha1-perl_2.11.bb
packages/perl/libipc-sharelite-perl_0.09.bb
packages/perl/liblocale-gettext-perl_1.05.bb
packages/perl/libparams-validate-perl_0.86.bb

index 0b90e75..f883867 100644 (file)
@@ -17,7 +17,12 @@ cpan_do_configure () {
 }
 
 cpan_do_compile () {
-        oe_runmake PASTHRU_INC="${CFLAGS}" CCFLAGS="${CFLAGS}"
+       # You must use gcc to link on sh
+       OPTIONS=""
+       if test ${TARGET_ARCH} = "sh3" -o ${TARGET_ARCH} = "sh4"; then
+               OPTIONS="LD=${TARGET_ARCH}-${TARGET_OS}-gcc"
+       fi
+        oe_runmake PASTHRU_INC="${CFLAGS}" CCFLAGS="${CFLAGS}" $OPTIONS
 }
 
 cpan_do_install () {
index dfbfdb5..0c8dd3c 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Compress::Zlib - Interface to zlib compression library"
 SECTION = "libs"
 MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
 LICENSE = "Artistic|GPL"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PM/PMQS/Compress-Zlib-1.42.tar.gz"
 
index 9d40110..ea79dc4 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Digest::SHA1 - Perl interface to the SHA-1 algorithm"
 SECTION = "libs"
 MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
 LICENSE = "Artistic|GPL"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Digest-SHA1-2.11.tar.gz"
 
index 3980842..75f4533 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "IPC::ShareLite - Light-weight interface to shared memory"
 SECTION = "libs"
 MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
 LICENSE = "Artistic|GPL"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MAURICE/IPC-ShareLite-0.09.tar.gz"
 
index 0f98e9b..c26755d 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "libs"
 MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
 LICENSE = "Artistic|GPL"
 DEPENDS = "virtual/libintl"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PV/PVANDRY/gettext-1.05.tar.gz"
 
index 55bbe54..30ba19f 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Params::Validate - Validate method/function parameters"
 SECTION = "libs"
 MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
 LICENSE = "Artistic|GPL"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Params-Validate-0.86.tar.gz"