lighttpd: fix init script (restart did not work)
authorJeremy Laine <jeremy.laine@m4x.org>
Wed, 11 Jun 2008 14:58:17 +0000 (14:58 +0000)
committerJeremy Laine <jeremy.laine@m4x.org>
Wed, 11 Jun 2008 14:58:17 +0000 (14:58 +0000)
packages/lighttpd/lighttpd/lighttpd
packages/lighttpd/lighttpd_1.4.18.bb

index 5723814..bf89a60 100644 (file)
@@ -1,16 +1,15 @@
 #!/bin/sh
-#
 
-PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
 DAEMON=/usr/sbin/lighttpd
 NAME=lighttpd
 DESC="Lighttpd Web Server"
-
+OPTS="-f /etc/lighttpd.conf"
 
 case "$1" in
   start)
        echo -n "Starting $DESC: "
-       start-stop-daemon --start -x "$DAEMON" --  -f /etc/lighttpd.conf
+       start-stop-daemon --start -x "$DAEMON" -- $OPTS
        echo "$NAME."
        ;;
   stop)
@@ -20,9 +19,9 @@ case "$1" in
        ;;
   restart|force-reload)
        echo -n "Restarting $DESC: "
-       start-stop-daemon -K -x "$DAEMON"
+       start-stop-daemon --stop -x "$DAEMON"
        sleep 1
-       start-stop-daemon -S -x "$DAEMON"
+       start-stop-daemon --start -x "$DAEMON" -- $OPTS
        echo "$NAME."
        ;;
   *)
index a83efca..4a27c62 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Web server"
 SECTION = "net"
 LICENSE = "BSD"
 DEPENDS = "libpcre"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.lighttpd.net/download/lighttpd-${PV}.tar.gz \
           file://configure.in.patch;patch=1 \