gcc-cross-initial: add 4.1.2
authorKoen Kooi <koen@openembedded.org>
Thu, 31 May 2007 12:05:11 +0000 (12:05 +0000)
committerKoen Kooi <koen@openembedded.org>
Thu, 31 May 2007 12:05:11 +0000 (12:05 +0000)
packages/gcc/gcc-cross-initial_4.1.2.bb [new file with mode: 0644]

diff --git a/packages/gcc/gcc-cross-initial_4.1.2.bb b/packages/gcc/gcc-cross-initial_4.1.2.bb
new file mode 100644 (file)
index 0000000..1e23ef9
--- /dev/null
@@ -0,0 +1,30 @@
+require gcc-cross_${PV}.bb
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils"
+DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel']]}"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
+PACKAGES = ""
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
+               --with-newlib \
+               --disable-shared \
+               --disable-threads \
+               --disable-multilib \
+               --disable-__cxa_atexit \
+               --disable-libmudflap \
+               --disable-libssp \
+               --enable-languages=c \
+               --enable-target-optspace \
+               --program-prefix=${TARGET_PREFIX} \
+               ${@get_gcc_fpu_setting(bb, d)}"
+
+do_stage_prepend () {
+       mkdir -p ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}
+       ln -sf libgcc.a ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/libgcc_eh.a
+}
+
+# Override the method from gcc-cross so we don't try to install libgcc
+do_install () {
+       oe_runmake 'DESTDIR=${D}' install
+}