fakeroot: bump to 1.9.6
authorJunqian Gordon Xu <xjqian@gmail.com>
Sat, 20 Sep 2008 09:07:47 +0000 (09:07 +0000)
committerJunqian Gordon Xu <xjqian@gmail.com>
Sat, 20 Sep 2008 09:07:47 +0000 (09:07 +0000)
packages/fakeroot/fakeroot-native_1.9.5.bb [deleted file]
packages/fakeroot/fakeroot-native_1.9.6.bb [new file with mode: 0644]
packages/fakeroot/fakeroot_1.9.5.bb [deleted file]
packages/fakeroot/fakeroot_1.9.6.bb [new file with mode: 0644]

diff --git a/packages/fakeroot/fakeroot-native_1.9.5.bb b/packages/fakeroot/fakeroot-native_1.9.5.bb
deleted file mode 100644 (file)
index 77d6f58..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-require fakeroot_${PV}.bb
-
-RDEPENDS="util-linux-native"
-
-SRC_URI += "file://fix-prefix.patch;patch=1 "
-S = "${WORKDIR}/fakeroot-${PV}"
-
-inherit native
-
-EXTRA_OECONF = " --program-prefix="
-
-# Compatability for the rare systems not using or having SYSV
-python () {
-    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
-        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
-}
-
-do_stage_append () {
-    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
-}
-
diff --git a/packages/fakeroot/fakeroot-native_1.9.6.bb b/packages/fakeroot/fakeroot-native_1.9.6.bb
new file mode 100644 (file)
index 0000000..77d6f58
--- /dev/null
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
diff --git a/packages/fakeroot/fakeroot_1.9.5.bb b/packages/fakeroot/fakeroot_1.9.5.bb
deleted file mode 100644 (file)
index aaf696d..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Gives a fake root environment"
-HOMEPAGE = "http://fakeroot.alioth.debian.org/"
-SECTION = "base"
-LICENSE = "GPL"
-# fakeroot needs getopt which is provided by the util-linux package
-RDEPENDS = "util-linux"
-PR = "r1"
-
-SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
-           file://configure-libtool.patch;patch=1"
-           
-inherit autotools
-
-do_stage() {
-        install -d ${STAGING_INCDIR}/fakeroot
-        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
-        autotools_stage_all
-}
diff --git a/packages/fakeroot/fakeroot_1.9.6.bb b/packages/fakeroot/fakeroot_1.9.6.bb
new file mode 100644 (file)
index 0000000..aaf696d
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+           file://configure-libtool.patch;patch=1"
+           
+inherit autotools
+
+do_stage() {
+        install -d ${STAGING_INCDIR}/fakeroot
+        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+        autotools_stage_all
+}