espgs: build with support for gutenprint, gimpprint and cups. ijs still disabled...
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sun, 3 Aug 2008 00:40:30 +0000 (00:40 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sun, 3 Aug 2008 00:40:30 +0000 (00:40 +0000)
packages/espgs/espgs_8.15.3.bb

index 50f2ca2..13cfad6 100644 (file)
@@ -2,31 +2,21 @@ DESCRIPTION = "ESP Ghostscript is an up-to-date GNU Ghostscript distribution \
 including bug fixes, new drivers, and additional support for CUPS."
 HOMEPAGE = "http://www.cups.org/espgs/"
 SECTION = "libs"
-DEPENDS = "jpeg zlib libpng fontconfig"
+DEPENDS = "jpeg zlib libpng tiff fontconfig"
 LICENSE = "GPL"
+PR = "r1"
 
 SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/ghostscript/${PV}/espgs-${PV}-source.tar.bz2"
-S = "${WORKDIR}/espgs-${PV}"
 
 PARALLEL_MAKE = ""
 
 inherit autotools
 
-PACKAGES += "espgs-examples espgs-resources"
-
-# I added the lib dir to the central package, since espgs complained of a missing file when run.
-# If I find exactly which files are needed for operation, I'll just add those, and split the package.
-
-FILES_${PN} += "${datadir}/ghostscript/8.15/lib/*"
-FILES_${PN}-doc += "${datadir}/ghostscript/8.15/doc/*"
-FILES_${PN}-examples += "${datadir}/ghostscript/8.15/examples/*"
-FILES_${PN}-resources += "${datadir}/ghostscript/8.15/Resource/*"
-
-EXTRA_OECONF = "--with-drivers= \
-               --disable-cups \
-               --disable-gtk \
+EXTRA_OECONF = "--with-drivers=ALL \
+               --enable-cups \
                --without-ijs \
-               --without-gimp-print \
+               --disable-gtk \
+               --without-gimp-print \
                --without-x \
                --without-omni"
 
@@ -34,12 +24,32 @@ do_compile() {
        oe_runmake CCAUX="${BUILD_CC}"
 }
 
+
 do_install () {
        oe_runmake 'prefix=${D}${prefix}' \
                   'bindir=${D}${bindir}' \
                   'datadir=${D}${datadir}' \
+                  'cups_datadir=${D}${datadir}/cups' \
+                  'cups_serverroot=${D}${sysconfdir}/cups' \
+                  'cups_serverbin= ${D}${libdir}/cups' \
+                  'CUPSSERVER=${cups_serverbin}' \
+                  'CUPSCONFIG=${cups_serverroot}' \
+                  'CUPSDATA=${cups_datadir}' \
+                   'sysconfdir=${D}${sysconfdir}' \
                   'gsdir=${D}${datadir}/ghostscript' \
                   'gsdatadir=${D}${datadir}/ghostscript/8.15' \        
                    'mandir=${D}${mandir}' \
-                   'docdir=${D}${datadir}/doc/espgs/' install                             
+                   'docdir=${D}${datadir}/doc/espgs/' install                                     
 }
+
+PACKAGES += "espgs-examples espgs-resources"
+
+# I added the lib dir to the central package, since espgs complained of a missing file when run.
+# If I find exactly which files are needed for operation, I'll just add those, and split the package.
+
+FILES_${PN} += "${datadir}/ghostscript/8.15/lib/* \
+               ${libdir}/cups/filter/* \
+               ${datadir}/cups/model/* \"
+FILES_${PN}-doc += "${datadir}/ghostscript/8.15/doc/*"
+FILES_${PN}-examples += "${datadir}/ghostscript/8.15/examples/*"
+FILES_${PN}-resources += "${datadir}/ghostscript/8.15/Resource/*"