gnome.bbclass : add name=archive to SRC_URI so .bb files can use new checksums
authorGraeme Gregory <dp@xora.org.uk>
Fri, 22 Jan 2010 19:23:23 +0000 (19:23 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Tue, 26 Jan 2010 21:21:31 +0000 (21:21 +0000)
New checksums system needs a name= in the SRC_URI name, so add a default
one for gnome.

classes/gnome.bbclass

index cb03650..61da6e1 100644 (file)
@@ -4,7 +4,7 @@ def gnome_verdir(v):
        return "%s.%s" % (m.group(1), m.group(2))
 
 SECTION ?= "x11/gnome"
-SRC_URI = "${GNOME_MIRROR}/${PN}/${@gnome_verdir("${PV}")}/${PN}-${PV}.tar.bz2"
+SRC_URI = "${GNOME_MIRROR}/${PN}/${@gnome_verdir("${PV}")}/${PN}-${PV}.tar.bz2;name=archive"
 
 DEPENDS += "gnome-common"