opie-sheet: fix compilation failure due to two function arguments with
authorMichal Hrusecky <Michal@Hrusecky.net>
Sat, 30 May 2009 13:08:14 +0000 (14:08 +0100)
committerPaul Eggleton <bluelightning@bluelightning.org>
Sat, 30 May 2009 13:08:14 +0000 (14:08 +0100)
the same name.

Signed-off-by: Michal Hrusecky <Michal@Hrusecky.net>
recipes/opie-sheet/opie-sheet/different-arg-names.patch [new file with mode: 0644]
recipes/opie-sheet/opie-sheet_1.2.4.bb

diff --git a/recipes/opie-sheet/opie-sheet/different-arg-names.patch b/recipes/opie-sheet/opie-sheet/different-arg-names.patch
new file mode 100644 (file)
index 0000000..a86aa9e
--- /dev/null
@@ -0,0 +1,11 @@
+--- opie-sheet/sheet.h       2009-05-25 07:47:12.042719009 +0200
++++ opie-sheet/sheet.h       2009-05-25 08:07:19.291516199 +0200
+@@ -209,7 +207,7 @@
+     void insertRows(int no=1, bool allColumns=TRUE);
+     void insertColumns(int no=1, bool allRows=TRUE);
+-    void dataFindReplace(const QString &find, const QString &replace, bool matchCase=TRUE, bool allCells=TRUE, bool entireCell=FALSE, bool replace=FALSE, bool replaceAll=FALSE);
++    void dataFindReplace(const QString &find, const QString &replacestr, bool matchCase=TRUE, bool allCells=TRUE, bool entireCell=FALSE, bool replace=FALSE, bool replaceAll=FALSE);
+     // Static functions
+     static int getHeaderColumn(const QString &section);
index ca0cdaf..b2cd1d2 100644 (file)
@@ -1,6 +1,8 @@
 require ${PN}.inc
 
+PR = "r1"
 
 SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/apps/opie-sheet \
            ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
-           ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
+           ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+           file://different-arg-names.patch;patch=1 "