gnome-keyring: sync with poky
authorKoen Kooi <koen@openembedded.org>
Sat, 29 Sep 2007 07:27:39 +0000 (07:27 +0000)
committerKoen Kooi <koen@openembedded.org>
Sat, 29 Sep 2007 07:27:39 +0000 (07:27 +0000)
packages/gnome/gnome-keyring/.mtn2git_empty [new file with mode: 0644]
packages/gnome/gnome-keyring/org.gnome.keyring.service [new file with mode: 0644]
packages/gnome/gnome-keyring_0.8.1.bb [new file with mode: 0644]
packages/gnome/gnome-keyring_2.20.bb [new file with mode: 0644]

diff --git a/packages/gnome/gnome-keyring/.mtn2git_empty b/packages/gnome/gnome-keyring/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gnome/gnome-keyring/org.gnome.keyring.service b/packages/gnome/gnome-keyring/org.gnome.keyring.service
new file mode 100644 (file)
index 0000000..96ea061
--- /dev/null
@@ -0,0 +1,3 @@
+[D-BUS Service]
+Name=org.gnome.keyring
+Exec=/usr/bin/gnome-keyring-daemon
diff --git a/packages/gnome/gnome-keyring_0.8.1.bb b/packages/gnome/gnome-keyring_0.8.1.bb
new file mode 100644 (file)
index 0000000..6489cbe
--- /dev/null
@@ -0,0 +1,12 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_stage() {
+        autotools_stage_all
+}
diff --git a/packages/gnome/gnome-keyring_2.20.bb b/packages/gnome/gnome-keyring_2.20.bb
new file mode 100644 (file)
index 0000000..c18d9f1
--- /dev/null
@@ -0,0 +1,23 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+PR = "r1"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+ libgcrypt"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+SRC_URI += "file://org.gnome.keyring.service"
+
+do_install_append () {
+       install -d ${D}${datadir}/dbus-1/services
+       install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+
+do_stage() {
+        autotools_stage_all
+}