matchbox-panel-2: add -Wno-error to TARGET_CFLAGS to build with gcc 4.4
authorThomas Zimmermann <zimmermann@vdm-design.de>
Thu, 5 Nov 2009 10:55:24 +0000 (10:55 +0000)
committerMartin Jansa <Martin.Jansa@gmail.com>
Sat, 16 Jan 2010 00:38:06 +0000 (01:38 +0100)
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
recipes/matchbox2/matchbox-panel-2_svn.bb

index a2a807f..ae3b122 100644 (file)
@@ -7,7 +7,7 @@ DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
 RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 PV = "2.0+svnr${SRCPV}"
-PR = "r0"
+PR = "r1"
 
 inherit autotools_stage pkgconfig
 
@@ -19,6 +19,8 @@ SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
 "
 S = "${WORKDIR}/${PN}"
 
+TARGET_CFLAGS += "-Wno-error"
+
 EXTRA_OECONF = "--disable-static --program-transform-name='s/$/-2/'"
 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"