batmand 0.3: New recipe (this time for real).
authorRobert Schuster <thebohemian@gmx.net>
Thu, 15 May 2008 21:42:45 +0000 (21:42 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Thu, 15 May 2008 21:42:45 +0000 (21:42 +0000)
packages/batmand/batmand_0.3.bb [new file with mode: 0644]
packages/batmand/files/.mtn2git_empty [new file with mode: 0644]
packages/batmand/files/makefile-fix.patch [new file with mode: 0644]

diff --git a/packages/batmand/batmand_0.3.bb b/packages/batmand/batmand_0.3.bb
new file mode 100644 (file)
index 0000000..c78f94d
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "https://www.open-mesh.net/batman"
+
+PR = "r0"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "\
+  http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
+  file://makefile-fix.patch;patch=1 \
+  "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+  oe_runmake
+}
+
+do_stage() {
+  :
+}
+
+do_install() {
+  install -d ${D}${bindir}
+  install -m 0755 batmand ${D}${bindir}
+}
diff --git a/packages/batmand/files/.mtn2git_empty b/packages/batmand/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/batmand/files/makefile-fix.patch b/packages/batmand/files/makefile-fix.patch
new file mode 100644 (file)
index 0000000..ff6ceb3
--- /dev/null
@@ -0,0 +1,13 @@
+Index: batman-0.3/Makefile
+===================================================================
+--- batman-0.3.orig/Makefile   2008-05-15 19:09:47.000000000 +0200
++++ batman-0.3/Makefile        2008-05-15 21:01:14.000000000 +0200
+@@ -17,8 +17,6 @@
+ #
+-CC =          gcc
+-CFLAGS =      -Wall -O1 -g3
+ EXTRA_CFLAGS =        -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA -DREVISION_VERSION=$(REVISION_VERSION)
+ LDFLAGS =     -lpthread