postgresql: added 8.2.4
authorMichael Krelin <hacker@klever.net>
Fri, 11 May 2007 20:05:46 +0000 (20:05 +0000)
committerMichael Krelin <hacker@klever.net>
Fri, 11 May 2007 20:05:46 +0000 (20:05 +0000)
packages/postgresql/files/.mtn2git_empty [new file with mode: 0644]
packages/postgresql/files/no-ecpg-test.patch [new file with mode: 0644]
packages/postgresql/postgresql_8.2.4.bb [new file with mode: 0644]

diff --git a/packages/postgresql/files/.mtn2git_empty b/packages/postgresql/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/postgresql/files/no-ecpg-test.patch b/packages/postgresql/files/no-ecpg-test.patch
new file mode 100644 (file)
index 0000000..c0f28f4
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/src/interfaces/ecpg/Makefile b/src/interfaces/ecpg/Makefile
+index dcd578f..1428423 100644
+--- a/src/interfaces/ecpg/Makefile
++++ b/src/interfaces/ecpg/Makefile
+@@ -8,7 +8,6 @@ all install installdirs uninstall dep depend distprep:
+       $(MAKE) -C ecpglib $@
+       $(MAKE) -C compatlib $@
+       $(MAKE) -C preproc $@
+-      $(MAKE) -C test $@
+ clean distclean maintainer-clean:
+       -$(MAKE) -C include $@
diff --git a/packages/postgresql/postgresql_8.2.4.bb b/packages/postgresql/postgresql_8.2.4.bb
new file mode 100644 (file)
index 0000000..3f65a4f
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "PostgreSQL is a powerful, open source relational database system."
+HOMEPAGE = "http://www.postgresql.com"
+LICENSE = "BSD"
+DEPENDS = "zlib readline"
+
+#WARNING: this recipe assumes you have the timezone compiler present in /usr/sbin/zic
+
+SRC_URI = "ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v${PV}/${P}.tar.bz2 \
+       file://no-ecpg-test.patch;patch=1"
+
+
+inherit autotools pkgconfig
+
+FILES_${PN}-doc += "${prefix}/doc/"
+
+do_compile_append() {
+cp /usr/sbin/zic ${S}/src/timezone/
+}
+
+DEFAULT_PREFERENCE = "-1"