Clean up IPKG_ARCHS as it was being used inconsistently, often with duplication....
authorRichard Purdie <rpurdie@rpsys.net>
Sat, 27 May 2006 09:55:35 +0000 (09:55 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sat, 27 May 2006 09:55:35 +0000 (09:55 +0000)
53 files changed:
classes/rootfs_ipk.bbclass
conf/bitbake.conf
conf/distro/openmn.conf
conf/distro/unslung.conf
conf/documentation.conf
conf/machine/a780.conf
conf/machine/amsdelta.conf
conf/machine/blueangel.conf
conf/machine/colinux.conf
conf/machine/collie.conf
conf/machine/devkitidp-pxa255.conf
conf/machine/efika.conf
conf/machine/ep93xx.conf
conf/machine/epia.conf
conf/machine/geodegx.conf
conf/machine/gumstix.conf
conf/machine/h1910.conf
conf/machine/h1940.conf
conf/machine/h2200.conf
conf/machine/h3600.conf
conf/machine/h3900.conf
conf/machine/h6300.conf
conf/machine/include/ixp4xx.conf
conf/machine/include/tune-iwmmxt.conf
conf/machine/include/zaurus-clamshell.conf
conf/machine/ipaq-pxa270.conf
conf/machine/jornada56x.conf
conf/machine/jornada6xx.conf
conf/machine/jornada7xx.conf
conf/machine/ks8695.conf
conf/machine/lite5200.conf
conf/machine/mainstone.conf
conf/machine/mtx-1.conf
conf/machine/native.conf
conf/machine/netvista.conf
conf/machine/nokia770.conf
conf/machine/omap1510inn.conf
conf/machine/omap1610h2.conf
conf/machine/omap1710h3.conf
conf/machine/omap2420h4.conf
conf/machine/omap5912osk.conf
conf/machine/poodle.conf
conf/machine/qemuarm.conf
conf/machine/simpad.conf
conf/machine/sun4cdm.conf
conf/machine/tosa.conf
conf/machine/triton.conf
conf/machine/wl500g.conf
conf/machine/wrt54.conf
conf/machine/x86.conf
conf/machine/xxs1500.conf
packages/meta/meta-sdk.bb
packages/meta/meta-toolchain.bb

index 2880411..2729503 100644 (file)
@@ -37,7 +37,7 @@ real_do_rootfs () {
        fi
        mkdir -p ${T}
        echo "src oe file:${DEPLOY_DIR_IPK}" > ${T}/ipkg.conf
-       ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_ARCHS} ${MACHINE}"
+       ipkgarchs="${IPKG_ARCHS}"
        priority=1
        for arch in $ipkgarchs; do
                echo "arch $arch $priority" >> ${T}/ipkg.conf
index 3542cfb..9c1ba1f 100644 (file)
@@ -57,6 +57,7 @@ TARGET_CC_ARCH = ""
 
 PACKAGE_ARCH = "${HOST_ARCH}"
 MACHINE_ARCH = "${@[bb.data.getVar('HOST_ARCH', d, 1), bb.data.getVar('MACHINE', d, 1)][bool(bb.data.getVar('MACHINE', d, 1))]}"
+IPKG_ARCHS = "all any noarch ${TARGET_ARCH} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
 
 ##################################################################
 # Date/time variables.
index 316720d..0e3d36e 100644 (file)
@@ -12,7 +12,7 @@ TARGET_OS = "linux"
 
 INHERIT += "package_ipk"
 INHERIT += "debian"
-IPKG_ARCHS = "armv5te openmn"
+IPKG_EXTRA_ARCHS = "armv5te openmn"
 
 FEED_URIS  = "mnci54##http://www.mn-solutions.de/feed/mnci54/base"
 
index 599d787..6d76e09 100644 (file)
@@ -26,7 +26,7 @@ THUMB_INTERWORK = "no"
 # to armeb - this makes this stuff independent of changes in machine/nslu2.conf
 TARGET_ARCH = "armeb"
 PACKAGE_ARCH = "${TARGET_ARCH}"
-# IPKG_ARCHS has the full list of supported architectures (from nslu2.conf)
+# IPKG_EXTRA_ARCHS has the full list of supported architectures (from nslu2.conf)
 
 # match the optimisation settings to that which has traditionally been used
 # in unslung
index b072ac8..c07c8fa 100644 (file)
@@ -38,6 +38,8 @@ PACKAGE_ARCH[doc] = 'The architecture needed for using a resulting package. If y
 machine dependant configuration options in your bitbake file add a \
 PACKAGE_ARCH  = "${MACHINE_ARCH}" to the file.'
 
+IPKG_ARCHS[doc] = 'A list of architectures compatible with the given target in order of priority'
+IPKG_EXTRA_ARCHS[doc] = 'Set this variable to add extra architectures to the list of supported architectures'
 
 DATE[doc] = "The date the build was started Ymd"
 TIME[doc] = "The time the build was started HMS"
index 3977f50..0b33e34 100644 (file)
@@ -5,7 +5,7 @@
 include conf/machine/include/motorola-ezx.conf
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv4 armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 
index dbe74de..193048a 100644 (file)
@@ -5,7 +5,6 @@
 TARGET_ARCH = "arm"
 
 TARGET_FPU = "soft"
-IPKG_ARCHS = "all arm ${MACHINE}"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-amsdelta-2.6"
index 9c2b94d..251dc8a 100644 (file)
@@ -7,7 +7,7 @@ KERNEL ?= "kernel26"
 OVERRIDES =. "${KERNEL}:"
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv4t armv5e armv5te ipaqpxa blueangel"
+IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel_kernel26 = "xanadux-ba-2.6"
 PREFERRED_PROVIDER_virtual/kernel = "xanadux-ba-2.6"
index 1af280c..556944e 100644 (file)
@@ -3,6 +3,6 @@
 #@DESCRIPTION: Machine configuration for Cooperative Linux running on an x86 compatible PC
 
 TARGET_ARCH = "i686"
-IPKG_ARCHS = "all i686 i386 x86 ${MACHINE}"
+IPKG_EXTRA_ARCHS = "i386 x86"
 PREFERRED_PROVIDER_virtual/kernel = "linux-colinux"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel kernel-modules"
index 3e95848..0363f05 100644 (file)
@@ -3,7 +3,6 @@
 #@DESCRIPTION: Machine configuration for the SA1100 based Sharp Zaurus SL-5000 and SL-5500 devices
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver ?= "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel ?= "collie-kernels-2.4-embedix"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel hostap-modules-cs orinoco-modules-cs \
index 39ef40a..6bc632d 100644 (file)
@@ -5,7 +5,7 @@
 TARGET_ARCH = "arm"
 
 GUI_MACHINE_CLASS = "bigscreen"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_virtual/bootloader = "uboot-${MACHINE}"
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
index 40387b5..103bd13 100644 (file)
@@ -5,7 +5,7 @@
 INHERIT += "linux_modules"
 
 TARGET_ARCH = "powerpc"
-IPKG_ARCHS = "all ppc ${MACHINE}"
+IPKG_EXTRA_ARCHS = "ppc"
 
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-${MACHINE}"
index b1e6208..4b044e8 100644 (file)
@@ -5,7 +5,7 @@
 INHERIT += "linux_modules"
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4t ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv4t"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
 
index 0d3bced..dd6b0f0 100644 (file)
@@ -7,7 +7,7 @@ udevdir = "/dev"
 OLDEST_KERNEL = "2.6.5"
 GLIBC_ADDONS = "nptl"
 GLIBC_EXTRA_OECONF = "--with-tls"
-IPKG_ARCHS = "i386"
+IPKG_EXTRA_ARCHS = "i386"
 
 include conf/machine/include/tune-c3.conf
 
index e4f56f1..f908361 100644 (file)
@@ -3,7 +3,7 @@
 # Released under the MIT license (see packages/COPYING)
 
 TARGET_ARCH =  "i486"
-IPKG_ARCHS = "all i486 geodegx"
+IPKG_EXTRA_ARCHS = "geodegx"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-geodegx"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel pciutils udev kernel-modules"
index 8da2f5c..75c671a 100644 (file)
@@ -3,7 +3,6 @@ TARGET_VENDOR = "-oe"
 PREFERRED_PROVIDER_virtual/kernel = "linux-gumstix"
 OLDEST_KERNEL = "2.6.15"
 MODUTILS = "26"
-IPKG_ARCHS = "arm ${MACHINE}"
 
 include conf/machine/include/tune-xscale.conf
 TARGET_CC_ARCH = "-Os -pipe -Os -march=armv5te -mtune=xscale -Wa,-mcpu=xscale"
index 7ebcccb..a023118 100644 (file)
@@ -6,7 +6,7 @@ KERNEL ?= "kernel26"
 OVERRIDES =. "${KERNEL}:"
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te h1910"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 include conf/machine/include/tune-xscale.conf
 
index fb4dc8c..b11e447 100644 (file)
@@ -2,7 +2,7 @@
 #@NAME: h1940
 #@DESCRIPTION: Machine configuration for the HP iPAQ h1930 and h1940
 
-IPKG_ARCHS = "all arm armv4 armv4t armv5e armv5te h1940"
+IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
 TARGET_ARCH = arm
 PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-h1940"
index 40401da..fab57ca 100644 (file)
@@ -4,7 +4,7 @@
 
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv4t armv5e armv5te ipaqpxa h2200"
+IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa-2.6"
index b364758..0261a84 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the Compaq iPAQ 36xx, Compaq iPAQ 37xx and Compaq iPAQ 38xx devices
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ipaqsa h3600"
+IPKG_EXTRA_ARCHS = "ipaqsa"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "handhelds-sa"
 EXTRA_IMAGECMD_h3600_jffs2 = "-e 0x40000 -p"
index cab50db..1611ed4 100644 (file)
@@ -8,7 +8,7 @@ KERNEL ?= "kernel24"
 OVERRIDES =. "${KERNEL}:"
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv4t armv5e armv5te ipaqpxa h3900"
+IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel_kernel24 = "handhelds-pxa"
 PREFERRED_PROVIDER_virtual/kernel_kernel26 = "handhelds-pxa-2.6"
index 3f8b7d7..33855e3 100644 (file)
@@ -4,7 +4,7 @@
 
 TARGET_ARCH = "arm"
 PACKAGE_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4"
+IPKG_EXTRA_ARCHS = "armv4"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-h6300-omap1"
index 2dab2e2..93befb9 100644 (file)
@@ -111,7 +111,7 @@ TARGET_PACKAGE_ARCH = "${TARGET_PACKAGE_ARCH_BASE}${BYTE_SEX_CHAR}"
 #    because everything built here is no more specific than that.
 MACHINE_ARCH = "ixp4xx${ARCH_BYTE_SEX}"
 
-# IPKG_ARCHS
+# IPKG_EXTRA_ARCHS
 #    The full list of package architectures which should run on the system.
 #    This takes into account both the board level issues and the INPUTS set
 #    by the distro.  The arm list is derived from the architecture settings
@@ -126,12 +126,12 @@ THUMB_ARCHITECTURES = "thumbe${BYTE_SEX_CHAR} thumbv4t${BYTE_SEX_CHAR} thumbv5t$
 #    NOTE: this list contains just the things which rootfs_ipk.bbclass does
 #    not add, rootfs_ipk.bbclass evaluates:
 #
-#        ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_ARCHS} ${MACHINE}"
+#        ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
 #
 #    This is a priority ordered list - most desireable architecture at the end,
 #    so put <ARM_INSTRUCTION_SET>_ARCHITECTURES at the end and, if
 #    THUMB_INTERWORK precede this with the other architectures.
-IPKG_ARCHS = "ixp4xx ${MACHINE} \
+IPKG_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
                ${@(lambda arch_thumb, arch_arm, is_arm, interwork: \
                (interwork and (is_arm and arch_thumb or arch_arm) + ' ' or '') \
                + '${TARGET_ARCH} ' + (is_arm and arch_arm or arch_thumb)) \
@@ -146,7 +146,7 @@ IPKG_ARCHS = "ixp4xx ${MACHINE} \
 #    the removal of the raw "${MACHINE}" from the end of the list.  ${MACHINE} and
 #    ixp4xx are included at the start (lower priority) as the non-byte-sex specific
 #    versions.
-IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${IPKG_ARCHS}"
+IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${IPKG_EXTRA_ARCHS}"
 
 #-------------------------------------------------------------------------------
 # Package versions
index 2976e0a..e46796f 100644 (file)
@@ -1,6 +1,6 @@
 # Configurations for the Intel PXA27x Appications Processor Family. 
 # Please use tune-xscale for PXA255/PXA26x based processors.
-IPKG_ARCHS += "iwmmxt"
+IPKG_EXTRA_ARCHS += "iwmmxt"
 TARGET_CC_ARCH = "-march=iwmmxt -mtune=iwmmxt"
 PACKAGE_ARCH = "iwmmxt"
 
index 1e3d3d7..0266636 100644 (file)
@@ -1,5 +1,5 @@
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv4 armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 
index 07753cc..f5cc893 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the iPAQ with a pxa27x CPU  devices
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te ipaqpxa hx4700"
+IPKG_EXTRA_ARCHS = "armv4 armv5te ipaqpxa hx4700"
 #use this for a hx47xx ipaq
 PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa-2.6"
 
index b3f5499..b5f8606 100644 (file)
@@ -3,7 +3,6 @@
 #@DESCRIPTION: Machine configuration for the SA1100 based HP Jornada 56x palmtop computer
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "handhelds-sa-2.6"
 PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
index 5aa492f..6521d15 100644 (file)
@@ -3,6 +3,5 @@
 #@DESCRIPTION: Machine configuration for the HITACHI SH3 based HP Jornada 6xx palmtop computer
 
 TARGET_ARCH = "sh3"
-IPKG_ARCHS = "all ${TARGET_ARCH} ${MACHINE}"
 
 include conf/machine/include/tune-sh3.conf
index 82eff0b..e821813 100644 (file)
@@ -3,6 +3,5 @@
 #@DESCRIPTION: Machine configuration for the SA1100 based HP Jornada 7xx palmtop computer
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ${MACHINE}"
 
 include conf/machine/include/tune-strongarm.conf
\ No newline at end of file
index a3e7509..5d214f7 100644 (file)
@@ -6,7 +6,6 @@
 
 TARGET_ARCH = "arm"
 
-IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_virtual/kernel = "linux-${MACHINE}"
 
 require conf/machine/include/tune-arm920t.conf
index 68efcce..2bf6cc2 100644 (file)
@@ -1,5 +1,5 @@
 TARGET_ARCH = "powerpc"
-IPKG_ARCHS = "all ppc ${MACHINE}"
+IPKG_EXTRA_ARCHS = "ppc"
 UBOOT_MACHINE = "Lite5200"
 SERIAL_CONSOLE="38400 ttyS0"
 
index a171a21..de24224 100644 (file)
@@ -5,7 +5,7 @@
 TARGET_ARCH = "arm"
 
 GUI_MACHINE_CLASS = "smallscreen"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
 
index 02c3164..3a5f047 100644 (file)
@@ -3,7 +3,6 @@
 #@DESCRIPTION: Machine configuration for the mtx-1 (aka MeshCube)
 
 TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"
 #PREFERRED_VERSION_linux-mtx-1 = "2.4.24"
index 4817b2e..8caa6b9 100644 (file)
@@ -3,7 +3,6 @@
 #@DESCRIPTION: Machine configuration for your build station
 
 TARGET_ARCH = "${BUILD_ARCH}"
-IPKG_ARCHS = "all ${TARGET_ARCH}"
 TARGET_PREFIX = ""
 VENDOR = "-oe"
 
index bcad9cc..9d483d4 100644 (file)
@@ -3,7 +3,6 @@
 #@DESCRIPTION: Machine configuration for the IBM Netvista thin client
 
 TARGET_ARCH = "i386"
-IPKG_ARCHS = "all i386"
 PREFERRED_PROVIDER_xserver = "xserver-xorg"
 PREFERRED_PROVIDER_virtual/kernel = "linux-netvista"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel pciutils"
index d24324a..5708c78 100644 (file)
@@ -2,7 +2,7 @@
 #@NAME: Nokia 770 internet tablet
 #@DESCRIPTION: Machine configuration for the Nokia 770, an omap 1710 based tablet
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv4 armv5te"
 
 PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-omap"
 PREFERRED_PROVIDER_virtual/bootloader = ""
index 9c460b4..bd367d4 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index 9c460b4..bd367d4 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index 9c460b4..bd367d4 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index db333b2..5140692 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te armv6te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te armv6te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
index 822d766..dccc5a2 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the OMAP Starter Kit with a 5912 processor
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel = "linux-omap1"
index 8c83416..79915e4 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the PXA250 based Sharp Zaurus SL-B500 and SHarp Zaurus SL-5600 devices
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te poodle"
+IPKG_EXTRA_ARCHS = "armv4 armv5te"
 
 ZKERNEL_VERSION ?= "2.4"
 include conf/machine/include/poodle-${ZKERNEL_VERSION}.conf
index f3edef9..022eb7f 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for running an ARM system under qemu emulation
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te qemuarm"
+IPKG_EXTRA_ARCHS = "armv4 armv5te"
 
 PCMCIA_MANAGER = "pcmciautils"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
index a643978..43097d8 100644 (file)
@@ -8,7 +8,6 @@ KERNEL ?= "kernel24"
 OVERRIDES =. "${KERNEL}:"
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ${MACHINE}"
 PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 PREFERRED_PROVIDER_virtual/kernel_kernel24 = "opensimpad-64+0"
 PREFERRED_PROVIDER_virtual/kernel_kernel26 = "handhelds-pxa-2.6"
index d73ab85..5376be0 100644 (file)
@@ -7,7 +7,5 @@ BOOTSTRAP_EXTRA_RDEPENDS = "kernel module-init-tools udev"
 udevdir = "/dev"
 OLDEST_KERNEL = "2.6.5"
 
-IPKG_ARCHS = "sparc"
-
 PREFERRED_PROVIDER_virtual/kernel = "linux-sun4cdm"
 
index 3485937..751b498 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the PXA255 based Sharp Zaurus SL-6000 device
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv4 armv5te tosa"
+IPKG_EXTRA_ARCHS = "armv4 armv5te"
 
 ZKERNEL_VERSION ?= "2.4"
 include conf/machine/include/tosa-${ZKERNEL_VERSION}.conf
index cb5c8fb..671def3 100644 (file)
@@ -3,7 +3,7 @@
 #@DESCRIPTION: Machine configuration for the XScale based triton boards from KaRo Electronics 
 
 TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm armv5te ${MACHINE}"
+IPKG_EXTRA_ARCHS = "armv5te"
 PREFERRED_PROVIDER_virtual/kernel = "triton-kernel"
 
 BOOTSTRAP_EXTRA_RDEPENDS = "virtual/kernel"
index 18445ec..516d709 100644 (file)
@@ -4,4 +4,3 @@
 
 TARGET_ARCH = "mipsel"
 TARGET_CC_ARCH = "-Os -mips2"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
index 569d78b..f61570a 100644 (file)
@@ -4,7 +4,6 @@
 
 TARGET_ARCH = "mipsel"
 TARGET_CC_ARCH = "-Os"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
 
 SERIAL_CONSOLE = "tts/0"
 
index 02583c9..0210b87 100644 (file)
@@ -4,7 +4,7 @@
 
 TARGET_ARCH = "i386"
 # TARGET_VENDOR = "-oe"
-IPKG_ARCHS = "all i386 x86"
+IPKG_EXTRA_ARCHS = "x86"
 PREFERRED_PROVIDER_virtual/kernel = "linux-x86"
 BOOTSTRAP_EXTRA_RDEPENDS = "kernel pciutils udev kernel-modules"
 
index 7500181..9cc47cd 100644 (file)
@@ -5,7 +5,6 @@
 # pad size and SREC_VMAADDR would need to be changed for the xxs1500 rev B.
 
 TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
 
 PREFERRED_PROVIDER_virtual/kernel = "linux-xxs1500"
 
index 4ae2718..286abb4 100644 (file)
@@ -42,7 +42,7 @@ EOF
         cat <<EOF >${SDK_DIR}/ipkg-target.conf
 src oe file:${DEPLOY_DIR_IPK}
 EOF
-       ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_ARCHS} ${MACHINE}"
+       ipkgarchs="${IPKG_ARCHS}"
         priority=1
         for arch in $ipkgarchs; do
                 echo "arch $arch $priority" >> ${SDK_DIR}/ipkg-target.conf
index 707f92a..8b303f3 100644 (file)
@@ -39,7 +39,7 @@ EOF
         cat <<EOF >${SDK_DIR}/ipkg-target.conf
 src oe file:${DEPLOY_DIR_IPK}
 EOF
-       ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_ARCHS} ${MACHINE}"
+       ipkgarchs="${IPKG_ARCHS}"
         priority=1
         for arch in $ipkgarchs; do
                 echo "arch $arch $priority" >> ${SDK_DIR}/ipkg-target.conf