dnsmasq: add default configuration for nylon
authorBruno Randolf <br1@subnet.at>
Fri, 24 Dec 2004 10:04:58 +0000 (10:04 +0000)
committerBruno Randolf <br1@subnet.at>
Fri, 24 Dec 2004 10:04:58 +0000 (10:04 +0000)
BKrev: 41cbe9caAuo0mP_jy_sbxUDQYTRTEg

packages/dnsmasq/dnsmasq_2.15.bb
packages/dnsmasq/files/dnsmasq.conf [new file with mode: 0644]
packages/dnsmasq/files/nylon/dnsmasq.conf [new file with mode: 0644]

index e69de29..f349810 100644 (file)
@@ -0,0 +1,29 @@
+SECTION = "console/network"
+DESCRIPTION = "Dnsmasq is a lightweight, easy to configure DNS forwarder and DHCP server."
+HOMEPAGE = "http://www.thekelleys.org.uk/dnsmasq/doc.html"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+PR = "r2"
+
+SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/dnsmasq-${PV}.tar.gz \
+       file://init \
+       file://dnsmasq.conf"
+
+S = "${WORKDIR}/dnsmasq-${PV}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "dnsmasq"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install () {
+       oe_runmake "PREFIX=${D}/${prefix}" \
+                  "BINDIR=${D}/${bindir}" \
+                  "MANDIR=${D}/${mandir}" \
+                  install
+       install -d ${D}/${sysconfdir}/ ${D}/${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/dnsmasq.conf ${D}/${sysconfdir}/
+       install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/dnsmasq
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/dnsmasq.conf"
diff --git a/packages/dnsmasq/files/dnsmasq.conf b/packages/dnsmasq/files/dnsmasq.conf
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/dnsmasq/files/nylon/dnsmasq.conf b/packages/dnsmasq/files/nylon/dnsmasq.conf
new file mode 100644 (file)
index 0000000..e69de29