midori-0.1.2 : added a dependency on python-docutils-native and new python-docutils...
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Fri, 23 Jan 2009 20:48:20 +0000 (21:48 +0100)
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Fri, 23 Jan 2009 21:01:07 +0000 (22:01 +0100)
*if you don't depend on python-docutils-native it midori it fails with :
| Traceback (most recent call last):
|   File "/usr/bin/rst2html.py", line 19, in <module>
|     from docutils.core import publish_cmdline, default_description
| ImportError: No module named docutils.core
| Unable to install the file `_build_/docs/user/midori.html': not found in dir:///home/gnutoo/oetmp/work/armv4t-angstrom-linux-gnueabi/midori-0.1.2-r0/midori-0.1.2
| make: *** [install] Error 1
| FATAL: oe_runmake failed
*don't bump the version as it couldn't build before

packages/gtk-webcore/midori_0.1.2.bb
packages/python/python-docutils-native_0.5.bb [new file with mode: 0644]

index 067e900..42ac708 100644 (file)
@@ -1,6 +1,6 @@
 require midori.inc
 
-DEPENDS += "python-native"
+DEPENDS += "python-native python-docutils-native"
 
 SRC_URI = "http://goodies.xfce.org/releases/midori/midori-${PV}.tar.bz2"
 
diff --git a/packages/python/python-docutils-native_0.5.bb b/packages/python/python-docutils-native_0.5.bb
new file mode 100644 (file)
index 0000000..5e294e5
--- /dev/null
@@ -0,0 +1,8 @@
+require python-docutils_${PV}.bb
+DEPENDS = "python-native"
+inherit native
+
+do_stage() {
+       distutils_stage_all
+}
+