Merge bk://oe-devel.bkbits.net/openembedded
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>
Fri, 21 Jan 2005 13:40:17 +0000 (13:40 +0000)
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>
Fri, 21 Jan 2005 13:40:17 +0000 (13:40 +0000)
into bkbits.net:/repos/n/nslu2-linux/openembedded

2005/01/21 14:13:30+01:00 local!hrw
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/
into marcinj.local:/home/hrw/zaurus/bb/openembedded

2005/01/21 14:13:06+01:00 local!hrw
justreader: fix Settings file location (really fix #204)

2005/01/21 14:11:29+01:00 (none)!koen
patch to libpcap to fix dsniff build, courtesy Bob Davies

2005/01/21 14:10:18+01:00 local!hrw
transition from libstdc++ to libsupc++

Basically it allow us to drop libstdc++ dependency from some programs.
Binaries are getting little bigger but don't depend on ~3.5MiB library.

If your package fails during linking you have to add one line to it's .bb file:
export OE_QMAKE_LINK="${CXX}"

2005/01/21 14:02:44+01:00 local!hrw
we already have freedroid in meta-opie - it's in task-qpe-games as it is not from OPIE

2005/01/21 14:01:28+01:00 local!hrw
disabled PARALLEL_MAKE for uae and zroadmap

2005/01/21 11:38:29+01:00 local!hrw
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/
into marcinj.local:/home/hrw/zaurus/bb/openembedded

2005/01/18 18:53:19+01:00 hrw.one.pl!hrw
disable PARALLEL_MAKE for opie-tinykate

BKrev: 41f106415qu3LUbzxrhFJByjZfa8pQ

13 files changed:
classes/palmtop.bbclass
packages/iqnotes/iqnotes_2.0.2.bb
packages/justreader/justreader_2.0k.bb
packages/kdepimpi/kdepimpi-base.inc
packages/libpcap/libpcap_0.8.3.bb
packages/meta/meta-opie.bb
packages/petitepainture/petitepainture_1.4a.bb
packages/qpdf2/qpdf2_2.2.1.bb
packages/uae/uae_0.8.23-20040129.bb
packages/visiscript/visiscript_0.3.2.bb
packages/zroadmap/zroadmap_1.0.8.bb
packages/zshopi/zshopi_0.2.bb
packages/zuc/zuc_1.1.2ern.bb

index e69de29..523c3d7 100644 (file)
@@ -0,0 +1,10 @@
+# basically a placeholder for something more fancy
+# for now, just declare some things
+
+inherit qmake
+
+EXTRA_QMAKEVARS_POST_append = " DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
+
+DEPENDS_prepend = "virtual/libqpe uicmoc-native "
+
+FILES_${PN} = "${palmtopdir}"
index 904d35e..34dd177 100644 (file)
@@ -8,6 +8,7 @@ LICENSE = "GPL"
 DEPENDS = "virtual/libqpe"
 HOMEPAGE = "http://iqnotes.kybu.org"
 AUTHOR = "Peter Vrabel <kybu@kybu.org>"
+PR = "r1"
 
 SRC_URI = "http://iqnotes.kybu.org/iqnotes-2.0.2-src.tar.bz2 \
            file://md5.diff;patch=1"
@@ -16,6 +17,8 @@ S = "${WORKDIR}/iqnotes/iqnotes"
 inherit palmtop
 
 QMAKE_PROFILES = "iqnotes.pro"
+export OE_QMAKE_LINK="${CXX}"
+
 
 do_install() {
         install -d ${D}/${palmtopdir}/help/html \
index e69de29..117e747 100644 (file)
@@ -0,0 +1,30 @@
+DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+HOMEPAGE = "http://justreader.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
+file://correct-settings-path.patch;patch=1"
+
+S = "${WORKDIR}/TextReader2"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST = 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_prepend() {
+       find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+       install -d ${D}/${palmtopdir}/bin \
+                  ${D}/${palmtopdir}/pics/${PN}/ \
+                  ${D}/${palmtopdir}/apps/Applications
+       install -m 0644 apps/Applications/justreader.desktop ${D}/${palmtopdir}/apps/Applications/
+       install -m 0755 bin/justreader ${D}/${palmtopdir}/bin/
+       install -m 0644 pics/* ${D}/${palmtopdir}/pics/justreader/
+}
index cccbe77..8702419 100644 (file)
@@ -33,10 +33,10 @@ file://libkcal.pro.patch;patch=1 \
 # kabc/plugins/opie     - wants libopie1  (we don't plan to have it in OE)
 # kmicromail            - have to check changes in KDEPIM/PI version libmailwrapper
 
-
+PARALLEL_MAKE = ""
 S = "${WORKDIR}/kdepim"
 EXTRA_QMAKEVARS_POST += "KDEPIMDIR=${S} INCLUDEPATH+=../ OBJECTS_DIR=obj/ MOC_DIR=moc/ \
-             LIBS+=-L${S}/dest/ DESTDIR=${S}/dest LIBS+=-lstdc++ \
+             LIBS+=-L${S}/dest/ DESTDIR=${S}/dest LIBS+=-lsupc++ \
              LIBS+=-Wl,-rpath-link,${S}/dest \
              LIBS-=-lzlib LIBS+=-lz \
              "
@@ -47,7 +47,7 @@ EXTRA_QMAKEVARS_POST += "KDEPIMDIR=${S} INCLUDEPATH+=../ OBJECTS_DIR=obj/ MOC_DI
 
 QMAKE_PROFILES= "all.pro"
 SUBDIRS="libical/src/libical libical/src/libicalss microkde libkcal libkdepim \
-        kabc korganizer kalarmd kaddressbook kabc/plugins/file kabc/plugins/dir \ 
+        kabc korganizer kalarmd kaddressbook kabc/plugins/file kabc/plugins/dir \
         kabc/formats/binary kabc/plugins/qtopia \
         gammu/emb/common \
         gammu/emb/gammu \
index e69de29..ef16ded 100644 (file)
@@ -0,0 +1,30 @@
+DESCRIPTION = "Network Packet Capture Library"
+HOMEPAGE = "http://www.tcpdump.org/"
+LICENSE = "BSD"
+SECTION = "libs"
+PRIORITY = "required"
+
+SRC_URI = "http://www.tcpdump.org/release/libpcap-${PV}.tar.gz; \
+          file://shared.patch;patch=1"
+#         file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-pcap=linux"
+CPPFLAGS_prepend = "-I${S} "
+CFLAGS_prepend = "-I${S} "
+CXXFLAGS_prepend = "-I${S} "
+
+do_configure_prepend () {
+       if [ ! -e acinclude.m4 ]; then
+               cat aclocal.m4 > acinclude.m4
+       fi
+}
+
+do_stage () {
+       install -m 0644 pcap.h ${STAGING_INCDIR}/pcap.h
+       install -m 0644 pcap-namedb.h ${STAGING_INCDIR}/pcap-namedb.h
+       install -m 0644 pcap-bpf.h ${STAGING_INCDIR}/pcap-bpf.h
+       oe_libinstall -a -so libpcap ${STAGING_LIBDIR}
+       ln -s ${STAGING_INCDIR}/pcap-bpf.h  ${STAGING_INCDIR}/net/bpf.h
+}
index be71e27..0f74583 100644 (file)
@@ -187,7 +187,6 @@ opie-tictac \
 opie-wordgame \
 opie-zlines \
 opie-zsame \
-freedriod \
 "
 RDEPENDS_task-opie-games = "${task-opie-games}"
 DEPENDS += " ${task-opie-games}"
index e69de29..81cb8c8 100644 (file)
@@ -0,0 +1,24 @@
+DESCRIPTION = "Pressure-Sensitive Paint Program for Opie/Qtopia"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+HOMEPAGE = "http://sun.dhis.portside.net/~sakira/wiki/index.cgi?cmd=view;name=LinuxZaurus%3APetitePeinture+en"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "petitpeintu"
+APPDESKTOP = "${WORKDIR}"
+PR = "r1"
+
+SRC_URI = "http://sun.dhis.portside.net/~sakira/archive/SPainter_${PV}_src.tar.gz \
+           file://petitpeintu.desktop \
+           file://petitpeintu.png "
+S = "${WORKDIR}/SPainter"
+
+inherit opie
+
+QMAKE_PROFILES = "spainter.pro"
+
+do_install() {
+        install -d ${D}/${palmtopdir}/pics
+        install -m 0644 *.png ${D}/${palmtopdir}/pics/
+        install -m 0644 ${WORKDIR}/petitpeintu.png ${D}/${palmtopdir}/pics/
+}
index 997c866..7305298 100644 (file)
@@ -19,6 +19,7 @@ inherit opie
 
 QMAKE_PROFILES = "qpdf_render-freetype.pro"
 EXTRA_QMAKEVARS_POST = "TARGET=qpdf"
+export OE_QMAKE_LINK="${CXX}"
 
 do_configure_prepend() {
        find . -name "Makefile"|xargs rm -f
index e69de29..138f9d6 100644 (file)
@@ -0,0 +1,35 @@
+DESCRIPTION = "Amiga Emulator based on SDL"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe"
+LICENSE = "GPL"
+
+SRC_URI = "http://rcdrummond.net/uae/uae-${PV}/uae-${PV}.tar.bz2 \
+           file://configure.patch;patch=1 \
+           file://m4.patch;patch=1"
+
+inherit autotools 
+
+EXTRA_OECONF = "--with-hostcc=gcc --disable-ui --without-x \
+               --without-gtk --enable-jit --disable-natmem \
+               --with-zlib=${STAGING_LIBDIR}/.. \
+               --with-sdl-exec-prefix=${STAGING_BINDIR}/.. \
+               --with-sdl-prefix=${STAGING_LIBDIR}/.."
+
+CFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
+CXXFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
+PARALLEL_MAKE = ""
+
+do_configure_prepend () {
+       touch NEWS AUTHORS ChangeLog
+}
+
+do_install_append() {
+# Packages NEVER, ever, ever, ever touch home directories directly.
+# ever.
+# Either update a global config in /etc, install it into /etc/skel/ for
+# new users homedirs, rely on the user installing it to put it in place,
+# or dont install it at all.  --CL
+#      install -d ${D}/home/root
+#      install ${FILESDIR}/uaerc ${D}/home/root/.uaerc
+}
index e69de29..4942b49 100644 (file)
@@ -0,0 +1,32 @@
+DESCRIPTION = "VisiScript is a simple graphical frontend for \
+scripting languages like minscript, Python,Ruby, Perl or others. \
+VisiScript runs on the Qtopia desktop environment of the Zaurus."
+SECTION = "opie/applications"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "qscintilla"
+LICENSE = "GPL"
+APPNAME = "visiscript"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
+           file://qptrlist.h file://qcleanuphandler.h"
+S = "${WORKDIR}/visiscript-${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "zvisiscript.pro"
+
+EXTRA_QMAKEVARS_POST = "CONFIG-=thread LIBS-=../qscintilla-1.60-gpl-1.3/qt/lib/libqscintilla_arm.a LIBS+=-lqscintilla"
+export OE_QMAKE_LINK="${CXX}"
+
+do_compile_prepend() {
+       install -m 0644 ${WORKDIR}/*.h ${S}
+}
+
+do_install() {
+       install -d ${D}/${palmtopdir}/pics/
+       install -m 0644 Visiscript.png ${D}/${palmtopdir}/pics
+}
+
+#FIXME: package help and translation
index d5f7f1f..febef98 100644 (file)
@@ -22,6 +22,7 @@ inherit palmtop
 
 EXTRA_OEMAKE = 'DESKTOP=QPE MOC=${OE_QMAKE_MOC} UIC=${OE_QMAKE_UIC} \
                 GUILDFLAGS="-lz -lpng -ljpeg -lts -lqte -lqpe -L${STAGING_LIBDIR} -L${QTDIR}/lib"'
+PARALLEL_MAKE = ""
 
 do_configure() {
        rm -rf moc*
index c021b7d..1b36044 100644 (file)
@@ -9,6 +9,7 @@ AUTHOR = "Bernd Lachner <dev@lachner-net.de>"
 APPTYPE = "binary"
 APPNAME = "zshopi"
 APPDESKTOP = "${WORKDIR}"
+PR = "r1"
 
 SRC_URI = "http://www.lachner-net.de/Frames/Software/zshopi_0.2.tar.bz2 \
 file://zshopi.desktop \
@@ -24,7 +25,6 @@ inherit opie
 
 EXTRA_QMAKEVARS_POST = "DEFINES+=QTOPIA LIBS+=-lm LIBS+=-lsqlite LIBS+=-lqpe"
 OE_QMAKE_CXXFLAGS = "-fno-rtti ${CXXFLAGS}"
-export OE_QMAKE_LINK="${CXX}"
 
 do_configure_prepend() {
        qmake -project
index f69861a..78450ef 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPL"
 APPTYPE = "binary"
 APPNAME = "zuc"
 APPDESKTOP = "${S}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.linux-solutions.at/projects/zaurus/source/zuc_V${PV}.tar.gz \
            http://nick.kreucher.net/zuc/zuc_units"
@@ -14,8 +14,6 @@ S = "${WORKDIR}/zuc_V${PV}"
 
 inherit opie
 
-export OE_QMAKE_LINK="${CXX}"
-
 do_configure_append() {
        echo "#define VERSION \""${PV}"\"" > version.h
        echo "#define BUILDTIME \""`date +%Y%m%d%H%M`"\"" >> version.h