ncftp: update to 3.2.0
authorMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 18 Dec 2006 21:29:17 +0000 (21:29 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 18 Dec 2006 21:29:17 +0000 (21:29 +0000)
packages/apr/apr-util_0.9.12.bb
packages/ncftp/ncftp/fixes.patch [new file with mode: 0644]
packages/ncftp/ncftp/make.patch [new file with mode: 0644]
packages/ncftp/ncftp_3.1.7.bb [deleted file]
packages/ncftp/ncftp_3.1.8.bb [deleted file]
packages/ncftp/ncftp_3.1.9.bb [deleted file]
packages/ncftp/ncftp_3.2.0.bb [new file with mode: 0644]
site/ix86-common

index 776fd03..5881fa3 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
            file://gen_uri_delims.patch;patch=1 \
            file://uri_delims.h"
 
-EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
 
 inherit autotools lib_package binconfig
 
diff --git a/packages/ncftp/ncftp/fixes.patch b/packages/ncftp/ncftp/fixes.patch
new file mode 100644 (file)
index 0000000..557ff5c
--- /dev/null
@@ -0,0 +1,22 @@
+Index: ncftp-3.2.0/ncftp/cmds.c
+===================================================================
+--- ncftp-3.2.0.orig/ncftp/cmds.c      2006-12-18 22:21:34.000000000 +0100
++++ ncftp-3.2.0/ncftp/cmds.c   2006-12-18 22:23:55.000000000 +0100
+@@ -945,7 +945,7 @@
+                       --n;
+                       memset(&st, 0, sizeof(st));
+               }
+-              (void) sprintf(modstr, "%u " PRINTF_LONG_LONG, (unsigned int) st.st_mtime, (longest_int) st.st_size);
++              (void) sprintf(modstr, "%u %ld" , (unsigned int) st.st_mtime, (longest_int) st.st_size);
+               if (AddLine(&modstrs, modstr) == NULL) {
+                       DisposeLineListContents(&modstrs);
+                       DisposeLineListContents(&rfiles);
+@@ -1006,7 +1006,7 @@
+                       (void) fprintf(stdout, "\n");
+                       continue;
+               }
+-              (void) sprintf(modstr, "%u " PRINTF_LONG_LONG, (unsigned int) st.st_mtime, (longest_int) st.st_size);
++              (void) sprintf(modstr, "%u %ld" , (unsigned int) st.st_mtime, (longest_int) st.st_size);
+               if (strcmp(modstr, mlp->line) == 0) {
+                       Trace(-1, "No changes made to \"%s\".\n", rpath);
+                       continue;
diff --git a/packages/ncftp/ncftp/make.patch b/packages/ncftp/ncftp/make.patch
new file mode 100644 (file)
index 0000000..78bc523
--- /dev/null
@@ -0,0 +1,39 @@
+Index: ncftp-3.2.0/Strn/Makefile.in
+===================================================================
+--- ncftp-3.2.0.orig/Strn/Makefile.in  2006-12-18 22:11:48.000000000 +0100
++++ ncftp-3.2.0/Strn/Makefile.in       2006-12-18 22:12:48.000000000 +0100
+@@ -42,7 +42,7 @@
+ static: $(LIB)
+ $(LIB): $(OBJS)
+-      @CCDV@@AR@ r $(LIB) $(OBJS)
++      @CCDV@$(AR) r $(LIB) $(OBJS)
+       -@chmod 644 "$(LIB)"
+       -@RANLIB@ "$(LIB)"
+       -@echo "$(VER)" > Strn.version
+Index: ncftp-3.2.0/sio/Makefile.in
+===================================================================
+--- ncftp-3.2.0.orig/sio/Makefile.in   2006-12-18 22:15:39.000000000 +0100
++++ ncftp-3.2.0/sio/Makefile.in        2006-12-18 22:15:56.000000000 +0100
+@@ -51,7 +51,7 @@
+ $(LIB): $(OBJS)
+       -@/bin/rm -f $(LIB)
+-      @CCDV@@AR@ r $(LIB) $(OBJS)
++      @CCDV@$(AR) r $(LIB) $(OBJS)
+       -@RANLIB@ $(LIB)
+       -@echo $(VER) > sio.version
+       -@chmod a+r $(LIB) sio.h usio.h
+Index: ncftp-3.2.0/libncftp/Makefile.in
+===================================================================
+--- ncftp-3.2.0.orig/libncftp/Makefile.in      2006-12-18 22:16:42.000000000 +0100
++++ ncftp-3.2.0/libncftp/Makefile.in   2006-12-18 22:16:56.000000000 +0100
+@@ -49,7 +49,7 @@
+ $(LIB): $(OBJS)
+       -@/bin/rm -f $(LIB)
+-      @CCDV@@AR@ r $(LIB) $(OBJS)
++      @CCDV@$(AR) r $(LIB) $(OBJS)
+       -@chmod 644 $(LIB)
+       -@@RANLIB@ $(LIB)
+       @/bin/ls -l $(LIB)
diff --git a/packages/ncftp/ncftp_3.1.7.bb b/packages/ncftp/ncftp_3.1.7.bb
deleted file mode 100644 (file)
index 99673d8..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "A sophisticated console ftp client"
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "ClarifiedArtistic"
-SRC_URI = "ftp://ftp.ncftp.com/ncftp/ncftp-${PV}-src.tar.bz2 \
-          file://acinclude.m4"
-
-inherit autotools
-
-do_configure_prepend () {
-       install -m 0644 ${WORKDIR}/acinclude.m4 acinclude.m4
-}
-
-do_install () {
-       install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}
-       oe_runmake 'prefix=${D}${prefix}' 'BINDIR=${D}${bindir}' \
-                  'SYSCONFDIR=${D}${sysconfdir}' 'mandir=${D}${mandir}' \
-                  install
-}
diff --git a/packages/ncftp/ncftp_3.1.8.bb b/packages/ncftp/ncftp_3.1.8.bb
deleted file mode 100644 (file)
index 99673d8..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "A sophisticated console ftp client"
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "ClarifiedArtistic"
-SRC_URI = "ftp://ftp.ncftp.com/ncftp/ncftp-${PV}-src.tar.bz2 \
-          file://acinclude.m4"
-
-inherit autotools
-
-do_configure_prepend () {
-       install -m 0644 ${WORKDIR}/acinclude.m4 acinclude.m4
-}
-
-do_install () {
-       install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}
-       oe_runmake 'prefix=${D}${prefix}' 'BINDIR=${D}${bindir}' \
-                  'SYSCONFDIR=${D}${sysconfdir}' 'mandir=${D}${mandir}' \
-                  install
-}
diff --git a/packages/ncftp/ncftp_3.1.9.bb b/packages/ncftp/ncftp_3.1.9.bb
deleted file mode 100644 (file)
index 690c7eb..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "A sophisticated console ftp client"
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "ClarifiedArtistic"
-PR = "r1"
-
-SRC_URI = "ftp://ftp.ncftp.com/ncftp/older_versions/ncftp-${PV}-src.tar.gz \
-          file://acinclude.m4"
-
-inherit autotools
-
-do_configure_prepend () {
-       install -m 0644 ${WORKDIR}/acinclude.m4 acinclude.m4
-}
-
-INHIBIT_AUTO_STAGE = "1"
-
-do_install () {
-       install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}
-       oe_runmake 'prefix=${D}${prefix}' 'BINDIR=${D}${bindir}' \
-                  'SYSCONFDIR=${D}${sysconfdir}' 'mandir=${D}${mandir}' \
-                  install
-}
diff --git a/packages/ncftp/ncftp_3.2.0.bb b/packages/ncftp/ncftp_3.2.0.bb
new file mode 100644 (file)
index 0000000..ce87846
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "A sophisticated console ftp client"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "ClarifiedArtistic"
+
+SRC_URI = "ftp://ftp.ncftp.com/ncftp/ncftp-${PV}-src.tar.bz2 \
+          file://acinclude.m4 \
+          file://make.patch;patch=1 \
+          file://fixes.patch;patch=1"
+
+inherit autotools
+
+do_configure_prepend () {
+       install -m 0644 ${WORKDIR}/acinclude.m4 acinclude.m4
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install () {
+       install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}
+       oe_runmake 'prefix=${D}${prefix}' 'BINDIR=${D}${bindir}' \
+                  'SYSCONFDIR=${D}${sysconfdir}' 'mandir=${D}${mandir}' \
+                  install
+}
index 6db5a6c..85f6f4a 100644 (file)
@@ -127,7 +127,7 @@ glib_cv_va_val_copy=${glib_cv_va_val_copy=yes}
 glib_cv_rtldglobal_broken=${glib_cv_rtldglobal_broken=yes}
 
 # glib-2.0
-glib_cv_stack_grows=${glib_cv_stack_grows=no}
+glib_cv_stack_grows=no
 utils_cv_sys_open_max=${utils_cv_sys_open_max=1015}
 ac_cv_func_posix_getpwuid_r=${ac_cv_func_posix_getpwuid_r=yes}
 glib_cv_use_pid_surrogate=${glib_cv_use_pid_surrogate=yes}