Prevent the loop in timespec_add_ns() to be optimised away
authorKhem Raj <raj.khem@gmail.com>
Thu, 29 May 2008 00:53:13 +0000 (00:53 +0000)
committerKhem Raj <raj.khem@gmail.com>
Thu, 29 May 2008 00:53:13 +0000 (00:53 +0000)
packages/linux/linux-omap1-2.6.24-omap1/timespec_add_ns_avoid_udivdi3.patch [new file with mode: 0644]
packages/linux/linux-omap1_2.6.24-omap1.bb

diff --git a/packages/linux/linux-omap1-2.6.24-omap1/timespec_add_ns_avoid_udivdi3.patch b/packages/linux/linux-omap1-2.6.24-omap1/timespec_add_ns_avoid_udivdi3.patch
new file mode 100644 (file)
index 0000000..4aba897
--- /dev/null
@@ -0,0 +1,20 @@
+Backport of this patch here
+
+http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg270684.html
+
+Needed for 2.6.24 to compile with gcc 4.3
+Index: linux-2.6.24/include/linux/time.h
+===================================================================
+--- linux-2.6.24.orig/include/linux/time.h     2008-05-28 15:39:46.000000000 -0700
++++ linux-2.6.24/include/linux/time.h  2008-05-28 15:40:48.000000000 -0700
+@@ -173,6 +173,10 @@
+ {
+       ns += a->tv_nsec;
+       while(unlikely(ns >= NSEC_PER_SEC)) {
++              /* The following asm() prevents the compiler from
++              * optimising this loop into a modulo operation.  */
++              asm("" : "+r"(ns));
++
+               ns -= NSEC_PER_SEC;
+               a->tv_sec++;
+       }
index f5ed1a4..2f2076b 100644 (file)
@@ -5,6 +5,7 @@ COMPATIBLE_MACHINE = "omap5912osk"
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
            http://www.muru.com/linux/omap/patches/patch-2.6.24-omap1.bz2;patch=1 \
            file://binutils-buildid-arm.patch;patch=1 \
+           file://timespec_add_ns_avoid_udivdi3.patch;patch=1 \
           file://defconfig"
 
 S = "${WORKDIR}/linux-2.6.24"