omap3-sgx-modules: add compile fix for DSS2 changes in linux-omap 2.6.29
authorKoen Kooi <koen@openembedded.org>
Wed, 8 Apr 2009 08:07:11 +0000 (10:07 +0200)
committerKoen Kooi <koen@openembedded.org>
Wed, 8 Apr 2009 08:07:11 +0000 (10:07 +0200)
recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb

index fc9f02f..3f9a3cd 100644 (file)
@@ -14,7 +14,10 @@ PVRBUILD = "release"
 MAKE_TARGETS = " BUILD=${PVRBUILD}"
 
 do_compile_prepend() {
-       find ${S} -name "*.*o" | xargs rm
+       find ${S} -name "*.*o" | xargs rm || true
+       if [ $(echo ${KERNEL_VERSION} | cut -c5,6) -gt 28 ] ; then
+               sed -i -e 's:omap_dispc_unregister_isr(OMAPLFBVSyncISR):omap_dispc_unregister_isr(OMAPLFBVSyncISR, psSwapChain, DISPC_IRQ_VSYNC):g' services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
+       fi
 }
 
 do_install() {