gsm0710muxd svn update to 283, including Marcel Holtmann's patches. Ship init script...
authorMichael Lauer <mickey@vanille-media.de>
Tue, 29 Apr 2008 13:34:30 +0000 (13:34 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Tue, 29 Apr 2008 13:34:30 +0000 (13:34 +0000)
it (alternative to dbus system activation)

conf/distro/include/sane-srcrevs.inc
packages/freesmartphone/gsm0710muxd_svn.bb

index 381a612..9604798 100644 (file)
@@ -37,7 +37,7 @@ SRCREV_pn-fstests ?= "204"
 SRCREV_pn-gconf-dbus ?= "641"
 SRCREV_pn-gnuradio ?= "6377"
 SRCREV_pn-gpe-contacts ?= "9312"
-SRCREV_pn-gsm0710muxd ?= "263"
+SRCREV_pn-gsm0710muxd ?= "283"
 SRCREV_pn-gtkhtml2 ?= "1158"
 SRCREV_pn-gypsy ?= "134"
 SRCREV_pn-hildon-1 ?= "14429"
index 09b3b8c..07eac3c 100644 (file)
@@ -2,32 +2,22 @@ DESCRIPTION = "GSM 07.10 muxer userspace daemon"
 HOMEPAGE = "http://www.freesmartphone.org"
 AUTHOR = "M. Dietrich"
 SECTION = "console/network"
-DEPENDS = "intltool-native dbus dbus-glib"
+DEPENDS = "dbus dbus-glib"
 RDEPENDS = "dbus dbus-glib"
 LICENSE = "GPL"
-PV = "0.9.0+svnr${SRCREV}"
-PR = "r0"
+PV = "0.9.1+svnr${SRCREV}"
+PR = "r1"
 
 SRC_URI = "svn://projects.linuxtogo.org/svn/smartphones/trunk/software;module=gsm0710muxd"
 S = "${WORKDIR}/gsm0710muxd"
 
 inherit autotools
 
+# install init script for people who want to manually
+# start/stop it, but don't add runlevels.
 do_install_append() {
-       # temp hack
-       mv -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.GSM.MUX.service ${D}${datadir}/dbus-1/system-services/org.mobile.mux.service
+       install -d ${D}${sysconfdir}/init.d
+       install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
 }
 
-pkg_postinst_${PN}() {
-       # can't do this offline
-       if [ "x$D" != "x" ]; then
-               exit 1
-       fi
-       # reload dbus configuration files
-       for i in `pidof dbus-daemon`; do
-               kill -SIGHUP $i
-       done
-}
-
-FILES_${PN} += "${datadir}"
-
+FILES_${PN} += "${datadir} ${sysconfdir}"