change nand map of duo
authorschon <schon@dev03-server>
Thu, 29 Sep 2011 08:28:06 +0000 (17:28 +0900)
committerschon <schon@dev03-server>
Thu, 29 Sep 2011 08:28:06 +0000 (17:28 +0900)
update beta driver

recipes/linux/linux-bm750-2.6.18/NOTE_ON_bm750_defconfig
recipes/linux/linux-bm750-2.6.18/linux_bm750_nand.patch
recipes/vuplus/vuplus-dvb-modules.bb

index 9feff31..fae5ffd 100644 (file)
@@ -1,2 +1,5 @@
 Duo's kernel size should be smaller than 2*1024*1024.
 Considering bad block existence, kernel size is recommended to be smaller than 2*1024*1024 - (128*1024*2)
+
+As of 201110xx, new cfe allowing larger kernel size up to 4M has been released.
+Consequently kernel size limit has been deprecated.
index 32cbf75..7c7e987 100644 (file)
@@ -152,11 +152,11 @@ Index: drivers/mtd/brcmnand/bcm7xxx-nand.c
 +#define ROOTFS_PART     (0)
 +        { name: "rootfs",               offset: 0,              size: DEFAULT_ROOTFS_SIZE },   /* rootfs is total nand size - 6 M Bytes. referr to cfe. bcm97335_devs.c */ 
 +#ifndef USE_SPLASH /* csh splash */
-+        { name: "kernel",       offset: 0x00600000,             size: 2<<20 },        
-+        { name: "boot",       offset: 0x00800000,             size: 4<<20 },
++        { name: "kernel",       offset: 0x00600000,             size: 4<<20 },        
++        { name: "boot",       offset: 0x00800000,             size: 2<<20 },
 +#else
-+        { name: "kernel",       offset: 0x00500000,             size: 2<<20 },        
-+        { name: "boot",       offset: 0x00700000,             size: 4<<20 },
++        { name: "kernel",       offset: 0x00500000,             size: 4<<20 },        
++        { name: "boot",       offset: 0x00700000,             size: 2<<20 },
 +        { name: "bootimg",       offset: 0x00B00000,             size: DEFAULT_SPLASH_SIZE },
  #endif
 +#if 0 /*12 09 */
index 1d9414c..89aa6ff 100755 (executable)
@@ -17,10 +17,10 @@ PV_vusolo = "${KV}"
 PV_vuuno = "${KV}"
 PV_vuultimo = "${KV}"
 
-SRCDATE_bm750 = "20110817"
-SRCDATE_vusolo = "20110817"
-SRCDATE_vuuno = "20110817"
-SRCDATE_vuultimo = "20110915"
+SRCDATE_bm750 = "20110929"
+SRCDATE_vusolo = "20110929"
+SRCDATE_vuuno = "20110929"
+SRCDATE_vuultimo = "20110929"
 
 
 RDEPENDS = "initscripts-vuplus kernel (${KV}) kernel-module-firmware-class kernel-module-input kernel-module-evdev kernel-module-i2c-core kernel-module-snd kernel-module-snd-pcm"
@@ -31,7 +31,7 @@ DEPENDS = " module-init-tools"
 RDEPENDS_append_vuplus = " module-init-tools-depmod"
 
 
-SRC_URI = "http://archive.vuplus.com/download/drivers/vuplus-dvb-modules-${MACHINE}-${PV}-${PREFERRED_GCC_VERSION}-${SRCDATE}.tar.gz "
+SRC_URI = "http://archive.vuplus.com/download/drivers/beta/vuplus-dvb-modules-${MACHINE}-${PV}-${PREFERRED_GCC_VERSION}-${SRCDATE}.tar.gz "
 SRC_URI_vuultimo = "http://archive.vuplus.com/download/drivers/beta/vuplus-dvb-modules-${MACHINE}-${PV}-${PREFERRED_GCC_VERSION}-${SRCDATE}.tar.gz "
 
 S = "${WORKDIR}"