irda-utils 0.9.16: write out /etc/sysconfig/irda in the init script, rather
authorMatt Reimer <mattjreimer@gmail.com>
Thu, 9 Feb 2006 19:00:50 +0000 (19:00 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 9 Feb 2006 19:00:50 +0000 (19:00 +0000)
than in postinst.

packages/irda-utils/files/init
packages/irda-utils/irda-utils_0.9.16.bb

index f1594aa..e7163d3 100755 (executable)
@@ -1,6 +1,34 @@
 #! /bin/sh
 
-# Source IrDA networking configuration.
+module_id() {
+        awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
+}
+
+if [ ! -f /etc/sysconfig/irda ]; then
+
+    case `module_id` in
+       "HP iPAQ H2200" | "HP iPAQ HX4700")
+           IRDA=yes
+           DEVICE=/dev/tts/2
+           DONGLE=
+           DISCOVERY=
+           ;;
+       *)
+           IRDA=yes
+           DEVICE=/dev/ttyS1
+           DONGLE=
+           DISCOVERY=
+           ;;
+    esac
+
+    echo "IRDA=$IRDA" > /etc/sysconfig/irda
+    if [ $IRDA = "yes" ]; then
+       echo "DEVICE=$DEVICE" >> /etc/sysconfig/irda
+       echo "DONGLE=$DONGLE" >> /etc/sysconfig/irda
+       echo "DISCOVERY=$DISCOVERY" >> /etc/sysconfig/irda
+    fi
+fi
+
 . /etc/sysconfig/irda
 
 # Check that irda is up.
index 4acfeff..1753edc 100644 (file)
@@ -3,7 +3,7 @@ IrDA allows communication over Infrared with other devices \
 such as phones and laptops."
 SECTION = "base"
 LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
           file://configure.patch;patch=1 \
@@ -30,36 +30,3 @@ do_install () {
        install -d ${D}${sysconfdir}/init.d
        install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/irattach
 }
-
-pkg_postinst () {
-#!/bin/sh
-
-module_id() {
-    awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
- }
-
-if [ ! -f /etc/sysconfig/irda ]; then
-
-  case `module_id` in
-    "HP iPAQ H2200" | "HP iPAQ HX4700")
-       IRDA=yes
-       DEVICE=/dev/tts/2
-       DONGLE=
-       DISCOVERY=
-       ;;
-    *)
-       IRDA=yes
-       DEVICE=/dev/ttyS1
-       DONGLE=
-       DISCOVERY=
-        ;;
-  esac
-
-  echo "IRDA=$IRDA" > /etc/sysconfig/irda
-  if [ $IRDA = "yes" ]; then
-    echo "DEVICE=$DEVICE" >> /etc/sysconfig/irda
-    echo "DONGLE=$DONGLE" >> /etc/sysconfig/irda
-    echo "DISCOVERY=$DISCOVERY" >> /etc/sysconfig/irda
-  fi
-fi
-}