python-setuptools[-native] 0.6c8 fix log usage bug
authorMichael Lauer <mickey@vanille-media.de>
Thu, 24 Jul 2008 08:51:40 +0000 (08:51 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Thu, 24 Jul 2008 08:51:40 +0000 (08:51 +0000)
packages/python/python-setuptools-native_0.6c8.bb
packages/python/python-setuptools/.mtn2git_empty [new file with mode: 0644]
packages/python/python-setuptools/fix-log-usage.patch [new file with mode: 0644]
packages/python/python-setuptools_0.6c8.bb

index b7716d8..0bbf9c3 100644 (file)
@@ -1,9 +1,9 @@
 require python-setuptools_${PV}.bb
 inherit native
 
+FILESPATH = "${FILE_DIRNAME}/python-setuptools"
 DEPENDS = "python-native"
 
 do_stage() {
-    BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-      ${STAGING_BINDIR_NATIVE}/python setup.py install
+       distutils_stage_all
 }
diff --git a/packages/python/python-setuptools/.mtn2git_empty b/packages/python/python-setuptools/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/python/python-setuptools/fix-log-usage.patch b/packages/python/python-setuptools/fix-log-usage.patch
new file mode 100644 (file)
index 0000000..6363c85
--- /dev/null
@@ -0,0 +1,13 @@
+Index: setuptools-0.6c8/setuptools/command/sdist.py
+===================================================================
+--- setuptools-0.6c8.orig/setuptools/command/sdist.py
++++ setuptools-0.6c8/setuptools/command/sdist.py
+@@ -95,7 +95,7 @@ def entries_finder(dirname, filename):
+         for match in entries_pattern.finditer(data):
+             yield joinpath(dirname,unescape(match.group(1)))
+     else:
+-        log.warn("unrecognized .svn/entries format in %s", dirname)
++        print ("unrecognized .svn/entries format in %s", dirname)
+ finders = [
index 19f73d3..5b82ece 100644 (file)
@@ -5,9 +5,12 @@ PRIORITY = "optional"
 LICENSE = "MIT-like"
 RDEPENDS = "python-distutils python-compression"
 SRCNAME = "setuptools"
-PR = "ml0"
+PR = "ml1"
 
-SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
+SRC_URI = "\
+  http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+  file://fix-log-usage.patch;patch=1 \
+"
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils