coreutils: added 6.0 (DEF_PREF=-1)
authorMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 2 Apr 2007 09:57:41 +0000 (09:57 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 2 Apr 2007 09:57:41 +0000 (09:57 +0000)
packages/coreutils/coreutils-6.0/.mtn2git_empty [new file with mode: 0644]
packages/coreutils/coreutils-6.0/man.patch [new file with mode: 0644]
packages/coreutils/coreutils-6.0/oe-old-tools.patch [new file with mode: 0644]
packages/coreutils/coreutils-6.0/onceonly.m4 [new file with mode: 0644]
packages/coreutils/coreutils-6.0/uptime-pow-lib.patch [new file with mode: 0644]
packages/coreutils/coreutils-native_6.0.bb [new file with mode: 0644]
packages/coreutils/coreutils_6.0.bb [new file with mode: 0644]

diff --git a/packages/coreutils/coreutils-6.0/.mtn2git_empty b/packages/coreutils/coreutils-6.0/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/coreutils/coreutils-6.0/man.patch b/packages/coreutils/coreutils-6.0/man.patch
new file mode 100644 (file)
index 0000000..5060e4f
--- /dev/null
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- coreutils-5.3.0/configure.ac~man
++++ coreutils-5.3.0/configure.ac
+@@ -237,6 +237,20 @@
+ AM_GNU_GETTEXT([external], [need-ngettext])
+ AM_GNU_GETTEXT_VERSION(0.13.1)
++AC_MSG_CHECKING([whether to build man pages])
++AC_ARG_WITH(manpages, 
++      AS_HELP_STRING([--with-manpages],
++              [Enable building of manpages (default=yes)]),
++      [cu_cv_build_manpages=$enableval],
++      [cu_cv_build_manpages=yes])
++# help2man doesn't work when crosscompiling, as it needs to run the
++# binary that was built.
++if test x"$cross_compiling" = x"yes"; then
++  cu_cv_build_manpages=no
++fi
++AC_MSG_RESULT($cu_cv_build_manpages)
++AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
++
+ AC_CONFIG_FILES(
+   Makefile
+   doc/Makefile
+--- coreutils-5.3.0/Makefile.am~man
++++ coreutils-5.3.0/Makefile.am
+@@ -1,6 +1,11 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
++if ENABLE_MANPAGES
+ SUBDIRS = lib src doc man po tests
++else
++SUBDIRS = lib src doc po tests
++endif
++
+ EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
+   .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
+   .x-sc_space_tab .x-sc_sun_os_names \
diff --git a/packages/coreutils/coreutils-6.0/oe-old-tools.patch b/packages/coreutils/coreutils-6.0/oe-old-tools.patch
new file mode 100644 (file)
index 0000000..495da36
--- /dev/null
@@ -0,0 +1,26 @@
+Index: coreutils-6.0/configure.ac
+===================================================================
+--- coreutils-6.0.orig/configure.ac    2007-04-02 11:21:27.000000000 +0200
++++ coreutils-6.0/configure.ac 2007-04-02 11:21:36.000000000 +0200
+@@ -26,7 +26,7 @@
+ AC_CONFIG_HEADERS([config.h:config.hin])
+ AB_INIT()
+-AM_INIT_AUTOMAKE([1.9.6 gnits dist-bzip2])
++AM_INIT_AUTOMAKE([1.9.3 gnits dist-bzip2])
+ gl_DEFAULT_POSIX2_VERSION
+ gl_USE_SYSTEM_EXTENSIONS
+Index: coreutils-6.0/m4/jm-macros.m4
+===================================================================
+--- coreutils-6.0.orig/m4/jm-macros.m4 2007-04-02 11:21:54.000000000 +0200
++++ coreutils-6.0/m4/jm-macros.m4      2007-04-02 11:22:02.000000000 +0200
+@@ -23,7 +23,7 @@
+ AC_DEFUN([gl_MACROS],
+ [
+-  AC_PREREQ(2.60)
++  AC_PREREQ(2.59)
+   GNU_PACKAGE="GNU $PACKAGE"
+   AC_DEFINE_UNQUOTED(GNU_PACKAGE, "$GNU_PACKAGE",
diff --git a/packages/coreutils/coreutils-6.0/onceonly.m4 b/packages/coreutils/coreutils-6.0/onceonly.m4
new file mode 100644 (file)
index 0000000..f6fec37
--- /dev/null
@@ -0,0 +1,63 @@
+# onceonly.m4 serial 3
+dnl Copyright (C) 2002, 2003 Free Software Foundation, Inc.
+dnl This file is free software, distributed under the terms of the GNU
+dnl General Public License.  As a special exception to the GNU General
+dnl Public License, this file may be distributed as part of a program
+dnl that contains a configuration script generated by Autoconf, under
+dnl the same distribution terms as the rest of that program.
+
+dnl This file defines some "once only" variants of standard autoconf macros.
+dnl   AC_CHECK_HEADERS_ONCE         like  AC_CHECK_HEADERS
+dnl   AC_CHECK_FUNCS_ONCE           like  AC_CHECK_FUNCS
+dnl   AC_CHECK_DECLS_ONCE           like  AC_CHECK_DECLS
+dnl   AC_REQUIRE([AC_HEADER_STDC])  like  AC_HEADER_STDC
+dnl The advantage is that the check for each of the headers/functions/decls
+dnl will be put only once into the 'configure' file. It keeps the size of
+dnl the 'configure' file down, and avoids redundant output when 'configure'
+dnl is run.
+dnl The drawback is that the checks cannot be conditionalized. If you write
+dnl   if some_condition; then gl_CHECK_HEADERS(stdlib.h); fi
+dnl inside an AC_DEFUNed function, the gl_CHECK_HEADERS macro call expands to
+dnl empty, and the check will be inserted before the body of the AC_DEFUNed
+dnl function.
+
+dnl Autoconf version 2.57 or newer is recommended.
+AC_PREREQ(2.54)
+
+# AC_CHECK_HEADERS_ONCE(HEADER1 HEADER2 ...) is a once-only variant of
+# AC_CHECK_HEADERS(HEADER1 HEADER2 ...).
+AC_DEFUN([AC_CHECK_HEADERS_ONCE], [
+  :
+  AC_FOREACH([gl_HEADER_NAME], [$1], [
+    AC_DEFUN([gl_CHECK_HEADER_]m4_quote(translit(defn([gl_HEADER_NAME]),
+                                                 [-./], [___])), [
+      AC_CHECK_HEADERS(gl_HEADER_NAME)
+    ])
+    AC_REQUIRE([gl_CHECK_HEADER_]m4_quote(translit(gl_HEADER_NAME,
+                                                   [-./], [___])))
+  ])
+])
+
+# AC_CHECK_FUNCS_ONCE(FUNC1 FUNC2 ...) is a once-only variant of
+# AC_CHECK_FUNCS(FUNC1 FUNC2 ...).
+AC_DEFUN([AC_CHECK_FUNCS_ONCE], [
+  :
+  AC_FOREACH([gl_FUNC_NAME], [$1], [
+    AC_DEFUN([gl_CHECK_FUNC_]defn([gl_FUNC_NAME]), [
+      AC_CHECK_FUNCS(defn([gl_FUNC_NAME]))
+    ])
+    AC_REQUIRE([gl_CHECK_FUNC_]defn([gl_FUNC_NAME]))
+  ])
+])
+
+# AC_CHECK_DECLS_ONCE(DECL1 DECL2 ...) is a once-only variant of
+# AC_CHECK_DECLS(DECL1, DECL2, ...).
+AC_DEFUN([AC_CHECK_DECLS_ONCE], [
+  :
+  AC_FOREACH([gl_DECL_NAME], [$1], [
+    AC_DEFUN([gl_CHECK_DECL_]defn([gl_DECL_NAME]), [
+      AC_CHECK_DECLS(defn([gl_DECL_NAME]))
+    ])
+    AC_REQUIRE([gl_CHECK_DECL_]defn([gl_DECL_NAME]))
+  ])
+])
diff --git a/packages/coreutils/coreutils-6.0/uptime-pow-lib.patch b/packages/coreutils/coreutils-6.0/uptime-pow-lib.patch
new file mode 100644 (file)
index 0000000..5eb3fca
--- /dev/null
@@ -0,0 +1,11 @@
+--- coreutils-5.3.0/src/Makefile.am.orig       2005-09-27 22:34:35.659272058 -0700
++++ coreutils-5.3.0/src/Makefile.am    2005-09-27 22:34:39.403507668 -0700
+@@ -74,7 +74,7 @@
+ sleep_LDADD = $(nanosec_libs)
+ tail_LDADD = $(nanosec_libs)
+-uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
++uptime_LDADD = $(LDADD) $(POW_LIB) $(GETLOADAVG_LIBS)
+ su_LDADD = $(LDADD) $(LIB_CRYPT)
diff --git a/packages/coreutils/coreutils-native_6.0.bb b/packages/coreutils/coreutils-native_6.0.bb
new file mode 100644 (file)
index 0000000..ee90981
--- /dev/null
@@ -0,0 +1,7 @@
+SECTION = "base"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/coreutils-${PV}"
+S = "${WORKDIR}/coreutils-${PV}"
+
+require coreutils_${PV}.bb
+inherit native
diff --git a/packages/coreutils/coreutils_6.0.bb b/packages/coreutils/coreutils_6.0.bb
new file mode 100644 (file)
index 0000000..59afd67
--- /dev/null
@@ -0,0 +1,85 @@
+require coreutils.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
+           file://man.patch;patch=1 \
+          file://oe-old-tools.patch;patch=1 \
+          file://onceonly.m4"
+
+# [ gets a special treatment and is not included in this
+bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
+               env expand expr factor fmt fold groups head hostid id install \
+               join link logname md5sum mkfifo nice nl nohup od paste pathchk \
+               pinky pr printenv printf ptx readlink seq sha1sum shred sort \
+               split stat sum tac tail tee test tr tsort tty unexpand uniq \
+               unlink users vdir wc who whoami yes \
+               "
+
+# hostname gets a special treatment and is not included in this
+base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
+                    ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
+                    true uname \
+                    "
+
+sbindir_progs= "chroot"
+
+do_configure_prepend() {
+       install -m 0644 ${WORKDIR}/onceonly.m4 ${S}/m4
+}
+
+do_install () {
+       autotools_do_install
+
+       # Renaming the utilities that should go in /usr/bin
+       for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
+
+       # Renaming and moving the utilities that should go in /bin (FHS)
+       install -d ${D}${base_bindir}
+       for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
+
+       # Renaming and moving the utilities that should go in /usr/sbin (FHS)
+       install -d ${D}${sbindir}
+       for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
+
+       # [ requires special handling because [.coreutils will cause the sed stuff
+       # in update-alternatives to fail, therefore use lbracket - the name used
+       # for the actual source file.
+       mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
+       # hostname and uptime separated. busybox's versions are preferred
+       mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
+       mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
+
+}
+
+pkg_postinst_${PN} () {
+       # The utilities in /usr/bin
+       for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
+
+       # The utilities in /bin
+       for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
+
+       # The utilities in /usr/sbin
+       for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
+
+       # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
+       update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
+       update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
+       update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
+}
+
+pkg_prerm_${PN} () {
+       # The utilities in /usr/bin
+       for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+       # The utilities in /bin
+       for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+       # The utilities in /usr/sbin
+       for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+       # The special cases
+       update-alternatives --remove hostname hostname.${PN}
+       update-alternatives --remove uptime uptime.${PN}
+       update-alternatives --remove '[' 'lbracket.${PN}'
+}