eglibc: Rework the glibc compat packages logic again.
authorTom Rini <trini@embeddedalley.com>
Wed, 18 Feb 2009 21:30:33 +0000 (16:30 -0500)
committerTom Rini <trini@embeddedalley.com>
Wed, 18 Feb 2009 21:30:33 +0000 (16:30 -0500)
We needed to use legitimize_package_name on our locale string.  So
we just take the eglibc package name that's been legitimized and change
it from 'eglibc...' to 'glibc...'

packages/eglibc/eglibc-package.bbclass
packages/eglibc/eglibc_2.9.bb
packages/eglibc/eglibc_svn.bb

index 74c9b73..7fcb558 100644 (file)
@@ -207,7 +207,7 @@ python package_do_split_gconvs () {
                f.close()
                if deps != []:
                        bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
-               bb.data.setVar('RPROVIDES_%s' % pkg, 'glibc-gconv-%s' % group.lower(), d)
+               bb.data.setVar('RPROVIDES_%s' % pkg, pkg.replace('eglibc', 'glibc'), d)
 
        do_split_packages(d, gconv_libdir, file_regex='^(.*)\.so$', output_pattern='eglibc-gconv-%s', description='gconv module for character set %s', hook=calc_gconv_deps, extra_depends='eglibc-gconv')
 
@@ -225,7 +225,7 @@ python package_do_split_gconvs () {
                f.close()
                if deps != []:
                        bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
-               bb.data.setVar('RPROVIDES_%s' % pkg, 'glibc-charmap-%s' % group.lower(), d)
+               bb.data.setVar('RPROVIDES_%s' % pkg, pkg.replace('eglibc', 'glibc'), d)
 
        do_split_packages(d, charmap_dir, file_regex='^(.*)\.gz$', output_pattern='eglibc-charmap-%s', description='character map for %s encoding', hook=calc_charmap_deps, extra_depends='')
 
@@ -243,7 +243,7 @@ python package_do_split_gconvs () {
                f.close()
                if deps != []:
                        bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
-               bb.data.setVar('RPROVIDES_%s' % pkg, 'glibc-localedata-%s' % group.lower(), d)
+               bb.data.setVar('RPROVIDES_%s' % pkg, pkg.replace('eglibc', 'glibc'), d)
 
        do_split_packages(d, locales_dir, file_regex='(.*)', output_pattern='eglibc-localedata-%s', description='locale definition for %s', hook=calc_locale_deps, extra_depends='')
        bb.data.setVar('PACKAGES', bb.data.getVar('PACKAGES', d) + ' eglibc-gconv', d)
index 7a71fcd..ecd21de 100644 (file)
@@ -4,7 +4,7 @@ DEPENDS += "gperf-native"
 DEFAULT_PREFERENCE = "1"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
 PV = "2.9"
-PR = "r3"
+PR = "r4"
 SVN_REV="7430"
 EGLIBC_BRANCH="eglibc-2_9"
 SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_9;rev=${SVN_REV};proto=svn \
index 9cf0393..a2d3e87 100644 (file)
@@ -5,7 +5,7 @@ SRCREV = "7542"
 # DEFAULT_PREFERENCE = "-1"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
 PV = "2.9+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
 EGLIBC_BRANCH="trunk"
 SRC_URI = "svn://svn.eglibc.org;module=trunk \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \