linux-omap_2.6.29.bb: added mmctiming patch
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Wed, 1 Apr 2009 18:31:15 +0000 (20:31 +0200)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Wed, 1 Apr 2009 18:31:15 +0000 (20:31 +0200)
recipes/linux/linux-omap-2.6.29/mmctiming.patch [new file with mode: 0644]
recipes/linux/linux-omap_2.6.29.bb

diff --git a/recipes/linux/linux-omap-2.6.29/mmctiming.patch b/recipes/linux/linux-omap-2.6.29/mmctiming.patch
new file mode 100644 (file)
index 0000000..ec540ab
--- /dev/null
@@ -0,0 +1,16 @@
+Index: git/drivers/mmc/core/core.c
+===================================================================
+--- git.orig/drivers/mmc/core/core.c
++++ git/drivers/mmc/core/core.c
+@@ -284,9 +284,9 @@ void mmc_set_data_timeout(struct mmc_dat
+                        * The limit is really 250 ms, but that is
+                        * insufficient for some crappy cards.
+                        */
+-                      limit_us = 300000;
++                      limit_us = 500000;
+               else
+-                      limit_us = 100000;
++                      limit_us = 200000;
+               /*
+                * SDHC cards always use these fixed values.
index a74bd62..0138e76 100644 (file)
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE = "-1"
 
 SRCREV = "90e758af52ba803cba233fabee81176d99589f09"
 
-PR = "r3+gitr${SRCREV}"
+PR = "r4+gitr${SRCREV}"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
           file://defconfig"
@@ -24,6 +24,7 @@ SRC_URI_append = " \
            file://0001-board-ldp-add-regulator-info-to-get-the-microSD-slo.patch;patch=1 \
            file://fix-unaligned-access.diff;patch=1 \
            file://make-alignment-visible.diff;patch=1 \
+           file://mmctiming.patch;patch=1 \
 "