libatasmart: add 0.13
authorKoen Kooi <koen@openembedded.org>
Thu, 21 May 2009 13:43:11 +0000 (15:43 +0200)
committerKoen Kooi <koen@openembedded.org>
Thu, 21 May 2009 13:43:11 +0000 (15:43 +0200)
recipes/devicekit/libatasmart_0.13.bb [new file with mode: 0644]

diff --git a/recipes/devicekit/libatasmart_0.13.bb b/recipes/devicekit/libatasmart_0.13.bb
new file mode 100644 (file)
index 0000000..31565f6
--- /dev/null
@@ -0,0 +1,20 @@
+LICENSE = "LGPL"
+
+SRCREV = "a80d7d5c25e88adea7b8e843cdb57143e6cfb46b"
+SRC_URI = "git://git.0pointer.de/libatasmart.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage lib_package
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_compile_prepend() {
+       rm strpool -f
+       ${BUILD_CC} -o strpool strpool.c
+       chmod +x strpool
+}
+
+do_stage_append() {
+       sed -i -e s://:/:g -e s:${base_libdir}/libudev.la:-ludev:g ${STAGING_LIBDIR}/libatasmart.la
+}
+