uboot-utils : Eliminate non-working builds. Package now builds and installs mkimage.
authorPhilip Balister <philip@balister.org>
Thu, 16 Aug 2007 21:42:39 +0000 (21:42 +0000)
committerPhilip Balister <philip@balister.org>
Thu, 16 Aug 2007 21:42:39 +0000 (21:42 +0000)
packages/uboot/uboot-utils_1.2.0.bb

index 8a5d7dc..89cc6a2 100644 (file)
@@ -2,22 +2,11 @@ DESCRIPTION = "U-boot bootloader OS env. access tools for PPC"
 SECTION = "bootloaders"
 PRIORITY = "optional"
 LICENSE = "GPL"
-DEPENDS = "mtd-utils"
-PR = "r5"
+PR = "r6"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/u-boot/u-boot-${PV}.tar.bz2 \
-        file://fw_env.c.patch;patch=1 \
-        file://tools-Makefile.patch;patch=1 \
-        file://env-Makefile.patch;patch=1 \
-        file://fw_env.config"
+SRC_URI = "${SOURCEFORGE_MIRROR}/u-boot/u-boot-${PV}.tar.bz2" 
 
 S = "${WORKDIR}/u-boot-${PV}"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-TARGET_LDFLAGS = ""
-
-UBOOT_MACHINE ?= "${MACHINE}_config"
-
-inherit base
 
 do_configure() {
        :
@@ -34,10 +23,3 @@ do_stage() {
        install -m 755 ${S}/tools/mkimage ${STAGING_BINDIR_NATIVE}/
 }
 
-do_install () {
-       install -d      ${D}/sbin
-       install -d      ${D}${sysconfdir}
-       install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
-       install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_printenv
-       install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
-}