Add some COMPATIBLE_MACHINE entries for various zaurus .bb files.
authorRichard Purdie <rpurdie@rpsys.net>
Mon, 24 Apr 2006 23:42:29 +0000 (23:42 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 24 Apr 2006 23:42:29 +0000 (23:42 +0000)
Also update python functions doing the same job to use COMPATIBLE_(MACHINE|HOST)

21 files changed:
packages/linux/devkitidp-pxa255-kernel_2.6.11.bb
packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
packages/linux/linux-omap-2.6_2.6.9-omap1.bb
packages/linux/linux-omap1_2.6.12-rc2.bb
packages/linux/linux-wrt_2.4.20.bb
packages/linux/linux-wrt_2.4.30.bb
packages/linux/mainstone-kernel_2.6.11.bb
packages/linux/nslu2-kernel.inc
packages/linux/nslu2-linksys-kernel_2.4.22.bb
packages/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb
packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc
packages/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb
packages/linux/poodle-kernels-2.4-embedix.bb
packages/linux/triton-kernel_2.6.11.bb
packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb
packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
packages/sharp-binary-only/sharp-flash-header-c700.bb
packages/sharp-binary-only/sharp-sdmmc-support.bb
packages/zaurus-updater/encdec-updater.bb
packages/zaurus-updater/zaurus-updater.bb

index 0b8b6ab..5df470a 100644 (file)
@@ -12,6 +12,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
 S = "${WORKDIR}/linux-2.6.11"
 
 COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "devkitidp-pxa255"
 
 inherit kernel
 inherit package
@@ -38,10 +39,3 @@ do_deploy() {
 do_deploy[dirs] = "${S}"
 
 addtask deploy before do_build after do_compile
-
-python () {
-       # Don't build kernel unless we're targeting an nslu2
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'devkitidp-pxa255':
-               raise bb.parse.SkipPackage("This kernel only builds for the PXA255 DevKitIDP")
-}
index c0b3bf2..846e5f4 100644 (file)
@@ -21,9 +21,4 @@ do_configure_prepend() {
         oe_runmake oldconfig
 }
 
-python __anonymous () {
-       import re
-       host = bb.data.getVar('HOST_SYS', d, 1)
-       if not re.match('arm.*-linux', host):
-               raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
+COMPATIBLE_HOST = 'arm.*-linux'
index 5cb4a43..feb9581 100644 (file)
@@ -10,12 +10,7 @@ S = "${WORKDIR}/linux-2.6.9"
 
 inherit kernel
 
-python __anonymous () {
-       import re
-       host = bb.data.getVar('HOST_SYS', d, 1)
-       if not re.match('arm.*-linux', host):
-               raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
+COMPATIBLE_HOST = 'arm.*-linux'
 
 KERNEL_IMAGETYPE = "uImage"
 
index 133fe9a..7ea9e16 100644 (file)
@@ -18,13 +18,7 @@ KERNEL_CCSUFFIX = "-3.3.4"
 
 inherit kernel
 
-python __anonymous () {
-       import re
-       host = bb.data.getVar('HOST_SYS', d, 1)
-       if not re.match('arm.*-linux', host):
-               raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
-
+COMPATIBLE_HOST = 'arm.*-linux'
 
 do_configure_prepend() {
        install -m 0644 ${WORKDIR}/defconfig ${S}/.config
index 8e49ffa..32361b7 100644 (file)
@@ -58,9 +58,4 @@ do_deploy[dirs] = "${S}"
 
 addtask deploy before do_build after do_compile
 
-python () {
-       # Don't build kernel unless we're targeting a wrt
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'wrt54':
-               raise bb.parse.SkipPackage("Unable to build for non-WRT54 device.")
-}
+COMPATIBLE_MACHINE = "wrt54"
index 0d9229c..352c879 100644 (file)
@@ -112,9 +112,4 @@ do_deploy[dirs] = "${S}"
 
 addtask deploy before do_build after do_compile
 
-python () {
-       # Don't build kernel unless we're targeting a wrt
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'wrt54':
-               raise bb.parse.SkipPackage("Unable to build for non-WRT54 device.")
-}
+COMPATIBLE_MACHINE = "wrt54"
index 12422c9..0e242c2 100644 (file)
@@ -36,9 +36,4 @@ do_deploy[dirs] = "${S}"
 
 addtask deploy before do_build after do_compile
 
-python () {
-       # Don't build kernel unless we're targeting a mainstone
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'mainstone':
-               raise bb.parse.SkipPackage("This kernel only builds for the Mainstone")
-}
+COMPATIBLE_MACHINE = "mainstone"
index b4c6752..bfae5f8 100644 (file)
@@ -257,9 +257,4 @@ do_deploy() {
 
 addtask deploy before do_build after do_compile
 
-python () {
-       # Don't build the kernel unless we're targeting an nslu2
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'nslu2':
-               raise bb.parse.SkipPackage("nslu2-kernel only builds for the Linksys NSLU2")
-}
+COMPATIBLE_MACHINE = "nslu2"
index 40bceb3..de2715d 100644 (file)
@@ -17,13 +17,8 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-2.4.22.tar.bz2 \
            file://defconfig"
 S = "${WORKDIR}/linux-2.4.22"
 
-python () {
-       # Don't build unless we're targeting an nslu2
-       if bb.data.getVar("MACHINE", d, 1) != "nslu2":
-               raise bb.parse.SkipPackage("NSLU2 kernel only builds for the Linksys NSLU2")
-}
-
 COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "nslu2"
 
 inherit kernel
 
index d9addd9..eae524a 100644 (file)
@@ -75,6 +75,7 @@ EXTRA_OEMAKE = "OPENZAURUS_RELEASE=-${DISTRO_VERSION}"
 KERNEL_CCSUFFIX = "-2.95"
 KERNEL_LDSUFFIX = "-2.11.2"
 COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = '(akita|spitz|borzoi)'
 PARALLEL_MAKE = ""
 
 #
index 4c8b431..3b0024d 100644 (file)
@@ -89,6 +89,7 @@ EXTRA_OEMAKE = " EMBEDIXRELEASE=-${DISTRO_VERSION}"
 KERNEL_CCSUFFIX = "-2.95"
 KERNEL_LDSUFFIX = "-2.11.2"
 COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = '(c7x0|corgi|husky|shepherd|poodle|poodle255)'
 PARALLEL_MAKE = ""
 
 #
index f600acb..a79d4f3 100644 (file)
@@ -57,6 +57,7 @@ ALLOW_EMPTY = 1
 KERNEL_CCSUFFIX = "-2.95"
 KERNEL_LDSUFFIX = "-2.11.2"
 COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "collie"
 EXTRA_OEMAKE = " EMBEDIXRELEASE=-${DISTRO_VERSION}"
 
 module_conf_usbdmonitor = "alias usbd0 usbdmonitor"
index e21a47a..7a714b7 100644 (file)
@@ -1 +1,2 @@
+COMPATIBLE_MACHINE = "poodle"
 DEPENDS = "poodle-kernel-2.4-embedix poodle255-kernel-2.4-embedix"
index 6fc575c..e42dfa2 100644 (file)
@@ -37,9 +37,4 @@ do_deploy[dirs] = "${S}"
 
 addtask deploy before do_build after do_compile
 
-python () {
-       # Don't build kernel unless we're targeting an triton
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'triton':
-               raise bb.parse.SkipPackage("The triton kernel is only for use on triton machines")
-}
+COMPATIBLE_MACHINE = "triton"
index 8aa07e8..c397a90 100644 (file)
@@ -28,9 +28,4 @@ SRC_URI += "file://linux-kernel-R25_to_R29.patch;patch=1 \
 
 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-kernel', '${FILE_DIRNAME}/nslu2-linksys-kernel-2.4.22', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
 
-python () {
-       # Don't build unslung kernel unless we're targeting an nslu2
-       mach = bb.data.getVar("MACHINE", d, 1)
-       if mach != 'nslu2':
-               raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
-}
+COMPATIBLE_MACHINE = "nslu2"
index beb00d5..f7a04cf 100644 (file)
@@ -13,6 +13,7 @@ S = "${WORKDIR}/AtiCore-1.0.1"
 EXTRA_OEMAKE="CC='${CC}' AS='${AS}' AR='${AR}' LD='${LD}' FPU='${TARGET_FPU}'"
 
 PARALLEL_MAKE = ""
+COMPATIBLE_MACHINE = 'c7x0'
 
 do_install() {
        install -d ${D}${bindir}
index 50301aa..fb886a2 100644 (file)
@@ -12,6 +12,8 @@ SRC_URI = "http://openzaurus.sf.net/mirror/camera-modules-2.4.18-rmk7-pxa3-embed
            file://sharpzdc.conf"
 S = "${WORKDIR}"
 
+COMPATIBLE_MACHINE = '(collie|poodle|tosa)'
+
 inherit module-base
 
 do_install() {
index c028824..789c7c2 100644 (file)
@@ -1,6 +1,7 @@
 SECTION = "base"
 SRC_URI = "file://header-c700.bin"
 LICENSE = "sharp-binary-only"
+COMPATIBLE_MACHINE = '(c7x0|spitz|akita)'
 do_stage() {
        install -d ${STAGING_LIBDIR}/sharp-flash-header
        install -m 0644 ${WORKDIR}/header-c700.bin ${STAGING_LIBDIR}/sharp-flash-header/header-c700.bin
index fa4e66e..6072c94 100644 (file)
@@ -7,6 +7,8 @@ RDEPENDS = "kernel (${PV})"
 PR = "r23"
 PACKAGE_ARCH = "${MACHINE}"
 
+COMPATIBLE_MACHINE = '(collie|poodle|tosa)'
+
 KERNEL2418 = "2.4.18-rmk7-pxa3-embedix"
 KERNEL2420 = "2.4.20"
 
index 49371a6..797a762 100644 (file)
@@ -4,6 +4,8 @@ DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh skript"
 
 SRC_URI = "file://encdec-updater.c"
 
+COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
+
 do_compile() {
        ${CC} -o encdec-updater ${WORKDIR}/encdec-updater.c
 }
index 21c15c7..0040ebe 100644 (file)
@@ -5,6 +5,7 @@ PR = "r4"
 
 PACKAGES = ""
 PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
 
 SRC_URI = "file://updater.sh \
            file://gnu-tar.gz"