gpe-nmf: Add patch to fix segfault allpying the playlist.
authorFlorian Boor <florian.boor@kernelconcepts.de>
Tue, 24 Jan 2006 16:34:41 +0000 (16:34 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 24 Jan 2006 16:34:41 +0000 (16:34 +0000)
packages/gpe-nmf/gpe-nmf-0.22/.mtn2git_empty [new file with mode: 0644]
packages/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch [new file with mode: 0644]
packages/gpe-nmf/gpe-nmf_0.22.bb

diff --git a/packages/gpe-nmf/gpe-nmf-0.22/.mtn2git_empty b/packages/gpe-nmf/gpe-nmf-0.22/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch b/packages/gpe-nmf/gpe-nmf-0.22/playlist-segfault.patch
new file mode 100644 (file)
index 0000000..01ceec1
--- /dev/null
@@ -0,0 +1,27 @@
+Index: playlist_edit.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-nmf/playlist_edit.c,v
+retrieving revision 1.21
+retrieving revision 1.22
+diff -B -b -u -r1.21 -r1.22
+--- playlist_edit.c    8 Jul 2005 14:40:33 -0000       1.21
++++ playlist_edit.c    11 Jan 2006 23:23:32 -0000      1.22
+@@ -172,8 +172,16 @@
+   if (fe->current_path)
+       g_free(fe->current_path);
+-  fe->current_path = isdir(s) ? g_strdup(s) : g_path_get_dirname (s);
+-      strcat(fe->current_path,"/");
++  if (isdir (s))
++    {
++      fe->current_path = g_strdup_printf ("%s/", s);
++    }
++  else
++    {
++      gchar *dir = g_path_get_dirname (s);
++      fe->current_path = g_strdup_printf ("%s/", dir);
++      g_free (dir);
++    }
+   
+   fe->fs_open = FALSE;
index 06c115a..d90c424 100644 (file)
@@ -17,9 +17,11 @@ RRECOMMENDS = "gst-plugin-mad \
        gst-plugin-ivorbis \
        gst-plugin-tcp"
 
+SRC_URI += " file://playlist-segfault.patch;patch=1;pnum=0"
+
 SECTION = "gpe"
 PRIORITY = "optional"
-PR = "r0"
+PR = "r1"
 
 PARALLEL_MAKE=""