obexftp: update to version 0.22
authorHenning Heinold <heinold@inf.fu-berlin.de>
Mon, 23 Jun 2008 18:52:40 +0000 (18:52 +0000)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Mon, 23 Jun 2008 18:52:40 +0000 (18:52 +0000)
* libgsm code is now in another package
* adjust DEPENDS

packages/obexftp/obexftp_0.20.bb
packages/obexftp/obexftp_0.22.bb [new file with mode: 0644]

index 386e83d..2a0b310 100644 (file)
@@ -2,17 +2,17 @@ DESCRIPTION = "OBEX Ftp Client based on openobex."
 SECTION = "console/network"
 HOMEPAGE = "http://openobex.triq.net"
 LICENSE = "GPL"
-DEPENDS = "openobex libgsm virtual/libiconv"
-PR = "r3"
+DEPENDS = "openobex libgsm"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.gz \
           file://iconv.patch;patch=1 \
           file://i-hate-libtool.patch;patch=1 \
           file://m4.patch;patch=1"
 
-inherit autotools
+inherit autotools gettext
 
-EXTRA_OECONF = "--enable-bluetooth --disable-swig --disable-perl --disable-python --disable-tcl --disable-builddocs"
+EXTRA_OECONF += "--enable-bluetooth --disable-swig --disable-perl --disable-python --disable-tcl --disable-builddocs --disable-rpath"
 
 PARALLEL_MAKE = ""
 
diff --git a/packages/obexftp/obexftp_0.22.bb b/packages/obexftp/obexftp_0.22.bb
new file mode 100644 (file)
index 0000000..89e10a7
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "OBEX Ftp Client based on openobex."
+SECTION = "console/network"
+HOMEPAGE = "http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+LICENSE = "GPL"
+DEPENDS = "openobex bluez-libs libusb virtual/libiconv"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.bz2 \
+         "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-bluetooth \
+                --disable-swig \
+                --disable-perl \
+                --disable-python \
+                --disable-tcl \
+                --disable-ruby \
+                --disable-builddocs \
+                --disable-rpath \
+               "
+
+PARALLEL_MAKE = ""
+
+LEAD_SONAME = "libobexftp.so"
+
+do_stage() {
+       autotools_stage_all
+}
+