kexecboot: fix build of initramfs-kexecboot-image
authorThomas Kunze <thommycheck@gmx.de>
Sun, 3 Aug 2008 23:58:58 +0000 (23:58 +0000)
committerThomas Kunze <thommycheck@gmx.de>
Sun, 3 Aug 2008 23:58:58 +0000 (23:58 +0000)
packages/kexecboot/initramfs-kexecboot_1.0.bb [new file with mode: 0644]
packages/kexecboot/initramfs_kexecboot_1.0.bb [deleted file]

diff --git a/packages/kexecboot/initramfs-kexecboot_1.0.bb b/packages/kexecboot/initramfs-kexecboot_1.0.bb
new file mode 100644 (file)
index 0000000..e133741
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
+PR = "r6"
+RDEPENDS = "kexecboot"
+do_compile() {
+        cat > init.sh << EOF
+#!/bin/sh
+/bin/mount -t proc proc /proc
+/usr/bin/kexecboot -a 270 -i /dev/event0
+EOF
+}
+
+do_install() {
+        install -m 0755 ${S}/init.sh ${D}/init
+        install -d ${D}/proc
+        install -d ${D}/mnt
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/init /proc /mnt"
diff --git a/packages/kexecboot/initramfs_kexecboot_1.0.bb b/packages/kexecboot/initramfs_kexecboot_1.0.bb
deleted file mode 100644 (file)
index e133741..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
-PR = "r6"
-RDEPENDS = "kexecboot"
-do_compile() {
-        cat > init.sh << EOF
-#!/bin/sh
-/bin/mount -t proc proc /proc
-/usr/bin/kexecboot -a 270 -i /dev/event0
-EOF
-}
-
-do_install() {
-        install -m 0755 ${S}/init.sh ${D}/init
-        install -d ${D}/proc
-        install -d ${D}/mnt
-}
-
-PACKAGE_ARCH = "all"
-
-FILES_${PN} = "/init /proc /mnt"