mtools: do not link with X11 (from Poky)
authorMarcin Juszkiewicz <hrw@openembedded.org>
Tue, 8 Apr 2008 12:49:09 +0000 (12:49 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Tue, 8 Apr 2008 12:49:09 +0000 (12:49 +0000)
packages/mtools/files/no-x11.patch [new file with mode: 0644]
packages/mtools/mtools-native_3.9.9.bb
packages/mtools/mtools_3.9.9.bb

diff --git a/packages/mtools/files/no-x11.patch b/packages/mtools/files/no-x11.patch
new file mode 100644 (file)
index 0000000..300f43f
--- /dev/null
@@ -0,0 +1,19 @@
+---
+ Makefile.in |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- mtools-3.9.9.orig/Makefile.in
++++ mtools-3.9.9/Makefile.in
+@@ -128,11 +128,11 @@ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+ CFLAGS = $(CPPFLAGS) $(DEFS) $(MYCFLAGS) -I. @extraincludedir@ -I@srcdir@ $(USERCFLAGS) 
+ CXXFLAGS  = $(CPPFLAGS) $(DEFS) $(MYCXXFLAGS) -I. @extraincludedir@ -I@srcdir@ $(USERCFLAGS) 
+ LINK      = $(CC) $(LDFLAGS) $(USERLDFLAGS) @extralibdir@
+ ALLLIBS   = $(USERLDLIBS) $(MACHDEPLIBS) $(SHLIB) $(LIBS)
+-X_LDFLAGS = $(X_EXTRA_LIBS) $(X_LIBS) $(X_PRE_LIBS) -lXau -lX11 $(LIBS) 
++X_LDFLAGS = $(X_EXTRA_LIBS) $(X_LIBS) $(X_PRE_LIBS) $(LIBS)
+ X_CCFLAGS = $(X_CFLAGS) $(CFLAGS)
+ all:    mtools $(LINKS) mkmanifest @FLOPPYD@
+ %.o: %.c
index 16a0c37..c82f740 100644 (file)
@@ -3,6 +3,5 @@
 # Released under the MIT license (see packages/COPYING)
 
 require mtools_${PV}.bb
-S="${WORKDIR}/mtools-${PV}"
 
 inherit autotools native
index 7c872a1..eca9909 100644 (file)
@@ -5,12 +5,15 @@
 DESCRIPTION="Mtools is a collection of utilities for accessing MS-DOS disks from Unix without mounting them."
 HOMEPAGE="http://mtools.linux.lu"
 LICENSE="GPL"
-PR = "r2"
+PR = "r4"
 
 SRC_URI="http://mtools.linux.lu/mtools-${PV}.tar.gz \
        file://mtools-makeinfo.patch;patch=1 \
-       file://mtools.patch;patch=1"
+       file://mtools.patch;patch=1 \
+       file://no-x11.patch;patch=1"
 
-#DEPENDS = "tetex-native"
+S = "${WORKDIR}/mtools-${PV}"
 
 inherit autotools
+
+EXTRA_OECONF = "--without-x"