[asu] Create ASU/Om2008.8 task and image (to ease removing Qtopia from it)
authorHolger Hans Peter Freyther <zecke@openmoko.org>
Sun, 3 Aug 2008 12:08:29 +0000 (14:08 +0200)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Sun, 26 Oct 2008 14:52:19 +0000 (15:52 +0100)
    Create a separate task-openmoko-asu and openmoko-asu-image. The image
    is installing task-openmoko-asu and task-openmoko-qtopia-x11. It should
    be fairly easy to remove Qtopia for the people that want that.

packages/images/openmoko-asu-image.bb [new file with mode: 0644]
packages/tasks/task-openmoko-asu.bb [new file with mode: 0644]

diff --git a/packages/images/openmoko-asu-image.bb b/packages/images/openmoko-asu-image.bb
new file mode 100644 (file)
index 0000000..2a8896c
--- /dev/null
@@ -0,0 +1,7 @@
+#------------------------------------------------------
+# Openmoko Qtopia/X11 Image Recipe
+#------------------------------------------------------
+
+require openmoko-minimal-image.bb
+
+IMAGE_INSTALL += "task-openmoko-asu"
diff --git a/packages/tasks/task-openmoko-asu.bb b/packages/tasks/task-openmoko-asu.bb
new file mode 100644 (file)
index 0000000..a815e22
--- /dev/null
@@ -0,0 +1,45 @@
+DESCRIPTION = "Openmoko: Om 2008.8 August Software Update"
+
+SECTION = "openmoko/base"
+ALLOW_EMPTY = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+LICENSE = "MIT"
+PR = "r2"
+
+inherit task
+
+PACKAGES = "task-openmoko-asu"
+RDEPENDS_task-openmoko-asu = "\
+  bluez-hcidump \
+  readline \
+  connman \
+  connman-plugin-connman-resolvconf \
+  connman-plugin-connman-dhclient \
+  connman-plugin-connman-80211 \
+  connman-script-dhclient \
+  e-wm \
+  illume \
+  illume-theme \
+  assassin \
+  diversity-daemon \
+  splinter \
+  ${XSERVER} \
+  xserver-kdrive-common \
+  xserver-nodm-init \
+  xauth \
+  xhost \
+  xset \
+  xrandr \
+  libnotify \
+  exposure \
+  etk-theme-ninja \
+  openmoko-community-repository \
+  assassin-thumbnail \
+  pyefl-sudoku \
+  \
+# For supporting the om2007.2 stack
+  openmoko-icon-theme-standard2 \
+  moko-gtk-engine \
+  settings-daemon \
+  openmoko-asu-om20072-support \
+"