bootchart 0.9: add the device part of bootchart, a neat way to view the boot process...
authorKoen Kooi <koen@openembedded.org>
Thu, 27 Apr 2006 11:55:26 +0000 (11:55 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 27 Apr 2006 11:55:26 +0000 (11:55 +0000)
read the recipe on how to use it

packages/bootchart/.mtn2git_empty [new file with mode: 0644]
packages/bootchart/bootchart_0.9.bb [new file with mode: 0644]

diff --git a/packages/bootchart/.mtn2git_empty b/packages/bootchart/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/bootchart/bootchart_0.9.bb b/packages/bootchart/bootchart_0.9.bb
new file mode 100644 (file)
index 0000000..b9b4029
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "Bootchart is a tool for performance analysis and visualization of the GNU/Linux boot process."
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.bootchart.org/"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
+
+
+#this only installs the loggers, you will need to run the renderers on your workstation 
+#boot with 'init=/sbin/bootchartd' and do '/sbin/bootchartd stop' to end the logging
+
+#needed for a real /bin/sh and /bin/sleep
+DEPENDS = "bash coreutils"
+RDEPENDS = "bash coreutils"
+
+#this is a plain shell script
+PACKAGE_ARCH = "all"
+
+SRC_URI = "file://bootchart \
+          file://bootchartd \
+          file://bootchartd.conf"
+
+               
+do_install() {
+       install -d ${D}/sbin
+       install -d ${D}/etc
+       install -m 755 ${WORKDIR}/bootchart ${D}/sbin
+       install -m 755 ${WORKDIR}/bootchartd ${D}/sbin
+       install -m 644 ${WORKDIR}/bootchart ${D}/etc
+}
+