meta packages: Create a new class, clean up the code and add correct dependencies...
authorRichard Purdie <rpurdie@rpsys.net>
Wed, 4 Apr 2007 23:06:24 +0000 (23:06 +0000)
committerRichard Purdie <rpurdie@rpsys.net>
Wed, 4 Apr 2007 23:06:24 +0000 (23:06 +0000)
14 files changed:
classes/meta.bbclass [new file with mode: 0644]
packages/meta/meta-e-x11-core.bb
packages/meta/meta-e-x11.bb
packages/meta/meta-gpe-extras.bb
packages/meta/meta-gpe.bb
packages/meta/meta-gpephone.bb
packages/meta/meta-opie-all.bb
packages/meta/meta-opie.bb
packages/meta/meta-sdk-sbox.bb
packages/meta/meta-sdk.bb
packages/meta/meta-sdl.bb
packages/meta/meta-sectest-gpe.bb
packages/meta/meta-toolchain.bb
packages/meta/xbase-clients.bb

diff --git a/classes/meta.bbclass b/classes/meta.bbclass
new file mode 100644 (file)
index 0000000..f7d41ee
--- /dev/null
@@ -0,0 +1,5 @@
+
+PACKAGES = ""
+
+BUILD_ALL_DEPS = "1"
+do_build[recrdeptask] = "do_build"
\ No newline at end of file
index 21960c6..cdc7640 100644 (file)
@@ -4,7 +4,7 @@ ALLOW_EMPTY = "1"
 PR = "r1"
 PACKAGE_ARCH = "all"
 LICENSE = "MIT"
-BUILD_ALL_DEPS="1"
 
-DEPENDS = "task-e-x11-core"
 RDEPENDS = "task-e-x11-core"
+
+inherit meta
\ No newline at end of file
index 0edfd43..1182b0c 100644 (file)
@@ -4,7 +4,7 @@ ALLOW_EMPTY = "1"
 PR = "r1"
 PACKAGE_ARCH = "all"
 LICENSE = "MIT"
-BUILD_ALL_DEPS = "1"
 
-DEPENDS = "task-e-x11"
 RDEPENDS = "task-e-x11"
+
+inherit meta
\ No newline at end of file
index 0adb7c4..b4425a6 100644 (file)
@@ -2,15 +2,10 @@ DESCRIPTION = "Meta-package of extra applications for the GPE Palmtop Environmen
 LICENSE = "MIT"
 PR="r2"
 
-ALLOW_EMPTY = "1"
-BUILD_ALL_DEPS = "1"
-
-DEPENDS = "task-gpe"
-
 RDEPENDS = "\
     gpe-task-apps-extra \
     gpe-task-games \
     gpe-task-web \
     gpe-task-desktopapps"
 
-
+inherit meta
index 2360db4..d6e199f 100644 (file)
@@ -2,11 +2,6 @@ DESCRIPTION = "Meta-package for GPE Palmtop Environment"
 LICENSE = "MIT"
 PR = "r42"
 
-ALLOW_EMPTY = "1"
-BUILD_ALL_DEPS = "1"
-
-DEPENDS = "task-gpe"
-
 RDEPENDS = "\
     gpe-base-depends \
     gpe-task-base \
@@ -15,3 +10,5 @@ RDEPENDS = "\
     gpe-task-apps \
     gpe-task-games \
     gpe-task-connectivity"
+
+inherit meta
index 96e393b..a0bd51e 100644 (file)
@@ -2,14 +2,11 @@ DESCRIPTION = "Meta-package for GPE Palmtop Environment Phone packages"
 LICENSE = "MIT"
 PR = "r0"
 
-ALLOW_EMPTY = "1"
-BUILD_ALL_DEPS = "1"
-
-DEPENDS = "task-gpe"
-
 RDEPENDS = "\
     gpe-base-depends \
     gpephone-task-base \
     gpephone-task-settings \
     gpephone-task-pim \
     gpeph-task-connectivity"
+
+inherit meta
\ No newline at end of file
index 6f315d3..ccdbbe9 100644 (file)
@@ -1,14 +1,16 @@
 DESCRIPTION = "Meta-package for QPE stuff"
 SECTION = "opie/base"
-ALLOW_EMPTY = "1"
-PACKAGE_ARCH = "all"
 LICENSE = "MIT"
-DEPENDS = "task-qpe"
 PR = "r3"
 
-BUILD_ALL_DEPS = "1"
-
-RDEPENDS = "task-qpe-applets task-qpe-games task-qpe-inputmethods \
-       task-qpe-multimedia task-qpe-emulators task-qpe-applications \
-       task-qpe-fonts task-qpe-settings"
+RDEPENDS = " \
+    task-qpe-applets \
+    task-qpe-games \
+    task-qpe-inputmethods \
+    task-qpe-multimedia \
+    task-qpe-emulators \
+    task-qpe-applications \
+    task-qpe-fonts \
+    task-qpe-settings"
 
+inherit meta
\ No newline at end of file
index 1158d85..6a9c35c 100644 (file)
@@ -1,12 +1,8 @@
 DESCRIPTION = "Meta-package for Opie"
 SECTION = "opie/base"
-ALLOW_EMPTY = "1"
 PR = "r34"
-PACKAGE_ARCH = "all"
 LICENSE = "MIT"
-BUILD_ALL_DEPS = "1"
 
-DEPENDS = "task-opie"
 RDEPENDS = "task-opie-applets task-opie-apps task-opie-base \
             task-opie-base-applets task-opie-base-apps \
             task-opie-base-decorations task-opie-base-inputmethods \
@@ -19,3 +15,4 @@ RDEPENDS = "task-opie-applets task-opie-apps task-opie-base \
             task-opie-multimedia task-opie-pim task-opie-settings \
             task-opie-styles task-opie-todayplugins task-opie-wlan"
 
+inherit meta
\ No newline at end of file
index 0642d49..a586972 100644 (file)
@@ -2,9 +2,7 @@ DESCRIPTION = "Meta package for a Scratchbox SDK"
 LICENSE = "MIT"
 PR = "r2"
 
-PACKAGES = ""
-
-inherit rootfs_ipk sdk debian
+inherit rootfs_ipk sdk meta
 
 SDK_DIR = "${WORKDIR}/sdk"
 SDK_OUTPUT = "${SDK_DIR}/image"
@@ -23,8 +21,6 @@ TARGET_INSTALL = "\
 
 DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native sed-native"
 RDEPENDS = "${TARGET_INSTALL}"
-BUILD_ALL_DEPS = "1"
-
 
 IPKG_TARGET = "ipkg-cl -f ${SDK_DIR}/ipkg-target.conf -o ${SDK_OUTPUT}/${prefix}"
 
@@ -92,4 +88,5 @@ EOF
 }
 
 do_populate_sdk[nostamp] = "1"
+do_populate_sdk[recrdeptask] = "do_package_write"
 addtask populate_sdk before do_build after do_install
index 7bf8606..e498583 100644 (file)
@@ -3,9 +3,7 @@ LICENSE = "MIT"
 DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native sed-native"
 PR = "r11"
 
-PACKAGES = ""
-
-inherit sdk
+inherit sdk meta
 
 SDK_DIR = "${WORKDIR}/sdk"
 SDK_OUTPUT = "${SDK_DIR}/image"
@@ -18,6 +16,7 @@ HOST_INSTALL = "\
     binutils-cross-sdk \
     gcc-cross-sdk \
     gdb-cross"
+
 TARGET_INSTALL = "\
     task-sdk-base \
     task-sdk-opie \
@@ -26,7 +25,6 @@ TARGET_INSTALL = "\
     task-sdk-gpe"
 
 RDEPENDS = "${TARGET_INSTALL} ${HOST_INSTALL}"
-BUILD_ALL_DEPS = "1"
 
 do_populate_sdk() {
        touch ${DEPLOY_DIR_IPK}/Packages
@@ -99,4 +97,5 @@ EOF
 }
 
 do_populate_sdk[nostamp] = "1"
+do_populate_sdk[recrdeptask] = "do_package_write"
 addtask populate_sdk before do_build after do_install
index cb19cb6..a1ab391 100644 (file)
@@ -1,15 +1,7 @@
 DESCRIPTION = "Meta-package for SDL"
 LICENSE = "MIT"
-RDEPENDS = "task-sdl-libs task-sdl-games task-sdl-emulators"
 PR = "r2"
 
-ALLOW_EMPTY = "1"
-BUILD_ALL_DEPS = "1"
-
-# no need to add libsdl as all libsdl-* already rdepend on it
-RDEPENDS_task-sdl-libs = "libsdl-gfx libsdl-image libsdl-mixer libsdl-ttf libsdl-net"
-
-RDEPENDS_task-sdl-games = "abuse freedroid lbreakout2 openttd prboom quake1 rott supertux xmame"
-
-RDEPENDS_task-sdl-emulators = "dgen-sdl e-uae frodo snes9x"
+RDEPENDS = "task-sdl-libs task-sdl-games task-sdl-emulators"
 
+inherit meta
\ No newline at end of file
index 70bcfc4..a73559a 100644 (file)
@@ -2,11 +2,6 @@ DESCRIPTION = "Meta-package for GPE Security Testing Image"
 LICENSE = "MIT"
 PR = "r6"
 
-ALLOW_EMPTY = "1"
-BUILD_ALL_DEPS = "1"
-
-DEPENDS = "task-gpe"
-
 RDEPENDS = "\
     gpe-task-base \
     gpe-base-depends \
@@ -14,3 +9,5 @@ RDEPENDS = "\
     gpe-task-settings \
     gpe-task-pim \
     gpe-task-sectest"
+
+inherit meta
\ No newline at end of file
index 7995ac3..35dbe9f 100644 (file)
@@ -3,9 +3,7 @@ LICENSE = "MIT"
 DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native sed-native"
 PR = "r0"
 
-PACKAGES = ""
-
-inherit sdk
+inherit sdk meta
 
 SDK_DIR = "${WORKDIR}/sdk"
 SDK_OUTPUT = "${SDK_DIR}/image"
@@ -23,7 +21,6 @@ TARGET_INSTALL = "\
     "
 
 RDEPENDS = "${TARGET_INSTALL} ${HOST_INSTALL}"
-BUILD_ALL_DEPS = "1"
 
 do_populate_sdk() {
        touch ${DEPLOY_DIR_IPK}/Packages
@@ -96,4 +93,5 @@ EOF
 }
 
 do_populate_sdk[nostamp] = "1"
+do_populate_sdk[recrdeptask] = "do_package_write"
 addtask populate_sdk before do_build after do_install
index 4297440..5f3c640 100644 (file)
@@ -1,4 +1,5 @@
 DESCRIPTION = "Basic X clients (meta package)"
+LICENSE = "MIT"
 PR = "r1"
 
 ALLOW_EMPTY = "1"
@@ -9,4 +10,4 @@ RDEPENDS = 'xauth \
        xmodmap \
        xrdb \
        xset'
-LICENSE = "MIT"
+