wesnoth: add a package for the current svn version (thanks Johannes Schauer)
authorJan Lübbe <jluebbe@debian.org>
Thu, 29 Nov 2007 15:55:38 +0000 (15:55 +0000)
committerJan Lübbe <jluebbe@debian.org>
Thu, 29 Nov 2007 15:55:38 +0000 (15:55 +0000)
conf/distro/include/sane-srcrevs.inc
packages/wesnoth/.mtn2git_empty [new file with mode: 0644]
packages/wesnoth/wesnoth_svn.bb [new file with mode: 0644]

index df8ebd2..df4be2d 100644 (file)
@@ -123,6 +123,7 @@ SRCREV_pn-tmut ?= "60"
 SRCREV_pn-webkit-gtk ?= "27222"
 SRCREV_pn-webkit-qt ?= "27222"
 SRCREV_pn-webkit-qtopia ?= "27222"
+SRCREV_pn-wesnoth ?= "22021"
 SRCREV_pn-xoo ?= "1623"
 SRCREV_pn-mplayer ?= "24587"
 SRCREV_pn-networkmanager ?= "2887"
diff --git a/packages/wesnoth/.mtn2git_empty b/packages/wesnoth/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/wesnoth/wesnoth_svn.bb b/packages/wesnoth/wesnoth_svn.bb
new file mode 100644 (file)
index 0000000..430abe7
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "fantasy turn-based strategy game"
+PV = "0.01+svnr${SRCREV}"
+PR = "r1"
+SECTION = "games"
+LICENSE = "GPL"
+DEPENDS += "libsdl-image libsdl-mixer libsdl-net"
+SRC_URI = "svn://svn.gna.org/svn/wesnoth;module=trunk;proto=http"
+
+EXTRA_OECONF += " --enable-tinygui --disable-python --enable-lite --enable-lowmem"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+addtask autogen after do_patch before do_configure
+
+do_autogen() {
+        cd ${WORKDIR}/trunk/ && ./autogen.sh --host=armv4t-angstrom-linux-gnueabi
+}