otpkeygen 1.3.0: one-time pad password generator for OPIE
authorMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 16 Feb 2006 11:20:37 +0000 (11:20 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 16 Feb 2006 11:20:37 +0000 (11:20 +0000)
packages/otpkeygen/.mtn2git_empty [new file with mode: 0644]
packages/otpkeygen/otpkeygen_1.3.0.bb [new file with mode: 0644]

diff --git a/packages/otpkeygen/.mtn2git_empty b/packages/otpkeygen/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/otpkeygen/otpkeygen_1.3.0.bb b/packages/otpkeygen/otpkeygen_1.3.0.bb
new file mode 100644 (file)
index 0000000..cae160e
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "OTP S/Key password generator"
+SECTION = "opie/applications"
+HOMEPAGE = "http://www.bitrot.de/pda_otpkeygen.html"
+AUTHOR = "Thomas Driemeyer <thomas@bitrot.de>"
+LICENSE = "GPL"
+APPTYPE="binary"
+
+SRC_URI = "ftp://ftp.bitrot.de/pub/otpkeygen/otpkeygen-src_${PV}.tar.gz"
+
+S = "${WORKDIR}/src/"
+
+inherit palmtop
+
+do_configure_prepend() {
+    cd ${S} && qmake -project
+}
+
+do_install() {
+
+    install -d ${D}${palmtopdir}/apps/Applications
+    install -d ${D}${palmtopdir}/bin/
+    install -d ${D}${palmtopdir}/pics/
+
+    install -m 0755 ${WORKDIR}/bin/otpkeygen ${D}${palmtopdir}/bin/
+    install -m 0644 ${WORKDIR}/apps/Applications/otpkeygen.desktop ${D}${palmtopdir}/apps/Applications/
+    install -m 0644 ${WORKDIR}/pics/otpkeygen.png ${D}${palmtopdir}/pics/
+}