ltp: Fix two QA issues; .debug leak and GNU_HASH.
authorLeon Woestenberg <leon@sidebranch.com>
Sun, 29 Mar 2009 15:14:51 +0000 (17:14 +0200)
committerLeon Woestenberg <leon@sidebranch.com>
Sun, 29 Mar 2009 15:16:42 +0000 (17:16 +0200)
Thanks to Koen for the hint on GNU_HASH.

recipes/ltp/ltp_20090131.bb

index 9026ac5..61775cf 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://ltp.sourceforge.net"
 LICENSE = "GPL"
 SECTION = "console/utils"
 DEPENDS = "zip-native"
-PR = "r2"
+PR = "r3"
 
 inherit autotools
 
@@ -21,28 +21,17 @@ S = "${WORKDIR}/ltp-full-${PV}"
 
 EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
 
-FILES_${PN}-dbg =  "${libexecdir}/ltp/*/*/*/*/*/.debug"
+FILES_${PN}-dbg  = "${libexecdir}/ltp/*/*/*/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/.debug"
 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/.debug"
 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/.debug"
 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/.debug"
 FILES_${PN}-dbg += "${libexecdir}/ltp/*/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/trigo/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/iperb/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/exp_log/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/power/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/bessel/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/abs/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/atof/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/nextafter/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/fptests/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/f00f/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/crash/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/pan/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/ipv6/*/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/rpc/rpc01/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/bin/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/syscalls/*/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/mem/*/.debug"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
 
 do_compile(){
         oe_runmake CROSS_COMPILE=${HOST_PREFIX}