gpsd: add /etc/default/gpsd config file - close #2465
authorJake Morrison <jake@cogini.com>
Mon, 11 Jun 2007 15:32:24 +0000 (15:32 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 11 Jun 2007 15:32:24 +0000 (15:32 +0000)
packages/gpsd/files/gpsd
packages/gpsd/gpsd.inc
packages/gpsd/gpsd_2.28.bb
packages/gpsd/gpsd_2.32.bb
packages/gpsd/gpsd_2.33.bb
packages/gpsd/gpsd_2.34.bb

index 289896f..2cf26c5 100755 (executable)
@@ -16,6 +16,8 @@ GPS_DEV="/dev/ttyS3"
 RETVAL=0
 prog="gpsd"
 
+test -f /etc/default/$prog && . /etc/default/$prog
+
 start() {
        # Start daemons.
        echo -n "Starting $prog: "
index f7c1de2..7fa05d4 100644 (file)
@@ -10,6 +10,7 @@ EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11  \
                --disable-python  "
 
 SRC_URI = "http://download.berlios.de/gpsd/gpsd-${PV}.tar.gz \
+           file://gpsd-default \
            file://gpsd"
 
 inherit autotools update-rc.d
@@ -40,6 +41,8 @@ do_install_append() {
         install -d ${D}/${sysconfdir}/init.d
         install -d ${D}/dev
         install -m 0755 ${WORKDIR}/gpsd ${D}/${sysconfdir}/init.d/
+        install -d ${D}/${sysconfdir}/default
+        install -m 0644 ${WORKDIR}/gpsd-default ${D}/${sysconfdir}/default/gpsd
 }
 
 PACKAGES =+ "libgps"
index 1a5e608..12ef7f4 100644 (file)
@@ -1,2 +1,2 @@
 require gpsd.inc
-PR = "r1"
+PR = "r2"
index 4d07974..1a5e608 100644 (file)
@@ -1,2 +1,2 @@
 require gpsd.inc
-PR = "r0"
+PR = "r1"
index f61c613..02aef51 100644 (file)
@@ -2,4 +2,4 @@ require gpsd.inc
 
 DEPENDS = "ncurses"
 
-PR = "r0"
+PR = "r1"
index 58e9ebe..885a41d 100644 (file)
@@ -1,3 +1,3 @@
 require gpsd.inc
 
-PR = "r0"
+PR = "r1"