fakeroot: update to 1.7.1 to fix image generation on some setups
authorAndreas Oberritter <obi@opendreambox.org>
Wed, 22 Oct 2008 12:50:52 +0000 (14:50 +0200)
committerAndreas Oberritter <obi@opendreambox.org>
Wed, 22 Oct 2008 12:50:52 +0000 (14:50 +0200)
packages/fakeroot/fakeroot-native_1.7.1.bb [new file with mode: 0644]
packages/fakeroot/fakeroot_1.7.1.bb [new file with mode: 0644]
packages/fakeroot/files/work-with-older-libtool.patch [new file with mode: 0644]

diff --git a/packages/fakeroot/fakeroot-native_1.7.1.bb b/packages/fakeroot/fakeroot-native_1.7.1.bb
new file mode 100644 (file)
index 0000000..8a54d64
--- /dev/null
@@ -0,0 +1,18 @@
+require fakeroot_${PV}.bb
+inherit native
+RDEPENDS = "util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
diff --git a/packages/fakeroot/fakeroot_1.7.1.bb b/packages/fakeroot/fakeroot_1.7.1.bb
new file mode 100644 (file)
index 0000000..f2708a1
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Gives a fake root environment"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+FILE_PR = "r2"
+
+SRC_URI = "\
+  ftp://ftp.gentoo.mesh-solutions.com/mirrors/gentoo/distfiles/fakeroot_1.7.1.tar.gz \
+  file://work-with-older-libtool.patch;patch=1 \
+"
+
+inherit autotools
+
+do_stage() {
+        install -d ${STAGING_INCDIR}/fakeroot
+        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+        autotools_stage_all
+}
diff --git a/packages/fakeroot/files/work-with-older-libtool.patch b/packages/fakeroot/files/work-with-older-libtool.patch
new file mode 100644 (file)
index 0000000..05f9be8
--- /dev/null
@@ -0,0 +1,11 @@
+--- fakeroot-1.7.1/configure.ac.orig   2007-08-09 16:03:34.000000000 -0500
++++ fakeroot-1.7.1/configure.ac        2007-08-09 18:26:11.000000000 -0500
+@@ -7,8 +7,6 @@
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+ AM_PROG_LIBTOOL
+-LT_INIT
+-LT_LANG(C)
+ AC_ARG_WITH([ipc],
+           AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],