apr-0.9.7,apr-util-0.9.7: replace unretrieveable 1.1.x versions
authorMustafa Yuecel <yuecelm@ee.ethz.ch>
Sun, 12 Mar 2006 19:19:12 +0000 (19:19 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sun, 12 Mar 2006 19:19:12 +0000 (19:19 +0000)
  - subversion needs only 0.9.7
  - avoid execution of gen_uri_delims (place uri_delims.h directly)
  - add APACHE_MIRROR to conf/bitbake.conf

conf/bitbake.conf
packages/apr/apr-util_0.9.7.bb [new file with mode: 0644]
packages/apr/apr-util_1.1.2.bb [deleted file]
packages/apr/apr_0.9.7.bb [new file with mode: 0644]
packages/apr/apr_1.1.1.bb [deleted file]
packages/apr/files/.mtn2git_empty [new file with mode: 0644]
packages/apr/files/gen_uri_delims.patch [new file with mode: 0644]
packages/apr/files/uri_delims.h [new file with mode: 0644]

index 36d4c33..6afd6ca 100644 (file)
@@ -306,6 +306,7 @@ FREEBSD_MIRROR = "ftp://ftp.freebsd.org/pub/FreeBSD/"
 HANDHELDS_CVS = "cvs://anoncvs:anoncvs@anoncvs.handhelds.org/cvs"
 FREEDESKTOP_CVS = "cvs://anoncvs:anoncvs@anoncvs.freedesktop.org/cvs"
 GENTOO_MIRROR = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles"
+APACHE_MIRROR = "http://www.apache.org/dist"
 
 # You can use the mirror of your country to get faster downloads by putting
 #  export DEBIAN_MIRROR = "ftp://ftp.de.debian.org/debian/pool"
diff --git a/packages/apr/apr-util_0.9.7.bb b/packages/apr/apr-util_0.9.7.bb
new file mode 100644 (file)
index 0000000..597c0ee
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
+LICENSE = "Apache"
+HOMEPAGE = "http://apr.apache.org"
+
+PR = "r0"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+           file://gen_uri_delims.patch;patch=1 \
+           file://uri_delims.h"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+  cp ${S}/../uri_delims.h ${S}/uri/. 
+  oe_runconf
+}
+
+do_stage() {
+  oe_libinstall -a -so -C .libs libaprutil-0 ${STAGING_LIBDIR}
+}
diff --git a/packages/apr/apr-util_1.1.2.bb b/packages/apr/apr-util_1.1.2.bb
deleted file mode 100644 (file)
index 1140ce2..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Apache Portable Runtime (APR) companion library"
-SECTION = "libs"
-DEPENDS = "apr expat gdbm"
-MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
-LICENSE = "Apache"
-HOMEPAGE = "http://apr.apache.org"
-
-PR = "r0"
-
-# apache mirrors?
-SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/apr/${P}.tar.gz"
-
-EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
-
-inherit autotools lib_package binconfig
-
-do_configure() {
-  oe_runconf
-}
-
-do_stage() {
-  oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
-}
diff --git a/packages/apr/apr_0.9.7.bb b/packages/apr/apr_0.9.7.bb
new file mode 100644 (file)
index 0000000..4c23610
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Apache Portable Runtime (APR) library"
+SECTION = "libs"
+MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
+LICENSE = "Apache"
+HOMEPAGE = "http://apr.apache.org"
+
+PR = "r0"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+  oe_runconf
+}
+
+do_stage() {
+  oe_libinstall -a -so -C .libs libapr-0 ${STAGING_LIBDIR}
+}
diff --git a/packages/apr/apr_1.1.1.bb b/packages/apr/apr_1.1.1.bb
deleted file mode 100644 (file)
index ac5d378..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "Apache Portable Runtime (APR) library"
-SECTION = "libs"
-MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
-LICENSE = "Apache"
-HOMEPAGE = "http://apr.apache.org"
-
-PR = "r0"
-
-# apache mirrors?
-SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/apr/${P}.tar.bz2"
-
-inherit autotools lib_package binconfig
-
-do_configure() {
-  oe_runconf
-}
-
-do_stage() {
-  oe_libinstall -a -so -C .libs libapr-1 ${STAGING_LIBDIR}
-}
diff --git a/packages/apr/files/.mtn2git_empty b/packages/apr/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/apr/files/gen_uri_delims.patch b/packages/apr/files/gen_uri_delims.patch
new file mode 100644 (file)
index 0000000..57bc15a
--- /dev/null
@@ -0,0 +1,7 @@
+--- apr-util-0.9.7/uri/Makefile.in.old 2006-03-11 23:01:09.000000000 +0100
++++ apr-util-0.9.7/uri/Makefile.in     2006-03-11 23:01:28.000000000 +0100
+@@ -15,4 +15,3 @@
+ apr_uri.lo: uri_delims.h apr_uri.c
+ uri_delims.h: gen_uri_delims
+-      ./gen_uri_delims > uri_delims.h
diff --git a/packages/apr/files/uri_delims.h b/packages/apr/files/uri_delims.h
new file mode 100644 (file)
index 0000000..0c855bf
--- /dev/null
@@ -0,0 +1,16 @@
+/* this file is automatically generated by gen_uri_delims, do not edit */
+static const unsigned char uri_delims[256] = {
+    T_NUL,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,T_HASH,0,0,0,0,
+    0,0,0,0,0,0,0,T_SLASH,0,0,0,0,0,0,0,0,0,0,T_COLON,0,
+    0,0,0,T_QUESTION,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
+    0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 
+};