gimp_2.3.10.bb : new version, DEFAULT_PREFERENCE=-1 at moment as it starts to
authorGraeme Gregory <dp@xora.org.uk>
Thu, 6 Jul 2006 10:25:33 +0000 (10:25 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 6 Jul 2006 10:25:33 +0000 (10:25 +0000)
load but at end of splash screen quits with message gimp-2.3: terminated: Aborted. This is not OOM.

packages/gimp/gimp_2.3.10.bb [new file with mode: 0644]

diff --git a/packages/gimp/gimp_2.3.10.bb b/packages/gimp/gimp_2.3.10.bb
new file mode 100644 (file)
index 0000000..e469f3c
--- /dev/null
@@ -0,0 +1,23 @@
+DESCRIPTION =  "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE =     "http://www.gimp.org"
+LICENSE =      "GPL"
+MAINTAINER =   "Koen Kooi <koen@handhelds.org>"
+
+SRC_URI =      "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
+                 file://configure-libwmf.patch;patch=1"
+
+DEPENDS =      "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools pkgconfig
+#Don't laugh, this just builds a threaded gimp
+EXTRA_OECONF =         " --disable-gtktest \
+               --disable-print \
+               --disable-python \
+               --enable-mp \
+               --without-libwmf"
+
+do_configure_append() {
+       find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+}