gcc-4.1.1: fix problem with backslash in sed command
authorPhil Blundell <philb@gnu.org>
Sat, 18 Oct 2008 08:13:33 +0000 (09:13 +0100)
committerPhil Blundell <philb@gnu.org>
Sat, 18 Oct 2008 08:13:33 +0000 (09:13 +0100)
packages/gcc/gcc-4.1.1.inc
packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch [new file with mode: 0644]

index 92ee2d7..ac8a4a8 100644 (file)
@@ -29,6 +29,7 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
         file://gcc-ignore-cache.patch;patch=1 \
         file://gcc-4.1.1-e300cx.patch;patch=1 \
         file://pr34130.patch;patch=1 \
+       file://sed-fixinc-backslash.patch;patch=1 \
        "
 
 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch b/packages/gcc/gcc-4.1.1/sed-fixinc-backslash.patch
new file mode 100644 (file)
index 0000000..9aff951
--- /dev/null
@@ -0,0 +1,18 @@
+2006-09-06  Matthias Klose  <doko@debian.org>
+
+        * Makefile.in (s-macro_list): Conform to POSIX rules in single quoted
+        strings.
+
+--- s/gcc/Makefile.in~ 2008-10-18 08:53:56.000000000 +0100
++++ s/gcc/Makefile.in  2008-10-18 08:55:16.000000000 +0100
+@@ -3146,8 +3146,8 @@
+ macro_list: s-macro_list; @true
+ s-macro_list : $(GCC_PASSES) 
+       echo | $(GCC_FOR_TARGET) -E -dM - | \
+-        sed -n 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p ; \
+-              s/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
++        sed -n -e 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p' \
++              -e 's/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
+         sort -u > tmp-macro_list
+       $(SHELL) $(srcdir)/../move-if-change tmp-macro_list macro_list
+       $(STAMP) s-macro_list